Rain Update Problem

I am using the trial version and wanted to correct an error in the rain amount for one day. I found the FAQ that deals with this, but before trying that I went to the screen below and corrected the date. I found that the amount was still present in other areas, so that prompted me to investigate more, which led me to the FAQ on correcting rain amounts. However, though I get the exact screens as shown in the FAQ section and follow the directions to “use corrected amount” and then “save,” the data doesn’t change. I an exit out, return to those same screens and the wrong amount is still there. I can’t seem to make the program “save” the new amount. What’s more, the data I was trying to change was a single day, wanting to change it to zero rain. Now, I am showing NO rain for any of the days in March when I click on the “detailed” rain chart, found by clicking on the “rainfall” section on the main screen.

Why can’t I save the new amount? I’ve been sure to click on “ok” on each screen to exit them, then even exit the entire program and bring it back up, but that doesn’t work. Any ideas?


Here is the date I want to change. After I follow the directions in the FAQ, when I come back to this screen, it looks the same with no changes.

Now, here is how my “detailed” rain report looks. Now, neither value for the 22 or the 23 show up. I should still have 0.85 inches for the 22.

When entering data in for rain, please ensure you use a decimal point even if 0.0" - I hope this helps fix the problem :wink:

you need to use:
view, averages/extremes, correct/edit the data
and there you can edit the rain amount for the day needed
there is a FAQ on this

Would that be the FAQ here?

Yes, I found that one as I mentioned and I have followed it as best I can, but when I click on “use new data” and “save,” the new data is NOT saved. When I click out of those screens then back again, the old data is still there, unchanged. I will try, though I thought I did, using a decimal amount, 0.0 and see if that works and let you know.


OK, see the screen shot below. I have circled the rain amount for March 23. I changed it to zero, where it had 0.02 inches of rain before. I then click on “use corrected amount,” number 1 in the shot, then “save,” number 2. I then exit out, but when I return to this screen, 0.02 inches of rain appear back in the date for March 23. I can’t get the program to save the zero amount!

Very weird! (and yes, to the person who suggested it, you can clearly see that the amount I corrected has a decimal between the zeros)

I shall continue with this! #-o


.zip and email me your data file month32008.inf
and I will test/try here

I don’t know if you noticed this, nor do I know if it makes a difference. Just thought I’d point it out, as a lot of trial programs have limited functionability.

the trial version has no limitations

If Dr Bob could .zip and email me his data file, I can test/check here

OK, I’ll send it to you within the next day


This morning WD started recording rain, though it was sunny. My Ultimeter 2100 did not show any rain, so I’m pretty sure this is a software problem. WD was “locked up” when I checked it this morning. I want to reset the rain to zero, but can’t figure out how to do that. See the screen shot below as to what I’ve tried. I’ve loaded the data file and corrected the 0.098 inches to 0.000 inches, but the total amount (rounded to 0.01 inches) still shows on the main screen. I click on “save” and “OK” to exit the screen. I’m not trying the “change the daily rain value” covered in the FAQ previously mentioned, I’m trying to tell WD to reset the current day’s rain to 0.000 since the amount recorded is an error. This value gets uploaded to weather underground and I’m trying to keep the error from being perpetuated throughout the day. Any ideas how to just tell WD there is NO rain today?


Perhaps Windy, we need a page for “today” to correct rain faults that are seen during the day because they
are usually an isolated single case on one day or during one hour, so 24 time slots and a chance to pick data in one hour that was a rogue value and then to correct the data in todays logfile automatically, then a link or statement to convert log to data and update last 31 days?

Then we may have chance to go back 1 or 2 days etc to correct a previous similar fault and correct mtd data.

I know in DrBob’s shot above, there is the list to after the fact to correct previous rain totals but you can’t do it on theday it happens, without shutting WD down, serious editing in Notepad or similar, and saving and starting WD and then immediately update data file and 31 days graph, and doesn’t always work.


to reset the current rain total (e.g today), go to control panel, barometer offset and rainfall setup
and set the needed rain totals for day/month/year

Thanks Windy - hadn’t used that yet - is it still functional on the actual day just after occurrence? Will it correct the MTD or is that another operation at the same time, I mean remove a value for the day then reduce the month total by the same?

OK . . . this is getting very frustrating.

I had rain tonight and noticed WD says I got over an inch, when my Ultimeter 2001 display says I got 0.29 inches. Huh?? I checked a couple of other weather stations in the area, and the 0.29 appears accurate. I can’t figure out why WD is recording so much more than my weather station is.

In the setup for the Ultimeter within WD, I have the 0.01 inch selected, which corresponds to my rain gauge. I do see this setting “rain is at the first part of the data.” How would I know? I’ve read through the manual for my Ultimeter and there is nothing about that that I can see. What does this mean?

There is another box, " *10 rain amount needed." What does this mean??

I still have about 15 days on my trial. WD seems to be a very sophisticated program, but the documentation is very sparse. For instance, I can find nothing regarding my question above in the online manual. It’s very basic and doesn’t begin to describe the details of the software.

Additionally, where in WD can I find parameters for the COM port? I see where I can set up the COM port number, but what about the baud? Data bits? Parity?? I can see no set up for these basic COM port parameters within WD. More often than not, WD will not connect with my com port and I have to manually change to another port number then back to COM 1 to get WD to talk to my weather station, and sometimes that doesn’t work. WD won’t work unless I set my COM port to 2400 baud, which by the way is not the default value my Vista system is using. WD never connected to my COM port until I manually switched the port to 2400 baud. Nothing in the setup information describes the need to do this.

And again, I got some bad data, with bizarre barometric data recorded. I went into the data correction setting, deleted the several lines of bad data, clicked on “save” but nothing doing. Bringing the data back up revealed it was still there. Multiple attempts to delete the lines of bad data were unsuccessful.

WD seems to be a really cool program, but there are just WAY to many problems. I’m two weeks into the trial and I have had to re-install WD about 6 times because of various problems I could not fix. Honestly, I think some of the problem relates to Vista, as I’ve had some serious issues related to it over the past couple of weeks. Vista seems to be the most unstable Windows platform yet.

I don’t expect answers to my rant, I’ve just become very frustrated at trying to get WD to work correctly. Since each reinstall recognizes that I have only a couple of weeks left in the trial version, I suspect some basic windows registry entries are perpetuating my problems.

Darn computers!! #-o


Bob, Brian will most likely be along to address your rain issue, as I know nothing about a Peet Bros station. It’s most likely a simple fix.

But, as a user of Weather Display of all most two years now, I will interject here that it is very, very rare, that there is ever any need to un-install and then re-install WD. It usually doesn’t accomplish a thing.

And yes, Vista add’s an additional layer of challenges (to be kind) to many things, not just Weather Display.
WD does have a learning curve, but it is worth the effort.

Edit: Just a guess, but after reading another prior post I’m betting you have electrical interference causing your false rain. This happens with the serial cable from the weather station to the computer. Make sure u don’t have it curled up behind the computer.

The easiest way to correct rain is to Right Click on the Rain section labeled “Rainfall” on the main window of Weather Display, then select on Offsets and Rainfall Adjustment on the label that pops up.

If your correcting just the current days rain then enter what the correct amount should be in the field labeled “Daily Rain Total” be sure to use 3 decimal places, and use the decimal. IE: 0.00
then click on Set next to the field you just entered data into. Then be sure to click on Yes button to Save the settings.
If your correcting yesterdays, current month, or the year to date, same procedure just use the appropriate fields on that same page.

OK . . . I feel better today!

I’m pretty sure much of my problem is a VISTA problem. :oops: It has become VERY unstable and I am currently in the process of backing up all my data files, etc and plan to reformat the drive and reinstall XP. It will be a very long while before I go back to VISTA.

I was having several lock-ups each day and I’m sure files/settings were becoming corrupted. That is why I was uninstalling and reinstalling WD, to make sure I had all fresh settings. I have been testing another software package and it reads the rain correctly. I’m still not sure why WD was giving me wrong data, but once I get XP installed, I’ll try WD again and see if things are better.

Wish me luck!! #-o

Good move, Vista has bad juju’s.

I am having the same issues as Bob is…and I run on XP…
Trying to update the year to date rain rate…and get it updated with a 0.0mm accuracy…on the graph it shows correct, but in the main screen still says the old number. I have been trying also to restart, close window, open window, but nothing works…

I have a registered version of WD.

Brian, please help…