"Quick fix" for GFS data problem

Hi Everybody,

As you may have seen from a couple of other threads, NOAA is having server problems and the GFS data is somewhat unreliable (especially today). See this:


This time, it’s not the “fault” of WXSIM, or of either downloading/processing system option (Chris McMahon’s or Sam Bohler’s). Chris’s system safely makes sure that the data are all good before it will post it, so with bad data slipping in, the last good set is now more than 24 hours old. Sam’s goes ahead and posts what it has, and it’s almost complete (95%, literally, as of the 06Z run), but WXSIM has been rejecting the data as “missing” if any part of it is missing. Of course, that would usually be appropriate, as we don’t want to use missing data!

However, with only one line at a time missing (none of these were consecutive in the sample I looked at), a solution is to average the two adjacent lines. That should be very close to OK, as it’s 3-hourly data. So, I’ve just posted an experimental fix, at


It’s labeled 12.10.1b, and should be able to handle the Bohler data as long as there are not two consecutive bad lines of data. please give this a try, by using the above file to replace the wxsim.exe you have, and also switch from McMahon to Bohler, temporarily. The Bohler site has not generally had heavy traffic, and I still want to default to McMahon as long as it’s available. Possibly Chris might come up with a workaround at some point as well. In any case, NOAA should have their problems fixed before too long.

Thanks for your patience! :slight_smile:


My last scheduled forecast for today just finished WITH NO ERROR. That

It’s working here with the Bohler data, Tom. :slight_smile: Thanks for the interim patch while NOAA-NWS gets things sorted out.

Tom I can confirm that using this version and Sam Bohler’s data it does indeed work now and a forecast ran without error and looks good.

Thanks for your hard work on this…


Hi Tom,

Thanks for the fix.

[quote]My last scheduled forecast for today just finished WITH NO ERROR. That

Great to hear it’s working! :slight_smile:

I have a feeling that some error reports I was getting recently have been due to these server problems. Hopefully, this will take care of these issues until NOAA gets their servers straightened out.

I did just post an even newer update (same labeling) at


I was concerned there could still be an issue if it encountered a bad line of GFS advection data. I think I’ve got a good protection in there against that possibility now, too.

Let me know how it goes!


Additional note: as of the 12Z run, there are still two lines out of 61 missing, but I think the version mentioned above takes care of that (and the first problem is 135 hours into the run anyway). I think even one bad line will prevent Chris’s data from updating, so maybe still with Bohler for the time being. Later, when NOAA gets this settled, I’d prefer to revert to Chris’s as he can handle the traffic better.


Hi Tom,

No luck for me sadly and it keeps failing in exactly the same place each time. Data downloads each time from Bohler and the data imports and the forecast run starts without any problems, however as soon as it gets to 75%, it fails.

I have tried changing the Iterations and the Output interval, however nothing stops it failing.

Many thanks


Just tried the new version and I’m still getting the runtime error 52.

Are there and particular files I should be deleting from previous downloads?

Make sure you have the very latest file:


as I’ve posted two of those since releasing 12.10.1 last night. Rob, the sudden drop in temperature on day five looks like it’s gotten hold of bad GFS advection data, which is the eventuality I was trying to head off with that second posting of 12.10.1b. it was a bit hard to test that as I wasn’t getting that error. Here’s an experiment: if you uncheck the use of advection on wind shifts (in autorun), and the error disappears, that’s the problem and if you let me know I can try again to work around that.

Rob, when is that error 52 happening? I think if you used the 12.10.1 upgrade installer, adn then replaced wxsim.exe using the link above, all the right files ought to be there. I’m thinking it’s probably a symptom of the bad GFS data problems, but I’m not 100% sure. I will certainly do my best to track down the problem.

18Z should be out soon. We’ll see what happens with that!


after switching to Bohler and using last fix-version of WXSIM!
I’m getting the “runtime error 5”

This is what I get RuntimeError 5.

I have had success so far (06Z, 12Z, and 18Z GFS runs) with the combination of Bohler and the new wxsim.exe at www.wxsim.com/wxsim.exe. The downloaded data has had either 2 or 3 bad lines each time (in random places), but WXSIM was able to fill in the gaps and run with no errors.

I see the reports above, though, of error #5, which sounds like WXSIM is encountering bad data. The first thing to confirm is that you are really getting the latest version of the program (I called two different uploads the same thing). So, I just recompiled and called it 12.10.1c (on the opening splash screen and at the top of the Data Entry form). If you are still getting errors, please downlaod this and make sure the program you are running is labeled 12.10.1c. If the error happens even after ensuring this is right, please send me wdata.txt. It could be that there is sometimes a type of bad line of data which I have not anticipated in the fix.

I’m also trying to figure out the error #52. I had rarely heard of this before, but then recently (though before the official release of 12.10.1) I’ve heard sporadic reports of this from three different users. I am not sure whether or not it’s related to the bad GFS data, though it seems it could be, at least indirectly. There should be a way around it even if it is due somehow to the bad data. Toward that end, I could use information, especially about when it happens. I will also try to build in a trap or diagnostic tool to catch it.



Tom, the fix is working without any problem so far!



All good here too by the looks of it. In the end I un-installed everything, reinstalled 12.10.1 and then added 12.10.1c.

I just posted a 12.10.1d, at


This is identical to 12.10.1c, except that it has a diagnostic feature in it to hunt down the source of the error 52 that three users have seen. If you have seen this error, give it a try. I don’t know that it will fix the problem, but four little files, each containing a time stamp are created right around the part of the code that might be where the error 52 is occurring (sporadically). If you get this error, then please send me the files wrapup1.txt, wrapup2.txt, wrapup3.txt, and wrapup4.txt, or let me know if any or all of them don’t exist in c:\wxsim.



Hi Tom
Version 12.10.1b in WXSIM and combination of Bohler in WXSIMATE.
Everything works fine without any error messages.



12.10.1.d working fine at this end with neither error showing now.

Tom I am seeing bad data in the advection part although I am not getting any errors from WXSim and so far I’ve not noticed any strange predictions in the forecast but I will check carefully. I’ll install this latest version just to be sure.


Hi Tom,
thanks for the fix.
No errors with your latest version and Bohler source.