NSDisplay 2

Is there any updated docs that support the most recent release of this script? The current docs don’t seem to support the most recent release and I am a little lost on how to create the maps.



The map making part will be the same as it is for NSDisplay 1 since both use my nslmap.php script to plot the strikes. Probably best to download the NSDisplay 1 package from my site just for those instructions.

  • Jim

Thanks Jim, I have NSD 1 installed and it works great as you can see here… http://www.mesquiteweather.net/NSTestStrict.php Where I am a little lost is how to set the maps up on NSD2. In the settings for 1 there is a place to setting the path to the map, but I am not sure how to set it for 2 as it appears that install docs are for NSD1, I could be just reading it wrong.

The only map that displays on NSD2 is the ones in the install…


Also doesn’t seem to be getting all the data. I think I have all the file paths set, but I could be overlooking some but not sure as to where. Any suggestions would be great.


Sorry, I’ve never installed NSD 2, so I probably can’t help you. I do know that he’s using nslmap.php to plot the strikes on “clean” maps like I do in the newest NSD 1. In order to do that, you need to have NexStorm create those clean maps and that’s what I describe in the documentation for NSD 1.

The script is probably halting where it looks for that series of 12 or so maps in order to create the drop-down list that allows zooming in and out. Beyond that, I’m not much help.

  • Jim

Thanks Jim, that is where I seem to be stuck since as far as I know Nexstorm can only upload one size map. Do I just need to take mapshots of each level and rename them?

I am also starting to think I don’t have the most recent version. In the docs it talks about nslmap.php and NSStorms-include.php. Each of these files has it’s own configuration section that you should look at to get the “look and feel” that you want, and to set the proper paths. But I don’t have a NSStorms-include.php and the nslmap.php doesn’t have a any configurations in it only the NSconfig-include.php. So I may have the wrong or most current installation which is causing the problems maybe? If so, could you point me to the most current? I downloaded these right off yours and his site.


Henkka’s NSD 2 doesn’t have a separate config file for nslmap like NSD 1 does. Also, he doesn’t use NSStorms-include, he displays the storm data a different way. The reason I pointed you toward the NSD 1 readme was because you do need to make the “mapshots” and it describes how to do that. Most of the rest of that is just for NSD 1.

I know it’s a little confusing, but hopefully you can figure it out. When you’re all done you won’t be uploading the nexstorm created map anymore, nslmap will be plotting the strikes and storms on the “mapshots” utilizing the NSLog uploaded data.

  • Jim

Ok I am starting over, deleted everything and starting with NSD 1 which is setup on the test script, but on the page it is looking for NSStorms-config-se.php which I don’t have and wasn’t in the install package. Only one I have is NSStorms-config-fr.php which I believe are the language files correct?

EDIT: found how to create the language file. make a copy of NSStorms-config.php and name it NSStorms-config-se.php. What’s strange is my test page is in English. On the live page it isn’t

test page


Live page above WASP2 graphic (which doesn’t show ether).


The test page came with

//$_REQUEST['lang'] = 'se';                         // optional to specify a language. NSlang-inc.php.

commented out so that’s why you’re getting English and it’s working right there. Comment that out on your other page and that will take care of it looking for the storms language file too. You’re right, there isn’t one. This is just a way for folks to customize for their own language and I don’t have a complete set to distribute.

For the small wasp2 image you may have to change the path in wasp105.php so it’ll find your uploaded large copy. If that’s right, then it could be that you need a file on the server with write permissions for it to write to when it caches. Info on that will be in the readme.

  • Jim

Thanks Jim that did the trick for the language. Now it is just a couple of small tweeks. As for the wasp I have it in the code like this…

$Graphic = '/lightning/wasp2.png';

The url to the image is here…


I didn’t have write permissions set on the image to 666, but I did change it to 666 after reading your last post as you suggested and I am still not getting anything. I have tried some things but I can’t get it to show.

One other small thing I can’t seem to find is it shows in Km, where do I set it to show in Mi?


I couldn’t find your wasp105 in either your root or your /lightning folder, so wherever it is, you maybe have a path problem? For the km, we get that from the NSRealtime.txt file now. That was an addition so if you have an old copy of NSLog you’ll need to update it.

  • Jim

Jim, the wasp105 is in my NSDisplay dir, the wasp image is in the lightning dir. So in the wasp105.php file I put the path to the image as follows…

$Graphic = '/lightning/wasp2.png';

Does the wasp105 need to be in a different directory with the image?

I am using NSLog v1.41, under general I have the box checked for “Show in miles”. Is their another place in the script I am overlooking that should be changed as well?


As the image is in the lightning folder and the address that the server is looking for is http://www.mesquiteweather.net/NSDisplay/wasp105.php then you need to think about where the wasp2.png is in relation to the wasp105.php file and not in relation to your wxnexstorm.php page (if you get me).
Try this:

$Graphic = '../lightning/wasp2.png';

or you may have to put the server location in there instead of the URL location. :wink:

Ah Thank you Budgie that did the trick adding the extra …/ instead of ./ as I tried as well. Never thought off trying two …/ so thank you.

I almost have this tweeked, the one issue I have come upon is Auto range defaults to 63km. That should be in miles and I would like the auto range to be set to 500 miles. I am sure this is a setting since I upload a 500 mile nslmap.png but it always gets change to 63 km. Also on the different range maps do they need to be CMOD to 666 or is it just the nslmap.png that needs to be CMOD 666 as I have?


Looking good.
I need to look at my own setup but I’m at work just now so will check in the morning when I get home. :wink:

Ok I found the line in nslmap-config.php that sets the default auto range…

$MinAutoZoom    = 500;                              // The closest that you want to Auto Zoom

But it displays it as km instead of mi. I change it to miles in the zoom.txt but it keeps getting written to km. What writes to this file?

Also, I found the file to change the map image size because it’s to wide for my div but now I can’t find it and it was fine until I uploaded the maps for the different ranges. I need to set it so it will fit in my layout and I can’t find it now.

I believe I’ve found your problem, in nslmap-config.php the paths are relative to that file, similar to the issue that you had with wasp105. Change the double dots to single dots since your data files are in that same folder. Then I think we have it?

  • Jim

Ah yes that did it Thank You Jim. I thought I had tried that but I guess I didn’t. I am sure there is others like that but I need to get some activity to test it.

There is a file that defines the $width variable and I had it set when I was testing it using just one map before uploading the different ranges. Now I can’t find it to save my life and I am losing my mind. I have been in every file at least 5 times and I can’t find it. I need to change the width a tad so it will fit in the template. Can you remind me where this would be done?


I just looked and I see that it plotted a strike, so you’re good to go. For width you’ll have to make that one page a bit wider and there’s a way within the template system to do that. I thought I had a link to a post here on how to do that, but I see that it is incorrect. Anyway, it’ll be a page setting not a NSDisplay setting because it’s not going to get any narrow than what you have.

Merry Christmas. - Jim

Ok thanks Jim, I will give that a try. It may have been the older version of NSDisplay I was working with that you were able to do that with. I know in NSD 2 there is a setting in the NSDisplay.php that you can control the width and set the variables. I am sure that probably throws the accuracy of the map off though. Here is the code that is in there…

if($smallmap) {
$bwidth = 648;
$twidth = 648;
$graphheight = 140;
$graphwidth = 648;
$imgwidth = 490;
} else {
$bwidth = 648;
$twidth = 648;
$graphheight = 150;
$graphwidth = 648;
$imgwidth = 648;

I will just make that page a little wider though, shouldn’t be to bad. One strange thing I did notice that I am not sure if it’s suppose to be like that or not. When you mouse over a strike it is anchored to a link to the page it is on and puts a black box around it. I saw some settings but not sure if that controls that or not. If there is not any strikes when you look you can mouse to the top of the map and it does the same thing too.

Thanks again and Merry Christmas to you!

I’m not sure about Henkka’s settings, but I’m sure he doesn’t change the size of the map or you’re right, that would throw the plotting off. NSD1 determines the size of the image for you and goes from there. If you’re just a few pixels off, you could tweak the css a bit and maybe make the right column a little narrower. I think you can make that one page a little wider and nobody will ever notice.

For the black box thing, that’s something else from your page bleeding over into things. When I run that page through the validator I see a lot of errors so when you get those fixed it’ll go away. If you run TestStrict through the validator it’ll come out “clean” so the NSDisplay part is fine.

  • Jim