NSDisplay 2

Thanks Jim, yea I have some errors to fix. I normally do that once I get the page set and laid out the way I want it then go back and fix the errors. Some of them won’t go away due to the javascript and flash on the page. I have that link problem narrowed down to the imap that is associated with the map. Just have to figure out why it is linking to the map.

I was able to hard code the map width in NSDisplay.php and surprisingly after doing some tests it doesn’t affect the plotting which is surprising since it seems it doesn’t actually change the width of the map it just pulls the content around it over it which you can tell from the range rings and the copyright name on the bottom right. I can live with that though. Which gave me a idea I may try to piece together. Which is add a option to use maps with and without range rings. I have two sets of maps both with and without range rings. So I am going to try to implement that into it. Wouldn’t think it would be to hard to do.


Well many many many hours later of digging and digging thanks to Firefox Web Developer add ons I finally tracked down the problem with the links on the map. This little bit of code for the tooltips is causing it.

			for ($i=1; $i <= $MaxLS; $i++) {        // creates the spans for placing the "last strikes"
				echo '			<span class="NSstrikes" id="LASTSTRIKE' . $i . '"></span>'  . "\r";
				echo '			<a id="TOOLLINK' . $i . '" class="info" href="#"><span id="TOOLTIP' . $i . '"></span>&nbsp;&nbsp;</a>'  . "\r";

I remove that code and the problem goes away. So I have isolated the problem as I know what is causing it. So digging a little further as to way that bit of code is causing problems I learned there is something in my style sheet for my site it doesn’t like. How do I know this. Because on the test page below that doesn’t have the css call in it the problem isn’t there…


But the problem arises on my live page at the top of the map and on tool tips for strikes…


But what I am not sure of is what in my style sheet it doesn’t like as I have gone all through it and don’t see ID’s or classes that I think it would clash with. If anyone else can see something in my style sheet that would clash with the code above causing the link issue when you mouse to the top of the map or tooltips I would be open to suggestions because I can figure that part out.


Ah never mind, disregard the last post. After analyzing that piece of code that was causing the problem i noticed there was a class called “info” well in my style sheet I have a class called “info” so the two were conflicting. Since that class in my style sheet is only assigned to one div in my site it was easier to rename it then the NSstyle sheet. So I just renamed it and problem gone. Working like a charm now.

Wow, very good catch there. I think I’ll change the name of that class in the distribution because it is way too common of a word. Sorry it caused you issues. Those Firefox tools sure are nice, aren’t they?

  • Jim

You ain’t lying love those firefox tools both web developer and the Firebug add ons. Been using them for years and been a life saver. It’s all good that info class was one I create for my RSS scroller in the header. It was easier for me to change that one then the one for NSDisplay. I tried to change it to NSinfo in the NSDisplay CSS but wasn’t working and I could barely stay awake so didn’t spend much time when I could just change the one div class for my site. So it may or may not be common but if you wanted to change it you could name it something like NSinfo so it would be strictly associated with the NSDisplay script.

Thanks for all your assistance Jim. Was curious though is it possible to use different style graphs? For example I like NSDisplay 1 but like the NSDisplay 2 graphs. So are they customizable or they strictly set?

The reason you had trouble with the info class is because it’s updated by the ajax so changes would have to be made there too. Maybe I’ll leave things alone unless someone else has problems.

You could certainly use a different graph there if you wish. I know Budgie was talking about using Henkka’s but I don’t know if he ever got around to that. I’d imagine that any of the graphing packages could be used, then you’d just point to that in the config instead of Strikes2.php.

  • Jim

I never did get around to look at using the JSON graphs for NSDisplay.
Still something for the future, when I have time to mess around with it. :wink:

Well I have gone and booger-ed it up. I changed NSLog to upload to NSLog dir instead of NSDisplay dir where the files for the NSDisplay are. I went and changed the dir for the txt files to NSLog and they upload and it’s showing data, but it isn’t showing strikes and I made the changes in all the files config and stikesX.php files. But the strikes don’t show on the map. Should the path be ./NSLog or just /NSLog?

I’d use ./NSLog/xxxxx.txt assuming your site file that includes NSDisplay is still in the root. Don’t forget, for nslmap and NSStorms, those paths are relative to those particular files so those would be …/NSLog/xxxxx.txt.

  • Jim

This whole …/ confuses the crap out of me…LoL Just so I am clear let me see if this is right. I have the folders in the root one NSLog for the text files. then on NSDisplay with the NSDisplay files.


$strikesfile = “…/NSLog/NSStrikes.txt”; // The path from this file to NSStrikes
$stormfile = “…/NSLog/NSStorms.txt”; // The path from this file to NSStorms
$realfile = “…/NSLog/NSRealtime.txt”; // The path from this file to NSRealtime


$stormfile = “…/NSLog/NSStorms.txt”; // The path from this file to NSStorms.txt
$expiredfile = “…/NSLOg/NSOldStorms.txt”; // The path from this file to NSOldStorms.txt
$realfile = “…/NSLog/NSRealtime.txt”; // The path from this file to NSRealtime

NSconfig-inc.php the path to the text files are like this.

$path_to_data = “./NSLog/NSRealtime.txt”;

It shows realtime just not old strikes who storms ether new or old and the graph shows. I know it’s a file path problem just not exactly sure which one is correct since they are different in each file.

Ah well it seems to be working now so I assume those paths are correct?

At a glance they look to be right. As you say, they must be if it’s working. Now you just need a good storm to see it in action.

Enjoy. - Jim

Just installed this one yesterday, and the initial problem that I’m getting is that it is only uploading a NSDGraph.txt and not the two other files.

At this stage the web side of the utility isn’t working properly as it isn’t getting the other files created and ftp’d in to the website.

Only have one entry in the ftp log, but that was just to do with a single failed connection to the server, i.e. my link could’ve been down at that moment of time, but that entry was hours after nsbackend was started up.

I see there’s now a new version NSD 2013 available, but it says it is for Europe though.

Anyone tried it outside of Europe yet ?

I know it in part relies on European only data, but if that was disabled would you be able to use it elsewhere ?