Davis VP2+ temperature sensor fault?

No. Started before that. There was nothing I had changed in the 12 months or so before the problem started. I updated WD after the problems started.
One issue I have wondered about is the registry entries but I have no idea what to look for, or how to modify them, if there’s something in there that could be the cause.

Registry entries probably aren’t the cause. You created a brand new set of them when you install WD2 copy so anything weird in there from the original installation can’t be relevant.

Ok, but somehow it knew the ID and password for my upload to WeatherCloud and I don’t think that’s in the config file.

That’s not how I thought the second WD copy worked but I don’t use the Windows version so it’s probably best to wait for a knowledgeable Windows WD user to pass by and hopefully give a more definitive answer.

I am not familiar with WeatherCloud so can’t help with that question. The wd2.txt entry allows you to run another instance of WD on the same computer without making changes to your original install. If you look in the WD databackup folder you will see files with a “2” added (if you used wd2.txt, or a “3” if you used wd3.txt) - for example “wdisplay2.ini”. You could then diff the ini files to search for clues.

You mentioned the 2nd WD install also failed…did it fail in the same exact way your original WD failed?

I think it proves the issue is with WD. Since WeatherLink does not fail it proves your hardware is working as expected. But as Brian told you earlier, it’s probably “bad” data that is causing WD to stop grabbing loop data.

The strangest part is your datalogger contains the missing sensor data AND you are able to import to WD successfully.

i am wondering if the problem is interference on you pc to console cable and is causing spikes during normal running, maybe try a clip on ferrite core on either end

That would also affect Weatherlink which seems to work OK.

Just done a databackup of the 2nd instance of WD but there is no “2” added to any files.
The original wdisplay has a folder called databackup
The 2nd - called wd2023 - has a completely separate structure which also has a folder called databackup.

Just had - we’ll call it WD2023 - running and it fails in the same way. Stops receiving data after a random amount of time.

Except that WeatherLink has dips in the ISS reception, which I wouldn’t expect with a cabled system.

The only thing that has changed is that I installed a new NAS (original is now 8 years old, so on borrowed time). This was installed about 1 week before I started having problems.

I have some clip-on ferrites, so it won’t do any harm to try them.

Just done a databackup of the 2nd instance of WD but there is no “2” added to any files.

Been a long time since I used this function…when I did it I didn’t do a separate install of WD, I just added the wd2.txt file in my normal WD directory and fired up WD. Maybe that’s why I had the files mentioned.

I think you need to contact Brian and ask for help in figuring out what is causing WD to fail.

I emailed Brian and he suggested an out of range value would cause WD to stop receiving data. I’ve not had any other suggestions from him.

I’ve installed a 2nd WD and that exhibits the same problem.

Looking at various menus/screens I noticed View - Davis VP Extra Temp/Humidity shows 255.0 C instead of -100.0, but I don’t have any extra sensors, so I don’t know where that value is coming from.

And another (un-related?) issue now is that while wunderground rapid fire works, WeatherCloud is giving me 10057: Connection closed.

I’m considering a complete uninstall of WD (Uninstalling WeatherDisplay... If you must ;)) and start as if a completely new user, but reluctant to do that - a lot of work - unless there’s some other option(s).

WD has various default values for non-existent sensors :slightly_smiling_face:

And WeatherLink can produce phantom readings - see 'Phantom' UV data

The non-existent sensor (temp #1) normally shows -100.0 but after WD stops receiving data it shows 255.
Maybe that is phantom data? An interesting comment in the link you gave is - ‘2nd temp’ is still appearing but on an intermittent basis - but even if that is not very common, I would have expected some other WD/VP2 users to have experienced the same problem that I’m seeing.

Search for 255 in Archives, user windy2, and you will find that 255 = NULL in WD-speak.

Appreciate your comment but I don’t know how that helps me. What I would like to find out is why it changes from -100.0 to 255.0

When you did the 2nd WD install did you make ANY setup changes other than station type?

Not that I know of. I used to have a 1-wire system and the “old” config (that was working fine in January) referenced a lot of 1-wire settings. The new install doesn’t need those but I still see refences to them in the latest config.
I’ve also just noticed record hi extra temp2, temp2 2, temp2 3 all showing 2550 instead of values of 1000 or less. I have no idea where those values are coming from as I have no additional sensors.

It’s very puzzling. Earlier today I had the same issue of WD not receiving data.
I did a save and exit, rebooted the laptop, restarted WD.
It has now been running for over 9 hours without that issue, but I still have the
10057: Connection closed issue with WeatherCloud.
Wunderground is working ok though.

1 Like

Any update on this thread?

Well I’m still getting stoppage on data received after random time intervals - 10s of minutes up to many hours. Frustrating when it happens in the middle of the night, but…

Having had no sucess previously with both the “Reboot computer when no comport data received for 10 minutes” AND “Restart WD instead of reboot” ticked, I’ve just tried ticking the latter only and it does what it says. The layout on that Setup → Advanced/Misc settings screen seems to suggest that for a restart WD to happen, both need to be ticked, but that appears to be a false interpretation. See Send Alert when not receiving data - #2 by broadstairs

I’m no nearer finding the reason why data stops, but at least now I’ve worked out how to limit data stoppage to 10 minutes.

I’ve put dielectric grease on the RJ plugs in the ISS, so I’m beginning to suspect one of the sensors.

I could unplug them, one at a time, and run WD for a couple of days each time, to see if that removes the problem, but I’d prefer not to do that, so I think I’ll email Davis and see if they have any other suggestions.

In addition to the weathercloud 10057: Connection closed issue, I also started seeing an error box pop up shortly after doing a save/exit of WD - invalid EdgeCache directory.
invalid directory cache

Bite the bullet time - I did a 'backup registry entries" and then saved everything in the WD folder to my NAS, deleted everything relevant on the laptop including using regedit.exe to delete the relevant WD entries (see WD Uninstall - #4 by windy2), did a clean install (I did make a note of registration key, wunderground and weathercloud names and keys) and now both those errors have gone away.

1 Like