Davis VP2+ temperature sensor fault?

I posted a message on the Weather Display for Windows section (Data received - stops) if you want to read the story of my problem.
I’ve sent a couple of emails to Brian and had replies. Latest I sent included rawultimeterdata files. I’ve yet to receive analysis of those.
When WD Data Received stops, shortly after that the outdoor temperature in the WD display goes blank.
Brian suggested that an out of range reading could cause WD to hang. Could a faulty sensor cause that?
Anybody seem a similar issue?
Reluctant to buy a new sensor (51gbp) without some confirmation that it could cure the problem.

How old is the sensor
And yes if the temp goes out of range WD will stop

Sensor is only 18 months old.
I’ve had a look at the 2023lg log and can’t see any errors.
I saw 100% solar - overcast sky - so unplugged the solar sensor but I’m still getting data stopping.
When I manually restart (I set it restart after 10 mins of no data received on com port - but it doesn’t do that) history data extraction starts. If there was faulty data in that would it stop again during extraction?
The mystery continues.

Mystery solved. What was causing WD to stop was corrupt data from the anemometer because there was some corrosion on the RJ plugs and coupler on the extension lead (even though the connection is in a dry loft)

Might be worth investing in some contact lubricant. A quick spray of it might keep things nice and corrosion free for many years to come?

I do have some Electrolube I’ll try. Not keen on Servisol, but I’m going to order some dielectric grease, which I think is a better long term option. So far I’ve only used a cotton bud dipped in ethanol.

Looking through the various WD settings I found (View / Davis VP Extra Sensors) Sensor #1 (temperature) showing 255 (I reset that), so that probably explains WD stopping receiving data and also the outdoor temperture disappearing from the main WD screen and points to the temp/humidity plug/socket inside the ISS being the problem.

Another thing I’ve discovered on my search for a solution is that I can resize or move various aspects of the main screen.
Setup / Advanced / Move/Resize. The UV reading was obsured by solar % bar. Now it’s not :smiley:

However I’ve also now seen another problem. It’s not an issue unless I have to exit/restart WD.
There is a delay once WD is launched (NOT to be confused with the option to delay WD launching after a PC reboot).
Data received shows 1, date is visible but time is blank. It takes about 3 minutes before WD then starts receiving and data received number increments.

If WD is set to retrieve missed data then you should see the import box pop-up on the screen. Might be worth turning off that function and see if anything changes. It sounds like WD is unable to communicate (find the time in the data it’s looking for) with the datalogger and is timing-out searching before starting loop data. IIRC there is a minimum 3 minute trigger before WD will try to import missed data, so be sure WD is off for at least that long. Did you reset the datalogger and verify time is sync’d between the VP2 and your computer?

1 Like
  1. I still seem to having problems, so my “solved” was a bit premature. I’m now thinking it could be a sensor, but tomorrow I’ll check all the plugs/sockets again and use my Electrolube on them. After that I could try running WD with a sensor (one at a time) unplugged for 24 hours and see if the omission of any particular sensor has any effect. The only one I don’t think I can do that with is the barometer??

  2. I have never set WD to automatically import from the data logger. It was only recently that it started doing that on its own. Just had a look and can’t see that option anywhere.

  3. When WD stops receiving it’s often quite a while before I notice, especially if it stops overnight.

  4. That 3 minute you mention is interesting. That’s the delay I’m seeing when I restart WD before the data received starts to increment.
    Next time I need to exit I’ll leave 5 minutes before restarting WD.

  5. Reset the data logger? I don’t know how to do that. Do you mean shut down/restart the console? Or clear the data in the logger?
    But I just found in WD, Control Panel/Data logger with clear archive, clear high, clear low. Never noticed those options before.

  6. Time sync. Just looked at it now and it’s within 10 seconds. The computer uses Meinberg so is accurate to about 1 or 2 seconds.

See attached.

Thanks. Yes, that, as far as I know, has always been on, but it’s only recently that I noticed the data extraction window popping up when restarting WD. I don’t remember seeing it during the first week I was having these ‘data received’ stopping issues.
Confusing (for me) because it refers to logging and not (specifically) extraction from the Davis data logger.

[This new forum layout might take some getting used to!]

Still getting “data received” stopping.
I’m beginning to think it really is a sensor fault.
First, I realised I had two extension cables, not one. Both in the loft but not near each other, which I why I’d forgotten about the second one.

  1. Clean RJ plugs and coupler socket contacts. No improvement.
  2. Replace all 4 plugs and both couplers. No improvement.
  3. Chop off the plugs and use crimp terminals to make the joints (see https://cpc.farnell.com/tuk/8a-xjyadg/idc-connector-2way-gel-crimp-10pk/dp/CN19937 ) whch are cheaper and hopefully at lot more reliable than RJ’s, even if the RJ’s were enclosed in a waterproof coupler.
    Still no improvement.
    Looking at the WeatherShop reviews of the temp/humid sensor, one review mentions one lasting just 18 months.
    WeatherLink works fine, it’s just WeatherDisplay that’s giving me headaches, so I’m not sure if it would be covered with their 3 year guarantee.
1 Like

If WeatherLink is not showing any issues then your sensors AND cables are okay.

WeatherLink used to be (may still be) considered the “gold standard” by Davis, that is to say if they needed data from you to troubleshoot an issue, then the only data they would accept had to be collected by WeatherLink. So if WeatherLink is not presenting with the same issues as WD then the problem is with WD.

Thanks for the comment. The only issue I can see in WeatherLink is dips in the ISS reception. Being cabled, not wireless, you would expect 100% continuously, but I’m getting random dips and (as I can’t run WD and WL at the same time) I suspect those dips coincide with the “received data” stoppages in WD.
I’ve set WD to “Restart WD instead of reboot” when “no comport data received for 10 minutes” but that doesn’t happen and I don’t know why.
If it did restart WD I wouldn’t be as frustrated.
I’ve just ordered some dielectric grease to put on the RJ’s in the ISS but I’m not confident of it curing the problem.

I run WeatherLink and WD on the same computer using VSPE (Virtual Serial Port Emulator).

My advice is make a 2nd install of WD using the 2wd.txt method described in the FAQ on running multiple instances of WD on the same computer. Setup the 2nd instance of WD with just enough config to grab data from your Davis station and see if the problem persists.

I’m struggling here. New folder called wd2023 with wd2.txt added to it.
Download and install latest WD.
Entered basic data (com port, registration code, lat/long, etc.)
Set both instances of WD to ‘do not shut down other instances’
Original WD is running and receiving data.
2nd WD is not receiving data :confused:
Shut down original WD, 2nd WD now receiving. Will see how that behaves.
My original station was 1-wire, so there are entries in the (original) config that refer to 1-wire but those didn’t change when I started having problems (10th Feb)
I noticed the 2nd WD had automatically added WeatherCloud but I had to manually enter details for wunderground rapid fire.

I think that if you’re using a wired connection from your WD PC to the Davis console then you can’t run two copies of WD at the same time. I think the idea was to create a fresh copy of WD to see if that ran without the problems that your original copy was experiencing.

OK. That makes sense. Do some installations (not necessarily Davis) link to the PC with wifi?
So far the 2nd copy is running… but it ran for over 10 hours yesterday before it stopped receiving, then after I rstarted it, it only ran for 55 mins before it stopped again. So frustrating when it’s random. Would be much easier to find a solution if it was predictable.
it might take a couple of days for me to have any confidence that it has solved (or not!) the problem.

The Davis WeatherLink Live (WLL) device allows you to get data from it using WiFi. There are also some third party plugins for the console that give you a WiFi connection.

If your second newly configured copy is able to get data for a period but then stops like the first copy then that’s helped by proving it’s not something weird in your original WD config that’s causing the problem. Granted it doesn’t help find a solution but at least it helps to remove potential problems.

You said this started fairly recently. Was that after upgrading WD? I’m wondering if you have a slightly older version of WD that you could try going back to and see if that makes things any better?

Ok about wifi.
The problem started 10th Feb “at random” after running for about 18 months with the VP2. After cleaning then replacing the RJ connections in the loft I thought I had cured it, but the problem continued.
One problem I’m finding, trying to set my desired screen colours, graphs, etc. is there are too many setup screens and options! I guess that’s the disadvantage of it developing over time and coping with lots of different weather stations.

Did the problems start after you upgraded to a new(er) version of WD?