Annual Rainfall not correct

Hi Wim,

Only 1 problem left, for now. Here is the website as of today:

I live in the Rocky Mountains which is a high desert. This number is impossible. I calculate the correct number to be roughly 9.35 inches.

Here is what I found:
First, this is from the first List Contents Button: ( _my_settings/history.txt)

The Show Station Values button didn’t reveal anything unexpected.

The Live Date Values showed:

I tried the Load Files button at the bottom of the Debug Console and it showed:

Again, the Annual Rainfall should be about 9.35 inches.

How do I fix this?

Many thanks for your knowledge and patience!!! And my offer to donate still stands.

The anual rainfall is calculated by the cron-job and stored in the history file.

To modify that field you run run in your browser

With a correct easyweathersetup password tall current history data is shown and you can change the contents of the fields.



Thank you, Wim! Let me know how I can help support you.

OK, you have corrected annual rainfall by manually changing the history that you got from WU.

So how/why did WU get it so spectacularly wrong in the first place?

I’m really not sure! There are no yearly totals displayed on WU. Just daily and monthly. I failed to see a yearly total in the WU downloads to PWS_Dashboard

Originally, after I updated, it was only off a a couple hundred inches. I tried running PWS_history_recreate.php. I ran it several times and the Annual Rainfall amount climbed every time. So, that may be a clue.

Wim said that: “All math is done in PWS_Dashboard.” So I’m assuming that the error is there. Not something that is wrong with PWS_Dashboard but from my ham handed attempts to fix it.

Always learning …


Only :laughing: That’s about 5 times our annual rainfall as an error.

I have to say this is one of the reasons I stopped using cron/history/status: WU holds some phantom numbers that cannot be corrected. Every time an error crept in from my end and I tried to correct it, WU would reproduce its rubbish - maybe because I was doing something wrong, who knows - and I had to go back and correct that, too.

Maybe I was running PWS_history_recreate.php and I should have been running update?

But I don’t think OP has the luxury of that choice. . .

Yeah, it eventually got up to nearly 460 inches. We would be underwater!

Thanks to Wim and Bits for straightening me out!


Let’s see what happens tonight after the cron job rolls over. :hand_with_index_finger_and_thumb_crossed:

The update worked great for me … so far.