WXSIMATE freezes at ozonedu.lst when downloading files

Just noticed that for a couple of days WXSIMATE has hung when downloading ozonedu.lst. If I untick Ozone downloads it hangs at raob.lst. I’ve shut the computer down, restarted it, but no difference. Edit: I’ve tried downloading a fresh copy of WXSIMATE but the problem persists. Any help welcome!

If you download GFS from my server then you already get ozone data that way and don’t need to do the separate ozone download.

Thanks Chris - I unticked the ozone box and the download now freezes at raob.lst.

I assume Ozone and RAOB come from the same servers or servers located near to each other. Unfortunately I can’t help with RAOB data.

RAOB is in the USA and ozone when loaded separately from Chris’ server in the the Netherlands! I’ve not seen any issues recently. When you say freeze do you really mean it stops and you have to close and restart WXSimate or does it just take a very long time?


It just stops at the point in my WXSIMATE screenshot. If I close and restart then the same thing happens. WXSIMATE never completes. The forecast itself does complete and uploads to my website although it probably isn’t that accurate.

what’s in the wmatelog.txt
have you tried changing the RAOB link address there’s 3 option avalable

wmatelog.txt just has “Error messages during intermet download:”

I’ve now tried all three RAOB link addresses and there’s no change.

OK so I just ran WXSimate with the same RAOB site as you use and it works fine and we both have the same settings. So I suggest you try the site in a browser and see if it works, if that does work then make sure you firewall allows WXSimate has full access. If the browser fails to find the site then your DNS could be at fault. Can’t think of anything else.


Hi there
I too like broadstairs (Stuart) changed my settings and ran a forecast and all worked fine.
Must be a firewall/Router issue

RAOB works fine in a browser. WXSIMATE has full access through the firewall. Router hasn’t been touched.

WXSIM forecasts have worked fine for years and I’ve not changed anything on the PC for months apart from Windows Updates and upgrading Weather Display to 10.37S151. It’s a separate PC which only runs Weather Display and WXSIM. Even with the “Download complete to raob.lst” message the WXSIM forecasts do complete and seem okay.

Edit: Just checked the raob.lst file timed at 1228 today and it seems fine with 3204KB of data.

I emailed Tom a few days ago and am awaiting his input. In the meantime I have noted that wdata.txt has not been created since 31 March. If I understand things correctly that file should be recreated after WXSIMATE runs. I renamed wxsimate.exe and installed a new copy. Same problem, wdata.txt is not being created.

I’ve pulled my forecasts from my website as they were meaningless.

Probably a silly question but is there an issue withe the disk used to store the data? Is there enough space?


I’m puzzled how you can be getting good forecasts is wdata.txt isn’t being updated!

Is that definitely the filename/path showing in the upper right hand of WxSimate? Also if you’re using GFS/ECMWF mixing have you got the correctly named files with the correct paths in all three of WxSimate, the mixer and WxSim?

Stuart - there’s no such thing as a silly question when it comes to me and computers! There’s 79GB available on the partition that wxsim uses.

Chris - it was just after the problem arose that I intially thought I was still getting good forecasts. As per my last post, I soon pulled forecasts from my website as it became obvious they had quickly become meaningless.

I’m using GFS/ECMWF mixing but I see the wdatamixed.txt file also has not been updated since the errors started. I haven’t changed any of the paths - everything has run okay for some years without a problem until things went wrong on their own as a forecast run commenced in the early hours of 31 March.


I just looked at your screenshot and the box under Site at the top is wrong, it should contain your site id. Mine shows egum+03796 in that box.


That screenshot shows what it looks like after the program has hung. Normally it shows my site id as below.

I have auto append and cull ticked. I wonder if the file has got too large? Try using the manual apped and cull buttons and then tick the box to do it automatically in future?

Chris - you’ve hit the nail on the head! I don’t know how but Auto Cull and Append must have got unticked. Everything seems to run through to a forecast conclusion, I’ll check the accuracy for a few runs before I resume uploading them to my website. Very many thanks to you and Stuart for your suggestions - much appreciated!

1 Like