wxglobalwarming trend page


Recently i stumbled upon this:

Notice: Undefined variable: avtempjannow in /customers/b/c/b/akker.be/httpd.www/Flashgraphs/temp-departure-12mths.php on line 47 Notice: Undefined variable: avtempfebnow in /customers/b/c/b/akker.be/httpd.www/Flashgraphs/temp-departure-12mths.php on line 48 Notice:
I have checked my testtags.php and the tags are in there. So what could be wrong here?
Link to the page:

Thanks in advance for helping me out!


There seems to be something wrong with the temp-departure-12mths.php file from line 47 to line 58 and the rain-departure-12mths.php from line 45 to line 56.
What do those lines have in them?

There are not even 49 or 56 lines of code in there:

<?php // Flashgraphs Package V1 11th January 2010 if (!isset($graphloc)) $graphloc = ''; if ($graphloc == '') $confloc = "Flashgraphsconf.php"; else $confloc = $graphloc."/Flashgraphsconf.php"; if (!file_exists($confloc)) { echo "Unable to find $confloc ... script terminated "; exit(); } require_once("$confloc"); require_once("${hostloc}testtags.php");

$margincolour = “9F9F9F”; // Colour of margin outside of graph //area
$canvascolour = “C0C0C0”; // Background colour to graph itself
$textcolour = “000000”; // Colour of all text outside the graph
$cvtxtcolour = “9900FF”; //Violet // Colour for all text within
// the actual graph area
$cvtxtcolour2 = “000000”; //Black // Alternative Colour for all
//text within the actual graph area
$winddotcolour = “FF0000”; //Grey // Set this to a contrasting
//colour with $canvascolour
$shadow = 1; //set to 1 if you want a shadow drawn along
// with the graph lines

$rain_unit = “mm”; // Change to in when required
$rain_format = “1”; //Sets no of decimal places to display
//suggest 1 for mm and 2 for inches
$rain_col = “1941A5”; //Dark Blue // Rain plot line colour
$rain_min_value = 0; // set to the normal min rain value you want
// displayed on graph
$pos_col = “9932CC” ;//Violet //
$neg_col = ‘4169E1’; //

Very strange…See attached rain-departure-text. This provides perhaps a solution…

raindepart.txt (8.07 KB)

If I put http://www.akker.be/temp-departure-12mths.php into a browser I get a message saying “Unable to find Flashgraphsconf.php … script terminated”.
Putting http://www.akker.be/Flashgraphsconf.php into the browser gives a 404 (not found) response so I’d say look for the Flashgraphsconf.php file on your server, make sure it’s there and that the file paths in the script are correct. :wink:

Have put my flashgraph-conf-file in my mainroot, but to no avail, it worked perfect until a few days ago.

Now it says “Unable to find FusionCharts/FusionCharts.php … script terminated” when you enter http://www.akker.be/Flashgraphsconf.php into the browser.
So, in the Flashgraphsconfig.php it’s looking for a file called FusionCharts.php in a folder called FusionCharts but it can’t find it.

This is all looking like there was a change made in the wxglobalwarning.php settings which has altered where the script looks for the other files it needs to work. Was Flashgraphsconfig.php originally in the FusionCharts folder on the server?
If so, then put it back there and check the file paths in wxglobalwarning.php and make sure they point to the correct location.
If not then check that the file paths in Flashgraphsconfig.php are correct for where you have the FusionCharts.php file located.

Gonna have a deeper look into the files, looks like my webhost has done an upgrade but mangled a few files…!!
Thanks so far Budgie!

Had a peek and this is what i get when i open this: http://www.akker.be/Flashgraphs/flashgraphs.php
So the script is working, but i’ve changed nothing here?


Got them working back again, my testtags.txt was replaced with an old one from the sever wich did’nd incorporated the tags needed for the script to work properly.
Thanks anyway for trying to help me out…


Hi guys,
i’ve noticed that my rain temp trends script isn’t correct.
Below the table:

Average 12 Month Rainfall since 2007: 872.40 mm
Rainfall for last 12 months: 1,178.20 mm
Current 12 Month Rainfall difference: -871.40 mm

It’s wrong!
The results should be +305.80
Probably the comma (1,178.20) is the issue!
How could i fix it?
Thanks in advance,


Link: http://www.meteocarmignano.it/wxraintrending.php

Hi, Allessandro!

I do not have a comma between the thousands? You can see this in the screen print which i’ve attached. i am now looking what could be the reason that you have it…


I’ve found my issue :slight_smile:

I’ve change this code from:

trends_gen_difference(",", "",$monthraintrend, $avrainalltime, $uomRain, 


trends_gen_difference(str_replace(",", "", $monthraintrend) , str_replace(",", "", $avrainalltime) , $uomRain,

Now it works correctly here: http://www.meteocarmignano.it/wxraintrending.php :wink: