WeatherFlow Tempest does not show live data, will only retrieve history data

When I set up my new WeatherFlow Tempest station with Weather-Display everything worked fine for about 2 weeks. After that Weather-Display no longer showed live data. I couldn’t figure it out so I installed Weather-Display on another computer. It ran great for a few days and it stopped also. I read on the forum that antivirus software might be the cause so I disabled that but still no luck. I checked multiple times after restarts and even disabled my firewall without any change. I also deleted my windows registry and re-setup the Tempest without any luck. I also made sure I followed all the setup procedures for WeatherFlow. Which really should be fine because it worked properly for a couple of weeks. When I start Weather-Display the first thing it does is bring up the Weather History Data window and downloads all the historical data and closes. I see Cronsweatherflow vers 6.1 is running with data updating constantly but Weather-Display will not update. I am using a computer with windows 10. Weather-Display version 10.37S120. I attached a screenshot which I hope will help. Hopefully, I am not missing something obvious. Please advise, Thank you.

i suspect the problem might be to do with the sensor names
if you could email me your settings file
from the databackup folder
after going action, back up windows registry entry now, in WD

After ticking action, backup windows registries entry, it did not update to today’s date. I tried to attach the latest backup dated 102020 but it said the file was too big.

attach to what?
my post above says to email it to me
not to post as an attachement to a forum post (not a good idea to put your settings on a public forum)

O.K. Thank you.

the problem is you have set WD to use the data from a downloaded metar
the clue is that it says that across the top of WD
see the attached screen shot

you need to unset that in control panel, ftp/internet setup , metar download

then restart WD

see screen shot, un set all circled

the other thing you have set wrong is the weather flow station ID
it looks like you have entered the serial number

you can find the station number in the tempest app, public data settings, share page, see the number shown there at the end of the URL
Maybe I need to do a youtube video on that

That databackup zip I sent you is not my current settings. When I tick on Action, Back up Windows Registry Entries it creates the file wdisplayftp.reg. I’ll send you that one.
What’s interesting when I first set up the WeatherFlow Tempest I did have the wrong number for the station I.D. It was working like that for a couple of weeks. When it stopped working I seen I had the incorrect station I.D. after I watched the youtube video. So my current settings have the correct station I.D. and I also have the Metar download set as you show. It’s also interesting how it retrieves all history data with no problem. It still does not update live though. I’ll send you some screenshots of what I think will be helpful to you. Thank you.

make sure to not have ticked to use the downloaded metar for WD’s data
since you did have set to use UDP data in the cron program, then even with an incorrect station id , you will get data that way

I did turn off metar data download, save and exit, and restarted computer, still no change. The Cronweatherflow vers 6.1 does continue to run and update data pretty rapidly, but the main screen just stays the same (does not update). I also see WD Send Tether Data Vers 2.0 running with error, can’t send, argument out of range. I do not know what this is or if it matters. I have been working on trying to figure it out for the past few weeks. Please continue to advise. Thank you.

you must have set to use the send tether data
so i would unset to use that
under setup. send data to WDlivepp

if you could .zip and email me current settings files
and wdisplayftp.reg, after going action, back up windows registry entry now in WD

I see another problem with your latest settings
you have set to use your weather flow data with another weather station type…but your weather station type is a weather flow
so unset those settings
under setup, advanced/misc, weather flow tab

see the attached screen shot

Yes, I do. I changed that but Weather-Display still does not update.

.zip and email me your latest updated settings files as there might still be something else set wrong maybe

Now my WeatherFlow Tempest station stopped working completely. So maybe there’s no issue with Weather-Display. Yesterday morning the station stopped sending data to its own program. So I climbed the latter, took it down, turned the station off and back on and it started working again. I started weather-display and it started updating live. Surprise! This morning the station stopped working again. I’ve only had the station for about 3 months. Also, this is my second station because the first one they sent me didn’t work. Bad radio they said. So now I need to find out from WeatherFlow what to do now.

I don’t have the Tempest, I have the original, I think they call it the Smart Weather now. Anyways, my HUB quit working a few days ago and nothing I do will bring it back to life. It’s been offline for 7 days now. I emailed WeatherFlow and they may be sending me a new hub. I don’t know if this is related to your problem or not but wanted to mention it. Now I’m wondering if one of the firmware updates they pushed out is causing issues…

A few days ago I had similar problem.
Took the sky down and opened the batterij lit, moved the batteries a bit and closed the lit.
Flashing green light which was good, then my hub connected again after booting it up.

Now I don’t have a green light on the hub but I do have data in WD.

It turns out there is no issue with Weather-Display. After the station stopped working completely I contacted WeatherFlow. They said that the Tempest station’s battery was failing. So when the battery started failing it stopped updating Weather-Display but the Tempest app was still working for a while until the battery completely died.
I just received my 3rd new station and everything works fine now. Just the outside station was replaced, not the hub. So the whole problem with Weather-Display not updating was the Tempest station battery failing.