WD not going below 0.0F Texas Weather Inst

Hi Brian,
You worked on a issue with my station type couple months back with the indoor temp not displaying correctly in WD.

This morning for a first time in a long time, we dropped below 0 F.
I recorded a low of -5.1 on my station console, but Weather Display shows the low at 0.0.
Warmed up to 2 above today, WD was right, soon as it dropped below 0, WD stays at 0.0.

Texas Weather Instruments Station.
I choose WLS 8000 High Resolution type in WD under station type.
WD ver 10.37R ver 74.


I have done some work on this recently
you should be using the latest version

Latest version installed just now. No luck, still shows 0.0. Actual temp -3.1F.

Your help is appreciated! Thanks!

you must be using a different hadrware version than the person I worked on this with
you will need to set the log raw data and let me know what shows under view, WS2010/WS2500 data setup

see attached
Current temp -2.0
appears to be #10


try a new .zip update, ready now

Thanks Brian.
We are above 0 now, forecast to stay above 0. I’ll let you know.
Thanks for working on this.

Resurrecting an OLD thread. My TWI WR-25 has a firmware bug that distorts reporting below zero temperatures. It reports them as “0-nF” instead of the correct form “-0nF” where n is the temperature. Typical software conversion routines barf on the bad temp string. I implemented workarounds in wview and now the weewx twi driver but I’m completely unfamiliar with WD.