WD Linux Console - "Inconsistency detected by ld.so" Ubuntu Hardy

As a newcomer here, though I bought a copy of Weather Display many years ago, may I thank Brian for his Linux port of Weather Display, and especially for the idea of WDL console, which is exactly what I need so that my server can capture weather info from my Irox copy (TFA)

I’m having a problem though. When I run WDL Console on my laptop running Ubuntu Hardy, it all works perfectly. I have the same USB udev config etc on my server, yet when I run it at the server, I get the following error:

Inconsistency detected by ld.so: dl-minimal.c: 148: realloc: Assertion `ptr == alloc_last_block’ failed!

I have tried all kinds of library options after much forum reading, but can’t get it to alter this behaviour. I have also tried altering the vm.mmap_min_addr amoutn etc, to no avail. Of course, the builds of my laptop vs the little server are likely to be different, most notably that the server was updated from Gutsy to Hardy, but I’ve run out of knowledge.

Has anyone got any ideas? I don’t fancy a rebuild of my server. My next step was to get a VM going under KVM or QEMU to run this, but it seems like a lot of trouble.

Many thanks


there is someone else who has this similar problem
but many who do not
I cant help much though, as I am not a Linux Guru

could you do :
ls /lib/libc* and post the result?
could you tell us more about the “little server”.


libc-2.7.so libcfont.so.0.0.0 libcom_err.so.2.1 libcrypt.so.1
libcap.so.1 libcidn-2.7.so libconsole.so.0 libc.so.6
libcap.so.1.10 libcidn.so.1 libconsole.so.0.0.0 libctutils.so.0
libcfont.so.0 libcom_err.so.2 libcrypt-2.7.so libctutils.so.0.0.0

And the server is a mini-ITX Via C7-based board, which dmittedly is different to the Intel in my trusty old IBMX31 but it runs the same Ubuntu kernel (generic). It’s very stable. It runs postfix, dovecot, mysql, lighttpd, dnsmasq, various security apps - a general server.

Last night I knocked up a jeos-based qemu VM on this box, with USB passed through and got WDL Console working on it, and that really does have minimal libraries as standard.


You may not be guru, but you’ve clearly got a clue about Linux. The provision of a QT-based version of WDL shows that, IMHO.

With this type of error, I’d have expected a compilation problem, perhaps relating to the Irox, but the fact that it works on a differrent box and a VM has me floored.


My guess is that libc 2.7 is the cause of your problem.

You could be right, but it’s the same as on my laptop and the qemu VM. Quite a puzzle. I’ve got a workaround with the VM at the moment, but I thought I’d better post the info in case it helps Brian with the progress he’s making.



is qemu VM a windows emulator? If so WD windows will run like a charm, since it uses the windows dll (usb.dll,…). I’d rather think this error is linked with the architecture of you PC . are you using a 64 bits processor and linux 64 bits?

Thanks for the idea, but I don’t have a license for windows, and even if I did, Brian is one of the few developers who understand the need for linux versions of software.

qemu is a virtual machine, so it can run pretty well any operating system. qemu was developed by a countryman of yours, Fabrice Bellard and is a brilliant bit of work. Many other virtual machine managers depend on his work, such as VirtualBox. In true Free Software fashion, there’s quite a range of supporting management utilities, such as vrt-manager etc. I have used it in anger in the past, at a disaster recovery centre, to re-create physical machines for backup and recovery purposes, and found it to be very flexible. One of the tricks it can do is emulate completely different architectures, so you can have, for example, a virtual multi-cpu system on a single processor host, or emulate SPARC, MIPS or ARM systems on Intel. (Oops -sorry - here ends the lesson, but I think highly of qemu)

No, it’s not a 64-bit machine, and your guess about the architecture is possible, but, I think, unlikely. It’s rather more probable that there is some library hanging around from the upgrade from the previous version of the operating system.

The qemu option is working well, and gives me access to the clientraw data as well as creating a suitable wxlocal file, which should suit me fine.