WD appears to have exploded.

WD locked up a few hours ago. I noticed it only because I saw my camera image had not updated for a few hours. NOTHING has touch this machine in days so nothing would have been changed.

I closed it down the best I could (meaning it was locked up so a proper software shutdown was NOT possible.) Rebooted the machine.

WD goes through the loading at startup process as it always has but I never get the main screen … keeps telling me WD is not responding. #-o

I rebooted multiple times, allowing 5-10 minutes of run time between each reboot to hopefully clear whatever mystery it is running into.

After multiple reboots did not solve the issue I did the following:
I have retried reloading the WDISPLAY.INI from yesterdays backup.
I have tried reloading the REGISTRY entries from yesterdays backup.

Since then I have rebooted the machine at minimum of 10 times in last hour or so hoping to see WD recover. I get nothing. All I see is WD is not responding. No Main screen whatsoever… I get a tray and taskbar icon and nothing else. No temperature or anything on the tray icon as would be normal. I cannot bring the main screen up no matter what I do. Nothing is working and something has seriously hung WD at boot up. Any help would be much appreciated.

Remnants of Harvey is to arrive sometime this evening or early AM with heavy rain and wind and I truly need this running tonight if possible.

What can I do to recover this please??

Since nobody else has responded…you can try moving/renaming the ini and reg files and see if WD will start up. If it does then you know the problem is in those files. If WD still fails to start then I would download a full install and see if that will run. If it does then re-install the ini and reg files.

How do you rename the REG file? Not sure what file that is.

I did rename the WDISPLAY.INI file temporarily. I was asked when I tried ot start, what language. Once chosen, I ended with the same result… nothing. Hung.

As long as they are backed up in the backup folder you can delete them from the wdisplay directory to see if WD will start up.


The 2 files you will need.

I would make a copy of those 2 files in case WD decides to overwrite them if it starts up…keep’em in a safe place.

Both files are constantly backed up (all my backups are) on a remote drive.

There is NO wdisplayftp.reg in the wdisplay main directory. There is obviously in the backup dir.

Regardless, something trashed itself earlier as no matter what I get notta.

I guess I am gonna have to take my chances and install from the main install… NO choice as I GOT to get this back online ASAP. Today will be a complete loss of data, most likely.

Well now I REALLY am in a pickle. Rebooted… Reinstalled from ORIGINAL FULL install and I am coming in with the EXACT same thing… nothing.

Any other thoughts?

What version of WD?

Whatever latest version is on download site… believe it to be b56

try as a test
install to a new directory
create a wd2.txt file there
then run (should start up with no settings)
and setup the basics needed to get data
as a test

Maybe this is something to do with WinBLOWS!!!

On the new install, I get to the register screen, tell it “later on” and it fully closes… does not even try to proceed further.

You could be right. The only idea I have left is to try an older version of WD. Maybe try build 81 in the new directory with the wd2.txt file. Make sure the name is exact, not wd2.txt.txt (make sure you are allowing viewing of extensions in your file listing).

I suspect some file that WD is attempting to load is corrupted in your wdisplay directory. The month inf file or log file perhaps.
You would need to talk to Brian to find out which file could prevent WD from starting up. The wd2.txt file should bypass all that and allow WD to startup clean, hence the suggestion to double check the exact filename.

I cannot believe this… no warning… just locked up and now it is toast!!!

I really do not want to go back to a really old version of WD. I cannot believe this has happened. Based on my investigation it appears to have blown up at or near 5:17 PM this date as that was that last time the testtags wrote, last clientraw entry etc.

I just do not get this…

Windows is operating fine and I have had no issues with the OS since I rebooted, able to do whatever I try to do. This BOX is only for WD so once it is up and runing I do not go near it for days unless I notice something amiss or I notice a WD software update is available. Other than that, this machine is rarely touched.

I suggested an earlier version as I see the version on the download page is from today’s date. It’s possible it is not fully functional.

I am uploading my last full version of WD to my server. I will post the link to it once it finishes.

Understood, but I had run the latest update a few days back (Friday or Saturday) which was also listed as 56. It was running fine up until about 5:15PM (CST) today. I’m still scurrying around hoping to get this recovered by midnight, but this is not looking promising.

I just completely deleted it again… uninstalled properly.

Now I have a tray icon but no main screen. So I have no idea what it is doing. I tried to click on the tray icon but it does nothing.


What version is that? I appears to be similiar to what I have… but will try it.

Build 56 from the 22nd of Aug.

As far as troubleshooting that’s all I can think of to try. If the wd2.txt file is used then WD should startup like brand new install. If you have a tray icon then all I can think of is WD is opening off your screen. You would need to search the forum for old posts where Brian mentions the setting that controls that. I’m not 100% sure the wd2.txt file function still works, it’s been a long time since I used it and Brain may have removed it. If that’s the case then I would pull up your ini file in a text editor and see if you can find the setting for screen location.

Sorry, that’s all I can think of to try. Wish you luck in finding the cause…73

OK, well it is showing as b55 which is no big deal. However… no change to my issue.

The Tray Icon loads, NO RapidUpdates or FTPs load… If I force them they will load but since the main program does not seem to be functioning I am sending in old data.

I do get a taskbar icon but it is pure white with the WD logo in the middle of it (most likely the icon loading). Nothing is resolving this issue. Seems something is missing maybe in WinBLOWS? Although I can find no issue with it and nothing reports in. I cannot see any error logs for WD so That is not going to assist me.

Hum… ](*,)

When you note make a wd2.txt file… I assume this is a blank file in the wdisplay (or new folder) root?