WD 1037Qb44 chart not updating [RESOLVED]

Not sure what you are asking, but WD takes the actual reading 24.9+ and applies the offset (5 inches) that I have entered somewhere in WD and then displays the corrected number of 29.9+ on the screen and in the graphs. Even when the readings from the new one wire reader were flat lined, the barometer reading were fine (not flat lined)

One other thing I saw of interest yesterday was that the name is set at the default of noname (thus the noname.html) and on one of the pages near there or maybe the same page there was a setting that I have never changed asking for the name of the main webpage, it is set to the default “table” --just something I wondered about, I have never changed either of those settings.

number of 29.9+ on the screen and in the graphs
thats the info I was looking for

note that the 1 wire reader will not show the barometer if using the separate aag baro program

try using the customise internet and file creation setup override to set the times to create and times to upload, and remote file names, for you web site
(recommended, that way you have complete control)

As far as I can tell there is no problem with the baro program and reporting, somewhere I have the box checked saying that I have the AAG baro so it uses the separate program to read it.

I will turn on the customize internet and file creation next time I am at the site and try that for the noname.html problem.

The problem remains that on any start or reboot the new one wire reader program will only see the internal sensors on the AAG unit on startup and does not see the extra sensors (humidity [also used as main temp] & interior temp) unless the Save button in the onewire is manually pressed, then of course they flatline the external sensors on any start or restart.

Is it possible that the external sensors cannot be initially read until the AAG baro program has run first?

what exactly is/providing the extra sensors?
from a aag barometer, and or?

there are no other reports of a problem with extra temp/hum not working on start up of the separate 1 wire reader until the save button has been clicked
can you post a screens shot of the 1 wire reader program ? (setttings screen as well)

I provided screenshots in reply number 6 this thread. One initial screenshot showing that the onewire reader sees the wind direction, internal temperature, and wind counter from the AAG weather station and the counter from the rain gauge on initial startup.

Then after pushing the save button in the new onwire reader it sees the additional external sensors, HUMIDITY & EXTRA TEMPERATURE and assigns all the sensors properly. Please see the images provided in reply 6 to this thread they show initial sensors and the added sensors after pressing the save button.

I will get another screenshot to you of the settings on the onewire reader. The sensors are each shown there individually.

I have not reported any problem with the AAG barometer, it always works since it is not read by the new onewire reader.

All of this works just fine in 1037P-44 and the problems are associated with 1037Qb-44 only.

In an attempt to somehow move this forward, I will remove the barometer and see if there is any change in the one wire initialization of the humidity and extra temperature sensor.

prior posts

I have the AAG barometer, I see the AAG reader run once in a while in the “tray?”, if I watch.
Also have an AAG standalone temperature sensor (indoor temp) and an AAG humidity sensor (outside humidity & temp)
I don’t use the temperature sensor in the one wire unit for anything, but it is seen by the reader.

The barometer operates correctly, a raw reading around 24.9+ inches, corrected by adding about 5 inches because we are at 5000 feet above sea level. The reading is changing throughout the day as it should.

looking at the screen shot of the 1 wire reader, for some reason, for your setup, its not finding the extra temp/hum sensors on the first search
(have not had any other reports of that particular problem before with the new 1 wire reader)

this version update will search again on start up for sensors

http://www.weather-display.com/downloadfiles/dallas1wirereader.zip

As far as I can tell that new aagbaro.exe does not work in 1037P44 or 1037Qb44

I had no problems with the old aagbaro reader from years ago.

The new onewire reader from the zip keeps on reiniting, but the results never show up on the main display screen. I can also tell you that I could find no way to make it see the humidity sensor as the main temperature sensor, it will only see the in unit sensor or the #1 extra interior as the main temp. It does see the humidity sensor though, I know screen shots are needed… next time.

I spent most of my time just trying to get 1037P44 back up after the new aagbaro took over, I did not have my full aagbaro backup with me so I ended up taking off the barometer for now. Will test new versions with the baro off soon.

the new aag baro reader works OK here with my aag baro

Ok, it works for you… I am going to try again today with 1037Qb46 and the new aagbaro that you sent me, without the ever updating onewire reader that scrolls and scrolls that you sent me.

But first the test without any barometer, since I took it off yesterday. It might be better to just work through the other problems first. Did you mean for that special onewire reader to just keep reiniting all the time and scrolling, seems like two minutes after startup would work. There was an checkbox option to reinit once an hour in the old onewire reader as I recall.

Where would I enter the ROM address of the humidity sensor to make the onewire reader use its temperature as the station temperature. There was a checkbox in the old onewire config before to check to make that happen, it is still checked. The humidity sensor is seen by the new onewire reader and the address is in the humidity box. Placing the humidity sensor address in the main temperature box above that does not work.

Thanks

no, of course I did not mean that to happen
that was a mistake

I have a terrible winter cold and have been feeling awfull, so that has not been helping
download a new update to fix that

note that the new aagbaro has also been working OK for others, not just me

Where would I enter the ROM address of the humidity sensor to make the onewire reader use its temperature as the station temperature. There was a checkbox in the old onewire config before to check to make that happen, it is still checked. The humidity sensor is seen by the new onewire reader and the address is in the humidity box. Placing the humidity sensor address in the main temperature box above that does not work.

no, do not enter the hum rom in the temp rom
that will not work

instead set to use the hum temp as outdoor temp in WD (or in the separate 1 wire reader, 2nd tab (then restart WD for that setting to take))

Hello again,

Hope you get well soon, making progress here.

The workaround to have the noname.html file created in the internet creation and upload worked.

The barometer was being read with the new aagbaro reader but it was not updating on the screen (I could see the changes in the old dallas onewire baro set up screen). I reset the offset for the barometer and restarted, now the readings are on the screen.

With the barometer connected, the initialization of the new onwire just will not see the humidity sensor and extra temperature. If there were a delay off a couple of minutes, or a reset of the onwire reader after a couple of minutes then perhaps that would fix it. It appears to work that way in the old onewire reader.

Attached are a couple of screenshots. I could not get the indoor humitdty display to go away in the main screen, there is no indoor humidity sensor.

I am going to run 1037Qb-46 without the barometer and see how it does overnight.

Thanks


ala cap wdisplay indoor humidity.jpg

ala cap 1wire other.jpg

I have fixed the constant re reading of the 1 wire sensors

Also I have changed the aag baro to use the registry to transfer the data…the problem with using the buffered wdisplay.ini file is the data is not updated

all in a new .zip update of WD, ready now

Hello again,

That new aagbaro does not work, I was fortunate enough to be able to read the display pop up window by clicking the tray icon and it says “no rom…”.

I ran the prior version manually, and it did read the barrometer and I could see the results in the pop up by clicking it in the tray, all of this happens to fast for a screenshot. Of course it can’t report to the WD program due to the latest changes.

It appears the new onewire reader is working properly, fingers crossed.

Thanks

Got a better look at the aagbaro error:

Memo 1
no roms in the list

=============================
I lost the all time records installing the Zip

no other reports of the all time records being lost, and that has not occured here either

Hello,

You gave no response to the aagbaro.exe error, or is it still “it does not happen here”

The new aagbaro from the 6/18/11 zip fixes the aagbaro problem, I had to hunt the answer down in another thread from a user that had the same problem (aagbaro flatline).

That zip replaces the taglist.txt file, to me this appears to delete the all time records, I manually edited the file to recover the records. I am not sure what happened there, I recovered the records though. Edited the wdisplay.ini I think (cut and paste from the backup).

I think all of the major issues in this thread have been resolved.

Thank you

I’ve had several problems recently. First the PC crashed. Reinstalling WD on a new PC I have had problems, all solved apart from the barometer flatine.
Using OneWire Viewer (different from Reader) I was getting constand CRC Bad errors from the 1 Wire AAG barometer. I bought a new barometer.
That works with Viewer. I’ve updated the ROM number in Reader but WD is still showing a flat line. aagbaro.exe latest version? 6/12/11 does not “pop-up” on the task bar and opening it shows “no roms in the list”.
Any suggestions?

The new aagbaro from the 6/18/11 zip fixed the aagbaro problem for me. The 6/12/11 version did not work.

I’m not sure where I got 6/12/11 from. I’ve just checked again and noticed it’s 24/06/2011 (6/24/11 in USA date format) and is version 9.5.2.0
but I have downloaded the latest version of WD - 10.37Qb82
aagbaro is not appearing on the task bar - it usually just flashes up for a few seconds (every 30 seconds?). Launching it manually still gives me ‘no roms in the list’.