WAP upload does not work anymore [RESOLVED latest update]


I had WAP up and running, all worked fine.
Yesterday, after installing a new WDisplay zip update it stopped uploading.

I can still generate the wml file in a local directory, also with a custom waplocal.txt.
I can still “create WAP directory for the first time”. → I get a new /wap on my FTP server

But I don’t get any data on my FTP server if I push the “Test” button and also not at the scheduled time.

Clientraw upload works still fine.

Any idea what the problem is?
I went already back to the old WDisplay version, but this also don’t work anymore for WAP.



Have you tried using the full update and then the most current zip on top of that?

What does the error logs say?

what shows in the Ftplogfull.txt file
also make sure you firewall is not blocking the updated ftp program


I hadn’t visited my wap site in a while and mine also appears to not be updating.




Same here - wml page stopped updating after I earlier this today installed latest full version (10.37N build 14)

The index.wml is updated in the webfiles folder - but the upload is missing.

Here is the ftpfulllog.txt:

list of files uploaded*
actual messages from upload session*
Start Time/date:22:09:00 26-02-2009
Permanent connection selected
Permanent connection, will do ftp now
Finshed email agenda
Finshed email agenda, and more Internet agenda items to do (FTP)…
Time/date:22:09:01 26-02-2009
Logging onto FTP server…web10.gigahost.dk
Connecting to FTP server.
220---------- Welcome to Pure-FTPd [TLS] ----------
220-You are user number 12 of 150 allowed.
220-Local time is now 22:08. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
331 User jwwddk OK. Password required
230-User jwwddk has group access to: jwwddk
230 OK. Current restricted directory is /
200 TYPE is now 8-bit binary
Changing Directory to www/silkeborg-vejret.dk/vejrdata/
CWD www/silkeborg-vejret.dk/vejrdata/
250 OK. Current directory is /www/silkeborg-vejret.dk/vejrdata
Checking for next FTP agenda…
there are 1 more things to do
DELE index.wml
550 Could not delete index.wml: No such file or directory
Doing abort procedure/program close…

I have this setting in serverpath in WAP controlpanel:


But it seems that its not changing directory.

Best regards,


i think the problem is with the delete of the index.wml file (in the normal directory) then causing the upload to not carry on, when that errors
(that file is deleted in the normal directory, in case it is there, because having a index.wml file there overides a index.html or index.htm as the home page

anyway, the upgrade in the ftp component must have broken something
I will investigate that now

yes, the problem was with the upgraded component
I have had to remove the delete index.wml from the code
version 9.07 of the Ftpupd.exe is now included with the latest .zip update and I am updating the full install now too
I also fixed something else that probably has been causing a problem for a few users with the updated Ftpupd.exe due to the updated Ftp component

Hi Brian

Its working now - thank you very much for your help.

Best regards,



Brian, what should I do now? Shall I update Ftpupd only? Are the different version of WD (the debugging versions as well) compatible with different versions of Ftpupd?

I am bit stressed because my weather page is now published by our communication/web officer and I need a stable running system.

Greetings, Uta

you can mix and match
the latest .zip update or latest full install update has the latest Ftpupd.exe version included (9.08)