VVP - Com port doesn't exist

I recently installed Virtual VP v Beta (I had thought I was downloading the “stable” version, but that’s not what I got when I clicked on that link), and the N8VBvCOM driver. VVP seemed to connect to my Davis Vantage Pro 2 weather station module just fine (it showed that it was downloading data from it). But when I tried to connect my Weather Link software (v. 5.7) to VVP (port 6,7, 8, or 9), I got a message saying “Weather Link tried to open a Com Port that doesn’t exist on this system. Please examine your Com Port settings”.

I’m not having any luck investigating this problem. A search of Windows Help doesn’t yield much of anything that’s relevant. I wondered if maybe there’s a conflict with Windows Firewall, though I didn’t receive any error message that Windows Firewall had blocked anything. I thought about trying to create a port exception in Widows Firewall, but Serial port wasn’t a choice for type of port to configure (only UDP or TCP).

I’m running Win XP Pro, SP2.

Thanks for any help/suggestions.


Does your computer already have physical com ports installed?
Worth checking in device manager and expand ports tab (see attached)

If you have higher than com4 these can clash with the default settings in VVP



Thanks for your reply, and sorry for the delay in answering your question - I was out of town all last week.

The Device Manager doesn’t list any comports above com4 - it only shows communications port (com1), a bridge controller (com4), and lpt1.


I would try VVP version 1.1.4 - http://www.softwx.com/weather/virtualvp/VirtualVPSetup-1.1.4.exe

Just installs on top of older version.

Also is your Davis Interface USB or Serial and which com port does it use?


Actually, after I posted the question about my difficulty with VVP, I did download the more recent version of the program, but it didn’t make any difference.

The Davis interface is via USB port. It uses comport 4. I don’t have enough much of an understanding of ports like this, but when I first opened Weather Link, there was an option for it to automatically detect the weather module, and it “found” it on comport 4.


It’s hard to say without getting more detailed information, but my first suggestion would be to uninstall and then reinstall the N8VBvCOM driver. To get a better understanding of what could be causing the problem, I would need to see the log.txt file. In windowsXP, it’s in the VirtualVP folder. In Vista, it’s buried under the Users/{username}/AppData folder hierarchy. If you can email me that log.txt file, that would help.