Vp2 soil sensors = WD not responding

Hello…new user here. I have a vp2plus that I installed in March, with meteobridge. I installed WD a few days ago on a spare laptop, installed fine, set the meteobridge ip and port, and started receiving data. When I first set WD up, I checked Davis weather station, plus enabled all the sensors I have, solar, uv, soil temps, soil moisture, leaf wet, etc. I really don’t remember ever seeing my extra sensor, even in the Davis extra sensor view. Since then this laptop has been shut down and now I can not get WD to see those sensors. After I startup WD, when I go back to station setup, everything is unchecked. Davis vp2, rain gauge, baud rate are highlighted blue, but unchecked. Even at the top drop down says select station. After I select station and check everything I have, wd becomes very unstable, I get alot of Not Responding, but I can see my extra sensors (uv, soil, etc) Nothing updates. If I just restart WD, and leave alone, it updates but I have no extra sensors. Ideas? Thanks

I will need to check if extra data like that is handled via the meteobridge data
and how that relates

have you tried selecting a davis station type as well as meteobridge?
when WD is sluggish etc is there any error under view, program event log?

any chance you can make your meteobridge port forwarded ?

only thing i see in log is

VP reception #1 30640 #2 696 = 98
It keeps repeating OK OK OK done etc

WD will not update if i select davis station type.

If i start WD, its fine, just no extra sensors. If i go to Station Type and Settings, drop down says Select Station. Within Davis tab, Davis Vantage Pro is highlighted in blue, as well as Davis rain gauge is 0.01 and baud rate. All sensors that i have enabled are unabled now. If i enable everything that i have, click Close and Save, then Ok…WD display freezes. No updates, but I can go to View, Davis Extra sensors, i can see all my sensors data, just isn’t refreshing. It’s almost like WD isn’t keeping my station fields in memory, but why does it lock/freeze up. I have always had Meteobridge enabled.

Possibly if told how :lol: :lol: :lol:

one problem is that meteobridge is not tied to being just for Davis VP
i.e it works with other hardware as well

WD should though be picking up the extra sensor data that it does provide

what I need to make is that with the meteobridge selected, the Davis extra sensor screen will get updated to show the extra sensor data that is coming through from the meteobridge

Brian, if you need to do some testing and access to a Meteobridge connected to a VP2 with similar configuration, leaf wetness, and soil. Just send me a PM and I will configure access

I even thought about doing an uninstall, removing everything wd etc and installing again. Maybe there is something corrupt. But I don’t know my registration key. Just a thought…I guess that’s why I am here

do you mean you have the same issue Brientim?
(if so that would be great if you could do that )

No, however I haven

try a new .zip update re the extra davis settings not being remembered

tested and the update retains the configuration and now displays extra sensors after restart

Did the update. All settings stayed after restarting. Soil temps showed up. WD still seems a bit laggy. Might be my laptop. Let me get a new laptop and I will report back. Thanks

what I should do is have the data gathered by a separate cron program
I can do that, and just need a tester
(or even better have someone make their meteobridge available via port forwarding)


I have a busy day with my daughter


I have the same problem as in the first post.
I have a vp2plus connected witch meteobridge, I set in WD the ip of meteobrigde and it’s works great.
only the extra sensors (soil) does not work, it’s only works if I select a davis station type as well than I can see it in davis extra sensor view, but the data are not logged (I need it for my website).
also after restart WD the station type is uncheked.

If you needed I can make my meteobrigde available.


now I understand better
WD is not handling or expecting that data, as its not thinking its a Davis station
I can fix that :slight_smile:
you will need to test…

it would be great, I’m ready to test :slight_smile:

try this update:
no gaurantees

Hi Brian,

I did soms test, now I can see it in davis extra sensor view.
but the data is still not saved/logged in extra sensor graph, clientraw, daily high/low.

I set on station type to use soil temp1 as extra temp 1 and soil temp 2 as extra temp 3.

I did soms screenshot of my problem


try another update
and see if a few more things working

no change with this update