Unhandled exception in the application

Hello friend, I don’t think I really understand how the forum works. I think the best thing to do would be to have sent you a private message so as not to overload the forum. Thank you very much for your offer to help me resolve the error. I am not an advanced user and my level of English is low so I am forced to use Google Translate. I hope we can understand each other.

I’m not sure what you’re asking of me. I can’t find the wximate log, but in exchange I will give you a copy of the error it generates.

I’m at your entire disposition

12024lg.txt (2.5 MB)
122023lg.txt (3.2 MB)

Consulte el final de este mensaje para obtener más detalles sobre cómo invocar a la depuración
Just-In-Time (JIT) en lugar de este cuadro de diálogo.

************** Texto de la excepción **************
System.IndexOutOfRangeException: Índice fuera de los límites de la matriz.
es wxsimate.Form1.localimport()
es wxsimate.Form1.impdat_Click(Remitente de objeto, EventArgs e)
es System.Windows.Forms.Control.OnClick(EventArgs e)
es System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
es System.Windows.Forms.Control.WmMouseUp(Message& m, botón MouseButtons, clics Int32)
y System.Windows.Forms.Control.WndProc(Message& m)
y System.Windows.Forms.ButtonBase.WndProc(Message& m)
y System. Windows.Forms.Button.WndProc(Message& m)
y System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Ensamblados cargados **************

Versión del ensamblado:
Versión Win32: 4.8.9195.0 compilado por: NET481REL1LAST_B
Código base : archivo:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll


Versión del ensamblado: 1.0.8600.27981
Versión Win32: 1.0.8600.27981
Código base: file:///C:/wxsim/wxsimate.exe


Versión del ensamblado:
Versión Win32: 4.8.9195.0 compilado por: NET481REL1LAST_B
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4 .0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


Versión del ensamblado:
Versión Win32: 4.8.9214.0 construido por: NET481REL1LAST_B
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System .dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0 .0__b03f5f7f11d50a3a/System.Drawing.dll


Versión del ensamblado:
Versión Win32: 14.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0 .0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll


Versión del ensamblado:
Versión Win32: 4.8.9214.0 compilado por: NET481REL1LAST_B
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0 .0__b77a5c561934e089/System.Core.dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0 .0__b03f5f7f11d50a3a/System.Configuration.dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0 .0__b77a5c561934e089/System.Xml.dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0 .0_es_b77a5c561934e089/mscorlib.resources.dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/CustomMarshalers/v4.0_4.0.0.0__b03f5f7f11d50a3a/CustomMarshalers .dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility .dll


Versión del ensamblado:
Versión Win32: 4.8.9037.0 compilado por: NET481REL1
Código base: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms .resources/v4.0_4.0.0.0_es_b77a5c561934e089/System.Windows.Forms.resources.dll

************** Depuración JIT **************
Para habilitar la depuración Just In Time (JIT), el archivo de configuración de esta
aplicación o equipo (machine.config) debe tener el
valor jitDebugging establecido en la sección system.windows.forms.
La aplicación también se debe compilar con la depuración

I looked through both files and there I don’t see any errors or duplicate lines that might be causing your issue. I’ll go back through some old notes to see if I can find any additional suggestions to offer you.

I had also reviewed the logfiles, although I recognize that between so many lines I could have missed an error. It is curious because it was working well, but it was due to a downgrade from Windows 11 to Windows 10. The computer that has been around for a while was too slow on Windows 11 although it worked well. I made a copy of everything and performed a new installation of Windows 10. Since then it has not worked. Sometimes I wonder if it has something to do with the net framework, as happened to me on a previous occasion, but the latest version is installed.

The truth is that I don’t know how to solve it anymore. Thank you very much for your attention

Did you contact Tom Ehrensperger and if so have you had a reply? If not I suggest you do contact Tom for advice.


Yes, I sent it a few days ago to Tom ([email protected]) but I haven’t gotten a response. :pensive:

It’s school term time so he’s likely to be busy, especially during the week.

1 Like

Certainly Tom, the times I have asked him, he has been quick and kind. We all have busy lives I understand. It’s a matter of having patience.

Hi, I’m sorry, but I haven’t seen the email, and can’t seem to find one from you (though I’m not sure about your email address). I’ve been trying to keep up, but I’ve been getting close to 100 junk emails (ads, which should have gone to SPAM) every day, and I could have missed a legitimate one. Or it could have gone to SPAM. Can you try again, and I’ll be on the lookout for it?



1 Like

Hello Tom, you don’t have to apologize at all, I understand you perfectly and I know that you are doing what you can.

I don’t care, because it is true that the import of the weather display logfile files fails with the aforementioned error, but look, I realized that I also have weatherlink running simultaneously and in wxsimate I changed the import to the latter and it is working correctly.

Should I worry, should I leave it as is? Sometimes I get the feeling that the WD database is more fragile than the WL one.

I got this one - thanks! :slight_smile:

I’ve frequently seen (through customers, as I don’t use WD myself) problems with WD’s log files. These often occur when there’s a power interruption. When WD starts back up, it sometimes garbles the lines up. I’ve seen parts of one day stuck in the middle of a different day! When I’ve seen these, I’ve generally been able to figure it out and repair the customer’s file (and some took care of it themselves), but it is kind of a pain.

I use WL directly, and can’t recall any such problems. Maybe stick with that! One minor difference, though - if you are using autolearn and/or WXSIM-Lite, you should schedule a WXSIMATE run (NOT a WXSIM one) in the early morning hours (maybe 1-something AM), before your autolearn or WXSIM-Lite analysis runs, so that the previous day’s data will be ready and wating, in a form those programs understand (only WXSIMATE is coded to directly read WeatherLink’s binary files, so it needs to create text files for the other programs’ use).

Please let me know if you have any more problems of questions, and thanks for your patience! :slight_smile:

Best Regards,


Yes, it’s as you say, I have noticed that almost all WD monthly devices have errors, I don’t think they are due to a power interruption since I have a UPS. Perhaps it is the fact of simultaneous data with WL or perhaps errors in the USB to SERIAL converter. However, it doesn’t happen with the WL records, I wouldn’t know why.

I am not an expert user, quite the opposite and of course I have everything automatic. I have made the mistake that every time I had a problem or updated the version of WXSIM I uninstalled, deleted the folder and reinstalled, without realizing that this is an inadvisable practice.

I have added, as you indicate, in addition to those that are already by default, an execution of WXSIMATE at 1:00 AM.

I will leave the rest as is, I think everything will be better.

Thank you very much for your attention.