Unable to open settings.php file check file permissions!

I am having the same issues. I get this when trying to save my setup file:
Unable to open ./_my_settings/settings.php file check file permissions !

And my cron job is not updating anything. permissions on all folders and files are “775” I have tried everything, cant figure it out.

Oceanside, CA Home Weather Station (AWapi version) (alyssasnaturesanctuary.org)

Hi Johnzapf,

Are you having the same problem with your previous website?
Oceanside, CA Home Weather Station (AWapi version)

The scripts work OK as they are allowed to correctly read the settings and data files.

But the new data files loaded are not allowed to be saved. None of them.

Warning: fopen(/home/admin/web/alyssasnaturesanctuary.org/public_html/obvw/jsondata/ambient.txtrnm): 
Failed to open stream: 
Permission denied in /home/admin/web/alyssasnaturesanctuary.org/public_html/obvw/PWS_load_files.php on line 475


NO DATA will be loaded - unable to open file to save data into: 
check permissions of file and folder.

You should not only set the permissions for the folcder, but also for all files inside the folder. It depends on your “FTP” program or hosting file-manager how to do that.

Example screenshot attached shows a button “Apply to enclosed” which set the folder permissions also for all enclosed files now and in the future.

Better ask your webhosting support how to set the file-permissions.
Also compare the differences between your two websites.


Hi Wim,

Artisticimages is working fine. and both sites are on the same server, all is the same just different url. And the artisticimages site has less pemitsions, and it works fine.

I am using mobaxterm for my termanal, I also ran chmod -R 775 on the folder. looks like all are set to 775.

What termanl tool are you using?

it looks like it has enough permissions.

Any Ideas? I have tried everything over the past few days.

Your screenshot shows another folder.
You have to set the permissions of the folder contents for the folders.
Not the scripts only but also the data folders.
As said in a previous post

Ask your provider-support for help, you pay them for their services.

If all fails, please sent an email with your FTP user-id and password.
I will compare your two sites and adjust the permissions.

Please ber aware that English is not my native language. So i can not explain better then I did in previous posts.

Yeah that’s the problem I’m having, permissions are set correctly on all folders subfolders and files and yet it says I don’t have permissions. The other weather station is working fine and it has less permissions than this one. All is on the same server I am the host provider so I don’t get it?

Abd these are the per mission on all the files of the one that is working fine.

Sorry, but you can not repeat the same question time after time without reading the answers in this topic and the previous topic.

  1. Correct permissions for the folder and for the files have to be set
  2. Owner and group ID have to be correct also
  3. Default PHP serrver settings have to be checked

Installation using a decent FTP program or your providers file-manager normally always works OK

The readers of of your post do not know how you installed / uploaded / copied your original website


neither how you installed the new website


Although you mention that they are at the same webhosting company they are two totally independent websites. Both can and sometimes will have very different ownership and very different folder/file settings and very different PHP settings.

If you had followed the normal install procedure download → upload, you had read the error messages from

check 3.3 : file_put_contents: 
result = ERROR 3.3 file_put_contents is not supported, 
?open_basedir restriction in effect  or ./jsondata/ folder not writable FATAL

There are fatal errors:

If you can not remove the errors yourself post your questions at
 the "PWS_Dashboard part" of the WW-forum "

From the outside we can not do any more than repeat what is already said:
Ask your hosting-provider personnel, they know their servers and permissions


Yeah it’s so weird it’s on the exact same server as the other weather station thats working perfectly. Again like I said the server is sitting right next to me I am the server administrator both websites are exactly the same, I copied alyssasnaturesanctuary from the working artisticimages, that is working 100%, All the permissions are set to more than they need.
I’ve been an it guy for 35 years I check everything on my end before I even get on the form.

And that’s what’s weird I copied it from one folder to another all is exactly the same permissions are more than enough so it has to be something else that’s why I’m on the form asking what else it could be.

It can be ownership, PHP default settings, an old website path, and probable a dozen or so other causes.

Even the check program startHere.php shows the error

check 3.3 : file_put_contents: 
result = ERROR 3.3 file_put_contents is not supported, 
?open_basedir restriction in effect 
 or ./jsondata/ folder not writable FATAL

That open_basedir is a website wide PHP setting which can have another value between the old and new website.

That the folder /jsondata/ is not writable can be ownership or something else.


  1. Rename the alyssasnaturesanctuary.org/obvw/ folder to OLDOLD/
  2. FTP a newly downloaded pwsWD/ folder to alyssasnaturesanctuary.org/ and rename that folder to obvw/
  3. Then check if startHere.php will work.
    That way we maybe know what the problem is.

If you have mailed me your FTP credentials, I could have tested every cause.
A waiste of time this discussion for both of us.


So I got it working. I recovered the website from a backup from three days ago before I started messing with permissions so reset all that to default. And then I used an ftp program and copied the weather directory from artistic images and then pasted it to Alyssa’s nature sanctuary and everything worked perfectly. So a lesson learned cut and paste in MobaXterm does not work well.