Setting station type, default alters on boot up

Every time I reboot my computer the default weather station changes & I have to go to the control panel / station type & Setting tab & alter it back to the station I am using.

I have tried to set this using the setup / setup wizard & the exit / save & exit, tabs but still on re-boot the station type has changed & has to be manually altered.

How do I set my WMR100 to the default when the program is booted up?


if using windows vista then make sure to set WeatherD.exe to run as administrator

also, which version of WD? (i.e what does it say across the top of the WD program?)

I’m not running vista, but XP (Professional, if it makes a difference!) I am running Weather Display - Ver 10.37N Registered.

Have this across the top

weather display - Ver 10.37N - Registered -Kestrel W,4.0 mph,6.3 c


i see it , at the moment, says kestral

you should be able to simply click on the wmr100 station type

and then on restart of WD it should be still a wmr100
make sure though that on restart of windows, windows is starting up the correct version of WD from the correct , needed location

thats why I posted up that code, it doesn’t say Kestral, But Kestrel, and when I look at ketral in the control panel it has “none slected” & the WMR100 is selected.

This doesn’t alter the fact that I can’t seem to save my WMR100 as default. what do you mean by “windows is starting up the correct version of WD from the correct , needed location”


after setting the wmr100 station type
and then you restart WD
is it then a wmr100 station type?

then make sure that on windows restart the correct vesion and location of WD is running

I was not worried abou the capital or not capital k in the word kestral

the bit I wasn’t to sure of wasn’t the K in Kestral but I was getting an Kestr(el) not a Kestr(al) to the new user I felt this was the station type but wasn’t sure because of the miss spelling.

I have just re-booted & now have the WMR100 showing, but the data was incorrect as 2 other station types where also checked in the control panel. As previously I unchecked them tried several ways to save the information & AGAIN on re-boot, re-start up the information is losing my preferred default & loading what it wants (which is randomly different each time)

I think I might try re-installing the software, thoughts?


try clicking on none, in the stationless type setup
then on the wmr100 station type
if all else fails, .zip and email me your settings files (see in the FAQ for how to do that)

I “think” I’ve creaked it Windy, I didn’t really want to forward the settings .zip because on looking at the wdisplayftp.reg file I saw it contained all my server details & password. this is with no disrespect to you, I just don’t like doing it.

However on this train of thought, as an experiment I tried the action/delete windows registry entries & restart option, re-entered the necessary entries & after a couple of reboots & restarts it appears my weather station details are now loading correctly.

Thanks for your time on this one, its taken nearly all day! but hopefully I won’t be back on this topic! :smiley: