Problem-77, 101, 109

Thu, 09 May 2024 09:35:50 +0000 = Ecowitt data received:
Problem-77: NO PASSKEY found.
Problem-101: Item in upload: with value between next brackets =><= is invalid
Problem-109: Invalid data:
[test] => test

I checked the ecowitt folder, there is no generated key file present, I am so confused.

Error_Log is empty, the main page shows the station is offline, yet I know it isn’t I am obviously missing something somewhere.

That [test] => test data is from someone testing the link in a browser.
Normally you do that yourself when you are installing the PWS_Dashboard to see if you entered the settings in your ecowitt device correctly.

The file with your encrypted pass-key is generated and stored when the script receives correct data the first time.
After that first time the data received is checked if the pass-key corresponds with the
encrypted one.

Read-me: Ecowitt setup for PWS_dashboard

You have two problems remainnig:

  1. Setup of the custom-upload from your Ecoewitt device
  2. Adept your .htaccess

Most ecowitt devices can not upload to a HTTPS server.
You have to instruct your webserver to allow “old” http accces to the pwsWD/ecowitt/ folder so that your weather-station upload arrives correctly.


you seem to be getting a file uploaded to the ecowitt directory. Check you settings 1st and let the forum know.


Hi swright1957,

Sadly that “uploaded” is not correct.
That file is a demo file (2023-07-24 11:10:33) which is available from within the original download.

If there was a correct upload there always is also a encrypted key array to make sure further uploads are received from the same ecowitt stations.


I finally gave up and decided that as I was using Weather Display, I’d use that, the clientraw is now in the root but I am still having issues with setting it up, although all the settings point to where the clientraw.txt is "…/Clientraw.txt I changed the datasource to ClientRaw - WeatherDisplay no joy with that either nor with the API - WeatherDisplay, the ClientRaw.txt is displaying in CoreFTP and it is populated. Complete loss here!


Sorry that the descriptions on how to upload using Ecowitt custom upload are not helping you.

But none of us is clairvoyant.
It should have helped us to understand your setup if you posted the screenshot of your ecowitt upload setup.
Outsiders do not know how the outside address translates to the real root of your webhosting setup.
The “root” could be
That root is put in the top part of the upload settings in your ecowitt device
For path you enter the rest always starting with a /

In you ecowitt/ folder there is a file which is in the browser addressed as
I think the first part to use is
The second part should be /WX/ecowitt/

For clientraw setup
the main “pwsWD/” folder is the start, "re"named in your case to wx/

You have to use in easyweather setup the name/location of your file relative to this wx/ folder. For your clidentraw is should be: ./clientraw.txt

That ./ tells the scripts to look in the same folder as all dashboard scripts.

This is described in


There is a debug console which also " tries" to show the uploaded data
As you can see your ../clientraw.txt is incorrrect change it to ./clientraw.txt
That ../ moves the folder pointer 1 folder to the left.
A ./ leaves the folder pointer as it is.

The screenshot also shows that your rloot-folder is public_html
Your pwsWD folder is /current/wx/



the ./ got it working with WeatherDisplay so as far as that goes I am happy right now :smiley:

Much easier with WD, it does all the “heavy lifting” for highs/lows, etc. :wink:

Just got to suss the lightning detections and then I will be happy :smiley:

That is the Ecowitt software setup and the FTP directory if that helps

To get the typing right:

Remove the http:// in the ServerIP/Hostname box
Also remove the character(s) before the first / on the Path box

Then the data will be uploaded to the website and there should be messages in the ecco_stats.txt log-file.

Probably there will be only error messages as your website automatically switches http (port 80) traffic to https

The https protocol forbids webservers to accept the data so all http data is discarded.

Solutions for http → https
Wait until the ecco_stats.txt log-file shows incoming traffic without any data:

  1. Maybe your Ecowitt console-device support https.
    Try to set the Port in the 5th line in your Ecowitt setup to 443
    Wait a few minutes and check the ecco_stats.txt log
  2. If port 443 is not a solution, you have to add a bypass for http to https in your .htaccess file.
    If you have a reputable hosting provider, you should ask them to add the lines for your folder.
    Most free or low-cost providers do not want to do that and charge extra for that kind of support.
    I can give you an example how those lines could look, but there are a lot of different hosting configurations.
Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{REQUEST_URI} !^/current/wx/ecowitt/
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

The .htaccess file should be in the root so in the public_html folder


The lightning-data is available now your ecowitt upload is arriving.

One question, just curious:

Why did you switch from WD-clientraw to WD-api ?
The WD-api specification contains a smaller number of fields. soil sensors.

You can use the Ecowitt upload for your lightning sensor and AQ sensors.