OK what happened?

Ok got up this morning and went to check the weather, all I got was the display in the photo below.

What the heck happened? I have tried the backup wdisplay ini file and still get nothing, anyone have an idea on how to fix this??

Looks as though it’s not recognising a station: top line usually gives the station type after “Registered”.

Maybe try Control Panel > Station Type & Settings? Comport settings?

BTW what is your station?

Well I had to reset the comport, and the location latitude and longitude, but the background color is wrong, and all the other settings I had for WD have changed, it’s like the program reverted back to when it first was loaded.

This is what it use to look like.

This is an old photo.

I wonder if you computer did a software update restart and that does not shut down WD gracefully and it some times corrupts the settings
I had an net framework update on 31st August that rebooted 1 of mine that was not expected for me it did not cause an issue

I agree with Harold that the possible cause is WD not shutting down gracefully - I’ve been burned by that before.

Now, to mitigate that, I keep Windows Update on a 5-week pause and restart the updates manually each week on Saturday mornings, then reset the pause to 5-weeks when the update is finished.

But before I restart the Windows Update, in WD I do Start → Back Up Windows Registry Entries, which saves the .ini and .reg files in C:\wdisplay\databackup. I copy those two files to my cloud (OneDrive) in case the PC fails to restart after the Windows update, which happened once and I had to reinstall Windows. Then I gracefully shutdown WD and do the Windows Update.

If anything goes wrong, I have the .ini and .reg files safely stored in my cloud in case I have to reinstall Windows or WD, which will put WD back to the configuration it was in when I backed-up those files.

Yeah, it’s a bit of a hassle, but it’s better than losing all the WD settings and possibly all the records.

Oh, and I do a continuous backup of the C:\wdisplay\webfiles files (each time they change) and a once nightly full backup of C:\wdisplay to my NAS in case my PC fails.

Well as far as know there was no windows update as I have that set to manual.

I have been shutting this PC down successfully for years without this problem popping up.

This has happened before on an older PC (windows 7, slower computer) but never on this new one. (windows 10 pro, much faster new one)

I always click on the save before shutting things down, this is the only time it has happened on the new PC, it was like WD as reset to factory settings (default??) or like a first time install display.

I had to reset the com port, the location settings as it looked to be set to 0000 on the longitude and latitude under the sun/moon/time.

I have managed to get it somewhat back to normal.

This PC and all my others are backed up daily to my NAS, retrieving the backup for this PC did nothing, so it changed sometime before the backup was done.

If you have space on your backup device configure multiple backups so that you can go back multiple versions if needed. Some NAS devices have snapshot functions that help reduce the storage used by multiple backups by only storing files that have changed since the last backup.

Ok fine, but my concern is WHY did this happen, WD should not have been totally reset to zip.

I don’t know why it happened. What’s the uptime on the PC. Does the last reboot correspond with when things went awry?

Look at the photo in my first post, 10:56:37 on the 8th of this month, WD is set to come up when the PC is booted up, all was well before i shut the PC down the night before. And I did a save before I shut down WD.

Mine has done the same in the past, and all I could put it down to was windows updates. I turned off automatically reboot. I know this doesn’t solve the problem but might explain the cause. I keep my weather PC on 24 hrs, and it only updates when I want it to. Before I do I do a backup of WD.

Can I suggest a simpler solution? As your graphs are working ok, is it not simply that your data colour has somehow been changed to black. Go to Control Panel / Colours to check.

Good point Chris about multiple backups on the NAS, which I do. I use AOMEI Backupper that does a daily differential backup that only backs up files that changed since the last backup. Once a month it does a full backup. I use Synology Drive to manage the real time backups.

Well not only the color change but all the settings were changed, com port, station type, longitude and latitude, data background colors everything, it’s like you just downloaded and ran WD for the first time, and going back one or two days on the ini files wont change it back the way it was.

I just would like to know what happened to do this, as I have everything back to normal for now.

Are there any clues in EventViewer, either timed before the previous shutdown or when the PC was starting up?

No nothing, I looked everywhere, all windows logs, and WD logs show nothing as to what happened.

In which case there doesn’t seem to be any way to figure out what caused it. All you can really do is make sure you have more than one backup of the files to make it easier to rebuild it should it everr happen again.

I’ve had a long-time issue shutting down WD after a long period of operation (usually for the monthly reboot required for Microsoft cumulative updates on the 2nd Tuesday of the month).

WD will close, then Windows 10 Pro will blue-screen with a kernel fault and restart. (old PC, can’t do Windows 11)

What I do, after applying the updates via Microsoft Update is:

  1. shut down all the other programs (WeatherLink, Cumulus, VWS, GRLevel3, edcast, etc)
  2. close WD and get the blue-screen
  3. wait for the system to restart, then try WD. If it looks wonky (black, uncustomized main screen) then
  4. close WD, use File Explorer to go to the \weatherd\databackup directory.
  5. double-click on the .reg file to reload the registry with WD settings from last night’s backup
  6. unzip the last backup .zip
  7. start WD and wait while it reloads data from the Davis archive
  8. when all good, start the remaining programs and let sit until next month.
1 Like

OK more info, the problem happened on the PC acting as the WD server, (see the first post) now this morning the same thing happened on one of the client computers…??? (running windows 7)

Is any WD setting information sent to the client computers from the main server?

And I haven’t checked the others to see if it may have happened to them. (yet)

Client mode is only looking for the weather data broadcast by the WD server no settings included or the clientraw file depending on how you have the clients configured I assume you shut the clients down at night if you shut the server down then
What is the event viewer showing for the client computer