NOAA forecast download setup -> ok now, was port forwarding in the router

I am in the process of setting up the CL templates. I am to the point of setting up the NOAA Forecast Download. I have tried every combination of the directory but cannot get the file to download. The zone I am looking for is caz060. I have tried what the guide says '/pub/data/forecasts/zone/ca and then #caz060.txt. and am getting nothing. It logs in but does nothing after that. Any ideas??

Full URL is:

So put “” in the host (without quotes)

/data/forecasts/zone/ca in the URL

and then caz060.txt is the file you’re looking for.

Thats exactly what I have. I am still not being able to download. Says software error. I will kepp looking. Is there a ftp download seeting I may have wrong? My uploads are working.

is this with the ftp noaa download setup in WD?
can you post a screen shot of that?

try: data/forecasts/zone/ca/ (note the final slash) for the directory entry.


Yes this is with the FTP in WD. When I get home tonight I will post a screen shot.

Jbrooks… I have tried that exact line. I have tried every combination I can think of. I think its a ftp setting maybe. I will send a screenshot this afternoon and maybe we can pin it down then.



Doc2.doc (63 KB)

you are missing a / on the end of the directory (as per the example shown there)

Did you click on the big button that says 5 Day forecast to use,

and point it to your file on your e: drive?

Well Thats the problem. I cant do that because its not downloading the file.

I put the / at the end and still have the same issue. It logs on and finds the file but does not d/l the file.

Is the directory to point this too the directory on my server where the wx and other files are located or???

I’m working on and still need to take care of a lot of issues. This is one of them :?


tod, can you post the ftplogfull.txt after download?
shorty, i think that something unrelated altogether to this thread

list of files uploaded*

E:\Program Files\wdisplay\caz060.txt
actual messages from upload session*
Start Time/date:4:59:19 PM 12/20/2006
Permanent connection selected
Permanent connection, will do ftp now
Checking for what else to do…
there are 1 more things to do
Finshed email agenda
Finished email agenda, no ftp items to do…
Logging onto NOAA FTP server # 2 setup…
Connecting to FTP server.
220-This is a United States Government (NOAA) computer system, which may be
220-accessed and used only for official Government business by authorized
220-personnel. Unauthorized access or use of this computer system may
220-subject violators to criminal, civil, and/or administrative action.
220 FTP server ready.
331 Guest login ok, send your complete e-mail address as password.
230-Please read the file README.TXT
230- it was last modified on Mon Aug 19 13:36:34 2002 - 1584 days ago
230 Guest login ok, access restrictions apply.
changing directory…
CWD /data/forecasts/zone/ca/
250 CWD command successful.
Next file ftp down
Local directory for Noaa download is E:\Program Files\wdisplay
257 “/data/forecasts/zone/ca” is current directory.
Retrieving the NOAA file caz060.txt now
Saving the NOAA file to E:\Program Files\wdisplay\caz060.txt now
PORT 192,168,1,104,5,20
200 PORT command successful.
RETR caz060.txt
150 Opening ASCII mode data connection for caz060.txt (1299 bytes).
226 Transfer complete.
Finished ftp download, loggin off from server
221-You have transferred 1338 bytes in 1 files.
221-Total traffic for this session was 2274 bytes in 1 transfers.
221-Thank you for using the FTP service on
221 Goodbye.
Doing abort procedure/program close…

It looks as if it did transfer but its not in wdispaly folder. I did a search of all my files and cannot find it.

I have done the test d/l a few more times. The blue progress never moves. Even tho the files says it did d/l, its not on my pc. I must be making progress however because before it would say that the software aborted the transfer.

Saving the NOAA file to E:\Program Files\wdisplay\caz060.txt now
have you check in that location?

Yes, and did a file search of my E drive.

it should be going there…as it says it is…
maybe your firewall is blocking it…