No WMR200 wind data in WD [Resolved]

See the quote from the manual: “Sensors can operate entirely on battery power.”

But no longer up my pole, it would appear :wink:

But your battery wasn’t connected, and your solar panel wasn’t connected and the sun was turned off overnight anyway.

Sorry for any confusion, there are two AA alkaline batteries in the anemo sensor itself. That’s what I changed first. . .

Ahhhh, so the battery was disconnected but the batteries weren’t disconnected. Sounds like a very complicated power supply.

Yes, that’s right :smile:

sounds like a job for the soldering iron to put old plug on new battery at least that’s what I would do
how often were you changing the alkaline batteries if the rechargeable in the solar panel had been connected then the alkaline would of need changing less often

I suspect you are suffering from signal interference possibly from a near by house

Maybe. . . old one seems to be OK, at least I’m measuring 3.9V open circuit from the panel now, after a few hours’ very low sun.

Approx. annually.

annually sounds about right for stand alone mode
would of expected 2-4 years with rechargeable doing it job

fully charged the voltage should be about 4.2v-4.4v what was the voltage before you connected it, but it sounds like its charging bearing in mind how old it is, is surprising
so will be interesting to see if you still get signal dropout with the rechargeable connected and solar panel has wind sensor plugged in

Well, it survived the night! Plenty of (low) sun today to give it a good charge :slightly_smiling_face:

What’s being charged? I thought the only rechargeable battery isn’t connected.

I connected the old rechargeable battery in the solar panel. . . but I obviously didn’t make this clear :face_with_hand_over_mouth:

All batteries now connected. I’m trying to decide whether to send the new rechargeable battery back for a refund or keep it as a spare. . . as @hcorrin says, it would be easy to change the plug. I have 30 days to make up my mind.

Weather and short days are hampering trouble-shooting here. . . every attempt has to start with “get ladder out of garage”, followed by “climb on to flat roof clutching multimeter”.

After a 10-hour flatline last night and a lot of rain this morning - no sun - I climbed on the roof at dusk and measured 4.0V from the solar panel. Anemo was registering, but later went AWOL until 19:00 or thereby. Now it has flat-lined again.


Ladder (aluminium) is still in place. Watch this space.

very intrigued BOS, i think a picture of you up ladder mending it would be good as well… :joy:

Next time it flatlines try moving the console around the room I assume it has batteries what does the console display do when WD flatlines

Difficult to move the console far: yes it has batteries but also a short USB cable to the computer below the desk.

WD only flatlines when the console has lost the anemo signal, so WD just displays the values it has stored. Sometimes the console re-acquires the signal, sometimes I have to put the console in search mode.

That’s really what I can’t understand: it’s worked for years and I suddenly get problems - even with a brand-new anemo.

I think I’ll have to go back to basics: the solar panel battery is a distraction, the anemo should work on its own batteries.

I think he needs to wear a GoPro and post it on Youtube. It might go viral!

As an experiment could you disconnect it for a few minutes to do the test? I see what @hcorrin is thinking. Does the connection recover when the console is nearer the anemometer. At the moment you’ve proved that the connection recovers when you move the anemometer nearer the console, but in doing that you’ve changed a number of variables at once, e.g. distance between anemometer and console, but also position of the anemometer and cables, etc. If you do this test the other way around, but moving the console then the anemometer variables all stay the same.

That could indicate it’s actually an RF issue, with some new local interference causing a problem. I say could…it could also just indicate that the power output from the anemometer is lower than usual due to battery voltage reductions (although that wouldn’t make sense with the brand new anemometer that you tried).

Luckily, I don’t have a GoPro :smile:

Still planning to do this, but we have had so little wind it would have been almost impossible. When signal is lost the console retains the last reading for quite a while before its wind display goes blank. . . and then WD flatlines at the last reading. It will be much easier when wind is changing rapidly.

I disconnected the solar panel yesterday, brought it indoors and put it face down. 24 hours later the rechargeable battery voltage had dropped from 4.02 to 4.00 V. . . I think that’s pretty good for an unused but 8-year-old battery pack that’s been up the anemo pole in all weathers, but it is only an “open circuit” measurement.

A note of cautious optimism. . .

After a 12-hour flatline (overnight 16-17 Nov.) I reconnected the solar panel at about midday and it all worked OK for 12 hours. Then a 6-hour flatline overnight before signal was re-acquired at 07:30 (sunrise) on the 18th. Apart from 10-10:30 that morning (as if rechargeable wasn’t quite charged) and 21-22:00 that evening (no obvious reason) it has worked fine. . .

So I’m still none the wiser about why all the troubles began and why they seem to have disappeared - that’s tempting fate, I know.

I have ordered a spare solar panel - described as “new” - from a firm on eBay, just in case. . . First thing I’ll do is check that the rechargeable battery is connected :wink:

In those immortal words, “I spoke too soon.”

After a 3.5-hour flatline yesterday morning (20 Nov.) I finally disconnected the USB cable and moved the console: almost immediate re-acquisition of signal. In fact, I discovered that I only had to turn the console through 90°. . . see below.

Weird. . .

(I tried removing the “inductively-coupled” aerial too, but then I lost the main temp/hum signal from the other side of the house.)

There were still a couple of hiccups overnight, but it’s behaved today - so far.