New ftp program not working

Hi… I tryed using wd 928b and the ftp program dons’t seem to be working. It seems to show opening someting, but it goes that quick that I can’t tell whats happing.


Tom :frowning:

I note the same thing with the following being the only data shown in the ftp “window.”

Permanent connection selected
Permanent connection, will do ftp now
Internet sharing…

I have seen multiple sessions of the ftp app with the same response and no updating.

Is it necessary to go into the setup of ftp/file creation and set these values rather than utilize those set from previous versions?

I had the same problem. I unchecked connection to internet with a lan and it works great now.

I tried unticking “I have internet sharing over LAN”, but still get the following response in the ftp window:

Permanent connection selected
Permanent connection, will do ftp now
Internet sharing…

and no update.

I shut down WD completely, reinstalled v 9.28c with “I have internet sharing over a LAN” unticked, and ftp now appears to be working properly.

the intenert sharing has been mis used with the old ftp , which is still available from here:

its only for when you have a modem thats needs waking up on a LAN
otherwise just tick permanent connection…(unless you have a dial up modem )
but i think i have the real internet shaing workin (it waits 35 seconds to start ftp) now anyway

It does work with Lan unticked,is this how it should be?

if it works with internet sharing unticked, then you do not need that ticked in the first place (most likely, the wake up modem on a lan is unusual)

I’m still having trouble getting anything up to my web site with the new frp both I have a permonent connection and shear internet over a lane are both unchecked. I tryed the old ftp program in your link in one of your other messages, but it seems to be the new frpt program… will see if it is on your website


This is the fastest ftp program yet !
It’s rocketing along, even with all the files I have including
3 extra sensors, lightning detector, animated we cam etc
It is uploading on both connections in 25-30 secs
It used to take over a minute
Using cable modem at one site
& Jet Start at the other.
No problems for me so far with this ftp 6.16? In version 9.28c
:smiley: :smiley: :smiley:

hi tom
not sure whats up there,
you do have a ISP selected under connections?
you can still use the old one:

leo, i didnt change much, re the email, so not sure why its OK now, must have been somehthing else…
good its 2 x as fast.
i notive that even on a slow 28 k modem!

Tom, if teh password is not rememberd (i.e grey out or not entered) under dial up networking, then that is the problem
I will add that function into the ftp version today, all going well

Hi Brian,
I’m getting a strange error with the new ftp-program ( I’m using version 9.28d ). It says it can’t connect because it can’t locate the phonebook. Strange because it worked fine in previous versions…any suggestions?

try going to connections in the ftp setup and reselect the ISP (use get Isp and click on on the left hand side)
otherwise i am not sure whats up yet

Hi Brian,

it’s no use …tried to reselect my ISP ,typed in my username and password eyc. but it still gives a error 621 : can’t find phonebook. I even tried to unload or disable my firewall although it used to work fine before . I’m using a dial up connection btw ( 56k6 modem ). Again this happened only since I installed 9.28d , so it worked fine with previous versions. I’ll try to download the new version, and see if it makes any difference.


when you click on get isp, the name appears in the left hand box
then you clik on the dial up networking that appears there
then the username and password info gets updated automaticly: you do not need to enter those details

i will test the latest vers me slef, other wise try a good old pc reboot?

Hi Brian,

SERIOUS BUG with new ftp-program running under windows 98 SE ( dutch version) . This new and improved ftp-program damaged my DUN -files , including the phonebookfile. I had to uninstall the communications-component from windows and re-install it . All seems to be working fine, but this has proven to be a very tedious bug indeed…anyone who encounters the same problem therefore shouldn’t panic and simply re-install the communication-component . This has never happened to me before but I looked up the error ( error 621 , can’t find phonebook ) on the internet and the solution presented itself…) . This bug never appeared until the new ftp-program so there’s a glitch in there somewhere ( serious but not disastrous :wink: …SO again : if you get error 621 with the new ftp-program , here’s what to do :

  • go to windows setup and remove the communications component
  • reboot computer
  • re-install the communications component , again under windows setup from your windows se cd
  • reboot computer
    -ready to go !! Ftp works fine now and faster than previous versions

I found out about this bug because under the setup ftp menu in WD it didn’t recognize any ISP’s on my systems and I had to manually input password and username etc.

phew,close call :wink:


i have not set it to write to the phonebook entries at all!

Hi. I’m using wd 929c, ftp program still not working sorry to say. So using old ftp 11.26 I think it is.

When I use the new ftp it tells me that it has checked the email settings and then I think it says new operation in progress, this goes quite a few time down the screen, but i’m not sure if thats what is being displayed because it goes so fast.


hi tom
can you email me the file ftplogfull.txt
after you try it again