New compiler WD & OS WMR928 ~ RESOLVED

I though that I’d start another thread as my comments were getting lost in the main thread in the Chatter area.

My problem is that try as I might, the latest version of WD done with Brian’s new compiler just won’t work for me. I have followed the same process that I have always done when upgrading, un-zipping the file into C:\wdisplay, and then running the WeatherD.exe file. The program opens OK, but where as very on the old version it very quickly received data from the WX station, the new version just sits there not doing anything. The Data Received & Data Quality boxes just stay Red.

If I revert back to an earlier version (i.e V 10.37P build 44), I have no problems at all.

My PC spec is:

mini-ITX VIA EPIA M1000 motherboard with a C3 Nehemiah processor, 1 GHz.
1 GB Ram.
OS is Win XP Professional.

Any ideas??


what shows under view, WS2010/WS2500 data setup?

is there any other wmr968 owners able to run the new compiler version OK?
(or not)

Under view, WS2010/WS2500 it shows:

Loaded all time records
loading the data file month92010.inf
Connecting com port
Com port connected OK

and you do not even get a flashing data received light?
I will try and find my wmr968 console and do some testing here today (no sensor though, but still should get some data arriving)

No, no Data Received light flashing, it just stays Red, whereas with the older version as soon as the program is started, within a few seconds it starts to receive data, the Data Quality light goes Green & the Data Received light flashes Green along with the Data counter incrementing.

I see on the other thread that there is a WMR968 user that does get data OK

SandhurstWX,is there any error under view , program event log, on start up?

Hi Brian,

I’ve just tried build 71 again, and I get the same result as previous, the View, WS2010/WS2500 shows exactly the same as before and there are no entry’s in the Program Event Log.

Maybe it is my PC that doesn’t like the new version, as others haven’t experienced the same problem with their WMR928’s, but I don’t at the moment have another PC to try it on.


Working ok for me Brian

Ian, Not sure if theres any difference but in the Station Type selection setup and i am using the 3rd one down in the
WM918/WX200/WMR918/WMR968 tab… called WMR-918N\WMR-968\WMR928(N)…
dont know why im using the older setting but its always worked ok for me so i just left it… Just an idea?

This non response issue has been reported in other threads, but with slightly different variations, and not specific to WMR928. I do have a WMR928, and I also suffer from the non responsiveness at startup and the way I get WD to ‘wake up’, is by clicking in the main temperature data area of the WD screen…and this 99% of times wakes WD up. I don’t understand why this works, but it does. This is the behaviour for both old compiler and new compiler. I am running the new compiler version.



TrevP, I tried your suggestion, and indeed if I click on the main temp area as you suggested it does come up with a value, and the data count increments by 1 digit, but it still doesn’t keep getting data, it’s almost as I have to keep clicking to get it to get data. I’ve never had a problem like this with any of the older versions that I have been using for the past 5 years. I’m coming to the conclusion that it may be my mini-ITX PC that I use, but at the moment I don’t have anything else to try.

Thankfully the last “current” version works OK, so I may be sticking with that one for the foreseeable future.

all you are doing is getting WD to display the last value from last time it got data from the station (e.g last time it was running even)
and its not going to make it start getting data from a comport if that is not working (for what ever reason)

Ian, I’m sorry that what works for me doesn’t work for you. Trust me, I know how infuriating this can be :frowning:

Brian, I can assure you, that doing what I do, gets WD to wake up and start receiving continuous live data…otherwise it would just sit in a state of limbo and not wake up. Yes, the initial response IS that of the last data it got from the station, but after a short time, WD does wake up and starts to receive live data, otherwise it would invariably would not. My method has been doubted previously, so perhaps it’s time I set up a movie to show this in action.


with the wmr918/68 type station, WD will not populate the main screen until all the sensor data has arrived (e.g including barometer data from the serparate indoor sensor)
by tricking the main screen data to populate, you then have made WD think all the data has arrived OK and so minute updates will get started

note that you will have a data received light flashing before doing your trick, yes?

SandhurstWX does not have a data received light flashing at all, so this is a different issue altogether and you are just creating confusion

Brian, No, I do not have the data received light…similar issues have been highlighted in other threads but doesn’t seem to be getting through to you. There is no confusion - I have a WMR928, Ian has a WMR928, we have a similar issue…I was throwing in a potential ‘workaround’ which works for me. Unfortunately this doesn’t work for Ian

I have uploaded the sequence of events here - so perhaps there may be better understanding…I’m not asking/pestering for a fix, I have a workaround as described…

[ Initial Opening.jpg]( Initial Opening.jpg)
[ - last known data populated.jpg]( - last known data populated.jpg)
[ - Only one data area appears to have updated - 4mins later.jpg]( - Only one data area appears to have updated - 4mins later.jpg)
[ Click in MainTemperature Data area.jpg]( Click in MainTemperature Data area.jpg)
[ - Custom tags now populate.jpg]( - Custom tags now populate.jpg)
[ - Screen data now populates and wd receiving data.jpg]( - Screen data now populates and wd receiving data.jpg)
[ - Continuous data now being received.jpg]( - Continuous data now being received.jpg)

I don’t want this thread to be hijacked by me so if a mod wants to move to/open another thread with this then please do -

make sure you have a wmr968 station type selected in WD if you have a wmr928 station
if you have the wrong station type selected, then you will not correctly get barometer data and WD will not sync with the station correctly

also if you have data arriving from the com port from the station then the data received light will flash
there is no way it will not Trevp, for your station type

I would try installing to a different location
then create a file there called 3wd.txt
then start up WD there
as a test
it should start up as brand new
set the com port
set the station type as wmr968 and tick to use sea level barometer

Hi Brian,

I’ll try the above as suggested later today if I get an opportunity (got to visit the out-laws today), but I will also try a set-up on my main PC and see if the problem is PC specific (i.e. the mini-ITX one).


Not sure the problem is confined to WMR928 because we have a similar problem with WS-2350 since the new compiler came along.

Just to have my input on the new compiler issue this is what happens to us. Having the luxury of a spare a spare WS-2350 and a PC we did a clean install of build 44 that always works with the on-line site. Then we added the new complier build 77. So far it has run and displayed weather data, for two hours so far. However as soon as I try to run as a TCP/IP server and click the update IP address button it displays the IP address correctly then locks up. It required a CTRL/ALT/DELETE to escape and restart. This also happened on the on-line PC, Del,l windows 7, dual core, 2Gb memory. The test PC is also windows 7 dual core and 3GB memory.

If this is not relevant to your specific problem sorry but didnt want post a new thread on this similar issue.

Cheers John

but thats not the same problem at all as this thread

can you post a screen shot of the IP setup you are setting in wd?

Just a follow up on this small problem…

Just tried the latest full install, Ver 10.37Q build 01 on my dedicated weather PC, the mini-ITX one, and it still doesn’t want to work, see the problem listed in my earlier postings.

However, I copied my wdisplay folder to my main PC, updated with the latest full install, and using a spare console that I have recently acquired, I am able to run the program with no problems as all, even going through a USB to serial converter.

So I surmise that the problem may be related to using the mini-ITX PC, I don’t know what the problem would be, but it just won’t run any of the new compiler versions of WD, although all pre new compiler versions run without any problems (now is this an excuse to buy a new weather PC?!)

I still have the initial no received data issue…ongoing for many months now…(and yes, I have a new build since it first happened, so its not machine specific), unless I take the action that I have described previously in this, and other threads. The workaround I describe wakes up WD, therefore I persevere with that method. One day, perhaps one day, a build will come along which fixes the issue.