How to install WD on Linux

OK. I thought I knew a LITTLE about Linux before reading the posts in this forum. Now I realize my knowledge of Linux may be too limited to even ask intelligent questions!

I have not been able to find instructions for installing WD on Linux. Only fragmentary posts in the Forum on problems installing, etc. Are there instructions somewhere that I haven’t found?

How do I determine which version of WD to install, WDisplay or WDconsole? How do I know if I have xwindows or not? I was able to download WDconsole and unzip but that is all.

I don’t have a lot of time to devote to this but any help would be appreciated!


if your linux looks like windows, i.e has desktop icons, then its x windows

We all start at the same place … :slight_smile:

Incomplete instructions can be found here: [url=][/url]

Given your comment of not having much time, I believe you want WDisplay. This is the package of software with the graphs.

WDconsole can be used to simply poll a select number of weather stations and create a raw data file. This data file can be shared by other WDconsole applications. In short, it allows you to setup a single server' (if you will) with multiple clients’ (WDisplay).

You should be warned the WDisplay software is extremely buggy. I would believe it’s fair to say Brian is in Alpha with this port.

Thanks Brian and Pablo. I’ll try to install WDisplay later today and post an update.


I finally got around to trying to install WeatherD. I think I’m having permission problems.

I followed the instructions from WeatherWiki. WeatherD.tar.gz downloaded and uncompressed to create a wdisplay directory containing the WeatherD executable.

I checked the permissions of /dev/ttyS0 and they were not correct so I used su and then chmod 777 /dev/ttyS0. The result was lrwxtwxtwx (not crwxrwxrwx) but I proceeded anyway.

I also tried to change the permissions of WeatherD and the result was -rwxrwxrwx (not crwxrwxrwx). I proceeded anyway.

I then ran ./ and the result was the following error message:
./WeatherD: error while loading shared libraries: cannot open shared object file: no such file or directory

So, it seems I have the files downloaded with the possible exception of or maybe the permissions are not correct for that file? Any suggestions?


I have to inline my `’ script since the board doesn’t allow me to attach it - Brian, perhaps this is something you can fix?

# Function to establish user id of current user.
# We call this function later on to test if they are ROOT and fail if they are.

getUID() {
        id $1 | sed -e 's/(.*$//' -e 's/^uid=//'
# Test if user is root and deny access if they are.
# It is not a good idea to be running software as root.
if [ "`getUID`" = 0 ] ; then
        echo "ERROR: You can't run this as ROOT. Change to another user and try again.";
# End of User test.

DIR_PATH=`dirname $0`

# setup the path to inlcude our directory

export PATH="$DIR_PATH":"$PATH"

# If we made it this far we mustn't be root.
# Just set the library path.
export LD_LIBRARY_PATH=$DIR_PATH/deploy/

# Then run the program.

exit $?

Chris (admin) would be the person to talk to about that
so i still do have the updated needed .sh file?
I will update it to this
the other solution is to change to root in the terminal and then copy the library files from the deploy folder to /usr/lib/

(then enter password)
then cd to the deploy folder
then go
cp lib*.* /usr/lib/

Which linux are you running.

humm, the file has the same info in it as posted above…

Your sh file okay its something else in the setup.

Pablo, Brian, Coyote,

Thanks for all the suggestions. I tried Brian’s suggestion to copy the contents of the deploy folder to /usr/lib (while logged in under su). When I tried to run the ./ script I got the same error message, that is, “error while loading shared libraries: cannot open shared object file: no such file or directory”.
I should note that I do not find a file with the name in my deploy folder. Could it be possible that I don’t have the correct file? Did I make a mistake in the installation?

Pablo, thank you for sending the file but I don’t know what to do with it. Are you suggesting that I replace my existing file with the script you sent and try running that?

Coyote, I am running Xandros on a recently purchased eeePC from Asus. I know, its not a powerful machine but its actually remarkably capable. One thing I noticed that is different from the other versions of Linux that I’ve read other people post: The wdisplay directory and WeatherD.tar.gz were downloaded to “My Documents” directory. The full path is /home/user/My Documents. Don’t know if that makes any difference.

Does this information provide any new clues?


the should be in the deploy folder, which needs to be a sub directory where WD is installed
its included in the .tar.gz file


So, should I start over and download WD again?


is that file in the deploy folder that came with the WeatherD.tar.gz ?

No. The file is not in the deploy folder that I have. The deploy folder appeared automatically after I downloaded WeatherD.tar.gz so I assume it came when I downloaded that compressed file.

Hi Francis,

I’ve been somewhat staying away because I think `too many chefs spoils the meal’ … :slight_smile:

Let’s do this … first off, please undo the copying of the library files into /usr/lib. That’s a bad practice because on a re-install, you’ll lose those changes. Personally, I believe any files placed in /usr/lib should be handled via .rpm’s.

Get your system back to the way it was before you installed the software.

Once you’ve undone the previous suggestions/effort, unzip the bits into any directory of your choosing. Do not do this as `root’ (not sudo).

After unzip’ing cd to the directory and type the following and post the results:

find . -print

Next, please type `file’ and post the results of this too.

And finally, phew, type and post the results of the following:

find . -print | xargs ls -la

Thank you.

Pablo, Thanks for the suggestions. I’ll try this later today (in about 12 hours).


Hi Francis,

Thank you for the update. I’m in eastern timezone so I won’t be able to respond until my tomorrow. :slight_smile:

when did you download the the WeatherD.tar.gz ?
strange that file is missing
try downloading again?

also I wonder Pablo if the problem with the .sh not working is with the file, in that I create that on my system , with my directory structure, but that does not work on other systms?

Hi Brian,

As long as the symlink isn’t using absolute path names, all should be good.

Looking at my installation, the symlink is fine so we’re good.

Francis: please verify whether you’ve downloaded Weather Display For Linux' or Weather Display for Linux, QT widget’