How to download images to animate?


If I understand you correctly, you are trying to put the following images together to make the animation:

There is no need to do this because is updated with a new image every hour on the website and 2.jpg then becomes 1.jpg from an hour ago.
Weather Display will do this for you as it will save 1.jpg into the Download folder, then an hour later it will save the same (updated) image again but call it a different name. It will save as many images as you tell it too and then puts them all together to creat the animation.

If you look at my PAGE, this is done by downloading only one image and storing a total of six of these to creat the animation.

Give our method a try and see if it does what you want.
This is how I put mine together (I called my image “sat.gif”):

[color=blue]1. Set up the download screen with the URL of the image and the local file name. Making sure they are both in the URL & Local Filename windows on the right hand side.

  1. Go to “View” > “Downloaded Images”. Click on “Open File” and select the sat.gif image (in my case) so it displays in the main window.

  2. Set the number of images you want to include in your animation.

  3. Tick the “remember this file”.

  4. Tick the “Auto Animate”.

  5. Click on the “Animate” button.

  6. Tick the “Upload selected animated image to my website”.

I left it overnight and in the morning I had the correct number of images in the C://program files/wdisplay/Download folder (sat.gif, sat1.gif sat2.gif… etc) and the animatedhttpfile.gif was uploaded to the website, but was also saved in the folder with the rest of the files for my site on my C:/ drive.[/color]

Let us know if this creates the type of animation you want, I think it will, and will also save you downloading 3 image files every hour. :wink:

Hi Budgie,e
I let it go 24 hours an got
It looks like all file in the download folder are ok
thankss for any help Beau


Here are screen shots of my setup.

The first one is the Download screen, make sure you have the “Download” button switched ON.

The second is the animation screen, follow the instructions for each red box and make sure you have the same tick boxes ticked as I do.

Another FAQ is born? :smiley:

Not bad as I only put my own together about a week ago. :wink:

I’d do the screen shots again though for an FAQ.

Hi Budgie,
Thanks for the help it is working now i had to use jpg instead of gif on my local file
Is there a way to not have the flashing cloud Thanks Beau
example here

Looking good there Beau. :smiley:

I don’t know why we are getting the flashing cloud, I’ve got it as well and it’s as if there is one frame missing in the animation but I can’t find the fault in my setup. It always seems to be the second from last imae that’s missing.

Brian, any ideas?

Link to Beau’s file:

try setting the number of frames to use to one less

I’ll give it a go, although I was running 10 images and now only running 8, could it the even numbers causing the problem?

Hi Brian,
I was using 6 i wet to 5 an it is still showing cloud

i am not sure why its doing that
(as I do not have that particular problem myself)

I may have a go at deleting all the images and let it start from scratch again to see what happens.
Something else for days off. :wink:

Hi Brian,
I do not known if this will help or not but it is not it not in any image In the download folder but it shows up in animatedhttpfile.gif it looks like the image you see on the bottom of the image download page Beau

It’s a standard image that WD will use to fill in for any missing images in the animation (I assume) as I saw these when I first set up my animation.

I think I start by removing one frame at a time and see if that clears it, then, if it clears, I’ll start adding the frames back in again and see what happens.

yes, its a placeholder image

I had a play with this today and did the following:

  1. I reduced the number of frames, one at a time and closed the animate window after each reduction, until I got to the minimum of two frames. The icon was still there throughout.

  2. I then reversed the process back to 8 frames with the same result.

  3. I then deleted all the images in the download folder, I also deleted the other files in there that had the same name as the image file but I can’t remember their extension and I don’t know what they are.

  4. I ran through the setup again and let it get on with it and waited until I was in work tonight before checking on the animation, the icon is still there. #-o

I can live with it as it doesn’t really interupt the sequence but it may annoy others.

On a similar subject Brian, I tried to set up a second animation and it all seemed to work OK but for some reason the animatedhttpfile.gif had the same image as animatedhttpfile2.gif and the only way to get the original image back was to delete animation2.
This is just “nice to have” so don’t think it anything desperate, I know you’re busy enough without stuff like this. :wink:

I know what you mean…I have had the same problem. To get mine working correctly I setup both, first number 1 and then number 2, and it seems to work for me most of the time. Give that a try and see if it helps.

Hi guys,
If i would upload to my website only the file sat.gif without any animation…how to do this?

As it happens, I’ve just made a new FAQ about setting up to downlaod an image. :smiley:
You’ll find it here:

Follow the instructions in the first section, “DOWNLOAD”, and make sure you have the button in the bottom right hand corner set to “Uploads On”, as it is in the FAQ. :wink:

Then WD will download the image for you, change the name, and upload it again.

If you wanted too, you could just link direct from your page to the satellite image by using code like this where you want the image on your page:

<p><a href="" target="_blank"><img src="" alt="Satellite Image" border="0"></a></p>

or just put a image url to the sat image into your web page to show it form the source?
but then that puts the bandwidth onto that site and not your site
so they might not like that