Help! WMR100 Main weather station USB connection problem

I want to enquiry the question about WMR100 model main weather station, it receives the wireless signals from outdoor sensors will its weaker(When it is connected to USB, distance is same). It is belong to normal?

When WMR100 main weather station have connected USB to PC side, it will slow upate when compare with not connect USB. When, it even moves further apart from them, main weather station sometimes will have chance to lose the wireless signals(Which is outdoor temperature, humidity and wind signals) during connected USB. Even, i have pressed the search button below of the main weather station, it still fail to receive the outdoor sensor signals.

Many thanks for answer my questions.

Hi and welcome to the forum. I have not noticed this with my station. Are you running on batteries or do you have power supplied to the console?

Yes, it is running with battery with AC power supplied to the console

I have not seen any reports concerning reception problems. And I have no idea why the USB would affect the range of the wireless reception. How far away are your sensors from the console, and what is between? We need to know the distances involved to be able to make a comparison with how our stations are setup.

I could believe it. These stations have very simple radio links and hanging a USB cable between the PC and the console is a good way to increase the amount of interference that the receiver experiences. Try having the PC further from the console, and try a better quality USB cable with a radiation reducing ferrite core.

Mine already has a core near the USB plug on the station input end of the cable…must be a known issue with these stations perhaps?

How far away are your sensors from the console, and what is between? About 1-2m, Window and walls.

If your sensors are only 2m away from the console then my guess is something wrong with your station. Is getting it replaced an option?

I don’t know how long you have had it so I hope it’s still covered under warranty. If that isn’t an option then I would try use the station with another computer.

Unplug ac adapter, usb, remove batteries in main unit and outdoor sensors…wait 30 seconds or so…then put the batteries back, plug in ac adapter and try again. This worked for me.

I have the same problem. When unplugged from USB to PC, base unit reads 9 remotes beautifully, but after you plug it in to the PC,
the reporting to the PC is spotty, and over several hours the base unit loses reception from the remotes. This was after replacing batteries in all remotes, & pulling batteries & AC & resetting base unit.
Subsequently, I depowered & reset base unit again and it read all remotes & worked perfectly without being connected to USB.
So the problem is in the USB implementation (hardware or software), not in reading the remotes.
Are you using Weather Display? What version?

Yes, whats common between you 2? Do you both have the wmr100a or the wmr100?

Mine is WMR100a (US version). My USB cable is about 30 inches long w/ 5/8" diam x 1" cylindrical item at PC end (supplied w/ unit).
Location: SF peninsula.

Does turning off RF clock have any effect on this problem? Mine can’t get a good signal. How do you do it? When I first set time/date, it doesn’t give me that option. The manual isn’t very clear on this.


To turn off the atomic clock sync you would use the select button to move the cursor to the clock field, then push/hold the search button on the bottom for a few seconds until you hear the beep and see the signal strength indicator on the screen disappear. Use the same procedure to toggle it back on.

looks like you have the dreaded wmr100 usb stoped sending problem Dan yourself now:

i see someone has found out that it could be a ground loop problem

Yea I noticed it going out last night (wind direction flat lined) and today everything has stopped. It will just have to wait until I get back to kick it…

Your help is great, guys, thanks!

Please tell me more about the “dreaded wmr100 USB dropout problem.”


there is a FAQ on that

Thanks; I went thru the FAQ’s before, and if it’s the FAQ re: powering down, I’ve done that several times, but when I plug it into USB, a beautifully-working console goes haywire in short order (see my post 9 to this thread above).

I believe the WD I downloaded from OS may not be the latest version…do your later versions cure this problem, or is it a hardware problem?

I’ve got 2 wmr100a’s with 9 external T/H sensors each (at totally different locations), and I can’t believe the hours I’ve spent trying to make these things work (probably not as many as you), and any insite you can offer would be very helpful.

Thanks again.

that version you downloaded is a free basic version

i think its more of a hardware, electrical interference/ground loop/feedback problem than a software problem

Thanks, Brian
At least I know which direction to turn.
'Appreciate your help.