Help needed with testtags.php upload [RESOLVED]

WD Noob here. Have looked through the forums and tried different things found there trying to get the testtags.php to upload. Attached are screen shots of the various screens I think will be needed to help me.

Shows the switch being on in the file create/upload screen.

Shows the green lights on Page 2

Shows the main internet switch being on, along with the main FTP settings including the correct remote directory.

Shows the FTP error log, which I find interesting in that it shows 0 bytes transferred yet my clientraw(x) files are all being updated at the correct intervals.

The problem I have though is with the testtags.php file. The file is created correctly and I have uploaded it manually outside of WD but I can’t seem to figure out where I have went wrong in getting WD to update it. The testtags.txt file is in the webfiles directory as is the testtags.php file.

As stated above I am new to this program…just installed it 2 days ago and have been pulling my hair out since then trying to figure out how to get this file to upload.

Thanks for any help.


make sure you have the correct file names set for the special file conversion, in the webfiles/web page setup, custom web page setup
looks like you have the local file name set as testtags.php instead of testtags.txt

Have you followed the instructions on the Saratoga Weather Site:

Place the testtags.txt in your wdisplay/webfiles folder on your weather system PC. In the WD main program page, goto Control Panel > Web files/Web page/realtime FTP/WDL > Custom Web page setup TAB. In the bottom right you'll see a an area marked "Special File Conversion". In the top text box enter "testtags.txt" (local file) then "testtags.php" (remote filename) Now turn the switch to ON and click "test", then OK to exit the window. This will convert the files to what you need, now we need to upload them to the website.

Control Panel > Internet File Creation & Upload > Setup Page #2. Look down the list for File #29 “Special Custom File Convers.” and click the “Set” button.
Click the “Show file create times” button and set the create interval, I have mine set to create every 5 minutes. Then click “Save Now” and then “Show file upload times” and set these to the same as the create times, click “Save Now” and turn the switch to ON if it’s not already there, then click OK to exit the window.

Thanks for both the replies so far…Yes, I followed the instructions on the Saratoga weather site…I tried setting creation and upload at 5 minute intervals but had the same results. I currently have it set to 1 minute just so I can more quickly confirm uploads.

The testtags.txt and testtags.php are listed correctly in the set-up…this is confirmed by the actual creation of the testtags.php file, it is the uploading to my webspace that is giving me the problem.

Are you sure the remote directory entry is correct?

Unless there is a seperate entry somewhere for the testtags file it would have to be correct. It is the same directory that the clientraw files are being uploaded to, and they are getting there just fine.

also post a screen shot of the custom web page setup from the webfiles/web page setup

also make sure you have the main internet switch on in the customise internet and file creation setup
and if using the 1 minute update, to make sure you have the 1 minute override ticked (top left)

Will do when I get home tonight around 9 PM Pacific time UTC-8. As of about 10 AM Pacific something appears to have hung up, and I don’t have the PC set up for remote access yet, so I will have to get home to find out if the PC died or my ISP is having problems.

I hope this is the image you needed…the first one shows the 1 minute override box checked and the 2nd on is the one you asked for (I think)


next is to make sure you have the testtags.txt file in the web files folder location that WD is using
i.e what shows in the webfiles/web page setup

Everything as far as I know is at defaults for the install so I belive this is the correct directory for this file…this is where the Saratoga website said to put the files. As you can see the testtags.php file is being created, it is just getting it to my website into the same directory as the clientrawxxxx files go.

its best to set windows to not hide known file extensions, in the folder options

for the ftp, make sure the ftp settings are correct in the connections setup in the ftp/internet setup, i.e the remote directory, ftp host, etc
and make sure you have ticked to use weather displays own Ftpup.exe and the main switch is on there

what shows in the file, Ftplogfull.txt?

Ya, I know about the extensions. It is a brand new netbook, that I received, installed WD on, plugged the station in, and started trying to get files to upload. Have not had time to change the defaults on it yet. Been working 13hr days since getting it + 2.5 - 3 hours of commuting, so it has been do a couple of things to try and get the data working, sleep, drive, work drive…rinse and repeat. :slight_smile: Will try to get to it over the weekend. Here is a snippet out of the text logfile. Basically the whole log file looks the same as this snippet. I am sure that the remote directory is correct, you can see it in the first message of this thread. The clientraw files are all being uploaded to the same directory without a problem. Thanks for all your time on this Brian.

Doing abort procedure/program close…
list of files uploaded*
actual messages from upload session*
Start Time/date:9:55:11 PM 8/27/2009
Doing abort procedure/program close…
list of files uploaded*
actual messages from upload session*
Start Time/date:9:56:10 PM 8/27/2009
Doing abort procedure/program close…
list of files uploaded*
actual messages from upload session*
Start Time/date:9:57:10 PM 8/27/2009
Doing abort procedure/program close…
list of files uploaded*
actual messages from upload session*
Start Time/date:9:59:16 PM 8/27/2009
Doing abort procedure/program close…

best thing is to .zip and email me your settings files (there is a FAQ on that)
is that the full ftp log?
(i.e view, ftp log, view full log)
or paste here the contents from the ftplogfull.txt file

I will read the FAQ for that and get that information sent off to you tomorrow it is night night time for me here. You were correct that it was the latter method of opening the file in the WD directory and then doing a cut and paste out of the file there.

I just want to say again thank you for your help on this problem. It is a rare thing to come across a product with this level of support. I only know of other application that is supported this well, and it is with my other hobby astroimaging.


It look to me that there is something wrong with the FTP side of it from that log.
Remember that the clientraw.txt is uploaded by a different ftp program so the fact that that is uploading OK doesn’t mean that these files will be OK. :wink:
Try entering the server details in the FTP page again, just to make sure that all the details are correct.

Are you sure that there are two different FTP programs? 1 for the Clientraw, and 1 for other items? I know that you can set WD up to use different FTP programs, or even have the same item FTP’d to different places, but I was under the assumption that unless you specifically set WD up to use a different FTP program, that all items were FTP’d using the same built in FTP process other than prebuilt reporting sites like WU, ARPS, CWOP…etc

In any case I will look at this possibility tonight when I get home along with zip’ing and sending my settings off.


Yep, the clientraw files are uploaded using the Clientraw Realtime FTP which has a small yellow square icon in your task manage with the occasional red arrow in it. Full setup instructions are in this [url=]FAQ[/url}

The one that uploads all the other files is the WD FTP, in the WD program folder as ftpupd.exe, and only shows an icon in the task manager when it’s actually uploading. This icon is in red and just says “WD FTP”.
This one is controlled from the FTP/Internet Setup > Connections page in the Control Panel.

Ohhhhh I hope it is as simple as this, so the example you linked me to is what is uploading my clientraw files correct? My screenshot here:

is what is supposed to be uploading my testtags file? So, it could be the directory listing/password/username here is that is incorrect.

tick, I have a permanent connection