Forecast not updating

I am having a problem with my forecast not updating. I have checked my client raw.txt and it is definitely updating regularly and the link for this in settings is directed at the root. Any help much appreciated. Thanks

I am on vacation so only a short answer.
Check your settings. If clientraw is in the root it should be specified as ../clientraw.txt

It seams you entered only clientraw.txt

Check the documentation at

Will be back next Wednesday and will check your other problems then.

Succs, Wim

Edit 2024-05-08
As i typed my answer on an iphone on a moving ship I did not notice the discourse forum software cchanged the two points into three.
And my iphone seems not to have that spacial “it-is-code” charecter either.
Sorry for the confusiuon later on. But the OP solved it maybe by using the link to the readme-document.

1 Like

Thanks Wim working now. Have a great holiday

1 Like

with …/clientraw.txt site is offline.

Try TWO dots before the slash: the Forum adds a third dot. . . :confused:

1 Like

no this works fine, no … / clientraw.txt just without the …/ when i use that it’s not working.

Then your clientraw is probably not in the root directory. . .

sure it is… see screenshot

try using ./clientraw.txt

let it go. the clientraw and the site both are in the root. this works, with ./ of …/ it does’t work. .

So why did you post in the first place? We thought you had a problem :confused:

The original problem was the forecast which I believe you are using wxsim for when I view you site on my iPad the forecast says offline if cleared the cache for your site and then reload it still says offline if I use _test.php instead of index.php it updates
Now the strange thing is mine has been doing the same today on the iPad

Will try on edge later to see if a browser or cache issue

i don’t use the clientraw.txt i use the api…

well edge and google chrome do it as well and ctrl F5 did not work, when i closed edge and reopened it, it had updated the forecast.
my plaintext file is at

I’m confused. . . why then have we been talking about clientraw.txt?

The OP alienburt posted a headerline with “Forecast not updating” but in the description only the location of the clientraw was mentioned.
I checked its website and there were numerous errors which were resolved wen the correct clientraw address was entered in the settings.
There are invalid links in the WXSIM forecast but it sems to be updating every so many hours.

hcorrin sites shows indeed “offline” in the forecast block although the data in the full pop-up is recent.

I added screenshots of both websites and will check the scripts to find the cause of the invalid “offline” in the WXSIM forecast block.

When typing on an iphone to point the OP tio the correct form of the clientraw link, I type .. and could not see the resulting text with ...
Sorry for the confusion, thanks for posting an immediate clarification


As I can not check every so many minutes:
If you get the “Off-line” message please right-click that word and select “inspect”
There should be a html comment such as
'<!-- date time from within the original clientraw file -->'
That will maybe give a clue


The wxsim file is updated every 3 hours and uploads at 27 min past the hour so the 9am is due to be available very shortly
Currently using iPad so not sure how to do right click on the offline will try this evening when I have my windows laptop running

Problem confirmed.
Attached screenshot shows amore recent wxsim forecast which should be used by the scripts to display the block data also.

Will have to add debug code to find the cause.

For now:
I tested multiple configurations , all PHP 8.x but only on Linux/Apache servers.
Some postings point to not correctly working of the PHP filemtime function on complex folder configurations.
But i can not replicate your problem.

Temporary solution: Change line 34 in fct_wxsim_shared.php|01|2020-11-02| from

$loadCache      = true;  


$loadCache      = false;  


ok have changed that line
thanks Wim