Fix for serial memory leak coming! -> its here!

Thanks to the hard work of forum member Yves and his creation of a .so (dll ) file for me to use
With the help of my brother we have this working (taken some hours!), getting data from a davis wmmii, in a test program now
so now just need to convert the linux program over to use this and then no more serial memory leak problem with the latest kernal versions :slight_smile:

also, i can now write a non xwindows console program that can output the clientraw.txt file data for WDL to use…

just doing some soak testing, the com port connection was lost after some time, so i will need to check for that
(ah, found the problem )

more good news: I have data at mouse position on the graphs working, just like the windows version

so the next linux update will be a goody
(i also noticed I needed to fix the graph setup small font problem)

i will also bring across more of the windows version improvements (like this new wind rose), and better setup screens too

i will also work on the web image screen grab timing problem more

(i.e I am going to concentrate on the linux version now more)

(ps. where is everyone?)

Looking forward for the changes will be back home in about two weeks and I’ll set the linux box again.
I’ll give it a run

Now I am drooling… :slight_smile: Its sooo silly having a linux box running win32 apps…
The non xwindows console interests me very much as well.

Standing by for more awesome info…

soak test been running now for 7 hours, will leave it running overnight :slight_smile:
yes, this console version , to produce the clientraw.txt file data for WDL, means in theory you could have it running on a Linksys router even ! (which has a serial port (needs wiring up Ricky told me))

As long as the router is running embedded linux with a processor which is x86 compatible no problem. What type of router are you thinking of?

i was thinking along the lines of a Linksys

what model?

Hi, Brian.

I’m still here.

At this moment I’m working with a virtual machine in VmWare with Mandrake 9.1 waiting for a new version without memory leak problem.

Only to remember some things, at this moment I’m working with version G of Linux program, sure that some, (or all), of this will be solved in the newest version.

  • Initial message about 61 Hpa for Oregon station.
  • Possibility to translate the standard web pages.
  • In one “test” version make a mistake with the rain when read too many times the file with the values of serial port
  • if still using a file to write and read the values, can configure where is the file? (In order to use a RAM disk)

Have luck with the new version, I’m waiting for it. :smiley:


Hello Brian.

Sorry for tell allways about problems.

I have check the last version, “P” with the last comdata program, and don’t works, (for me), I don’t know if there is any special configuration, but comdata tell that are receiving data but was not writing in the comdata.txt file that has values from last March, now I have the minimum value for the temperature today of 10 degrees instead 28.

Came back to “G” version.

Any advice?


humm,maybe the comdata program does not have permissions to write the file?
I am working with Yves still on the new com port code…some teething problems

also i tried with the 2310 station i have here…but its not waking that up (via the RTS/DTR toggling)…not sure why not yet

also, what weather station type rmallafre?

while working through the teething problems with the new com port
i have added the new windrose and a html viewer for the detailed climate report that is generated too, to the view, averages/extremes :slight_smile:

Hi Brian.

I was checked the permissions to write the file, and, in theory, it has permissions.

The station is a Oregon WRN982N, also, when run the program, the first screen about the battery status say that all batteries are full at 100%, also for extra sensors that I don’t have. I have 1 extra sensor, and the graphic put also 100% for sensor 2 and 3


i seem to have the new comport driver running stable now (with the help of Yves)
I will soak test overnight
it should work ok with the wmr968 station
i will test with my wm918 station tomorrow
i will check on the code for the battery status tomorrow

Just to keep everyone up to seed
Yves and I are still working through some bang your head on a wall issues and strangeness

(it all works ok when connected to a serial LOOP back)

also i have come up with a way of grabbing the web images with out having to bring the windows to the front.,…and then having them missed, and the background grabbed instead
the graphs and dial images are able to be saved as individual .bmp images
and then i would need to draw those images onto a image canvas and then also draw the necassary text onto that canvas as well

will take a bit of work, but will be worth it in the long run

OK, different tack here at the moment
I think I have a way of freeing the memory up with the com port component I was using

i.e with the separate comdata program

if anyone who has used this program, or could test this new update for me, that has the memory leak:
(remove the .dat to make it an executable)
and then click on the free memory button, and then see if the the memory use that has accumulated has been released
if this works, then I can incorporate it back into WD and out in to releaese the memory every hour(i actualy free the component and then recreate it again!)

Hi Brian. I downloaded the latest and greatest through the links, and I can not get any data through at all. I get the occasional green blink, but mostly red.

The one time I did get any data through to WD, it was was out to lunch.

I’m running a WMR-968, Fedora 7, with a 2.6.21-something kernel… This setup did work with an eariler version before the comport split. This isn’t my production machine, thats got the win32 version and wine simmering at the moment.

Do you need any other info?


i will test here with my wm918, that separate comdata program
it might be that i need to do a DTR/RTS toggle or similar for the wmr968
(which if this free memory works, I will put it all back into WD itself)

:smiley: Brian

RE “where is everyone”

Well I am running WD under wine in Linux and watching this forum to seeing how thing progress.
Like maybe other folks are just waiting…

Glad to see progress on the Linux side.

Cheer Lee :smiley:

Going home at lunch to restart WD yet again…

Will d-load and test.