Finally, my 1-wire station moves outside...

…however, there is a BUT.
Inside it was working fine… wind dir, wind speed and temp.
Now i KNOW the basic included temp is not brilliant, but is all i have for now.
I decided that one the mast was up I would not want to move it, so i created a 10’long loop, rather than the rj-14 that was included. This worked inside too.

Now moving it outside, the cable was checked and there were no breaks in it.

The wind dir and wind speed work fine, but the temperature isnt reading.
I rescanned the 1-wire devices and it has picked up all the serial numbers fine.

Anyone any idea as to what could be causing this?
(ie could i have the 2 wires the wrong way round in the plugs I have created?)


And yes, I will publish my site when I am happy with it working, along with a blog of the initial build and the problems I had to overcome…

Do you still have the other plug with the loop connected in the other port of the weather device?? also check the cable to the weather device has plenty of slack where its connected to the weather device they do not appreciate being tugged pull the plug out and put it back in again had the same problem today myself and this resolved the problem.


I have my own loop - basically an extension… ah well i guess i will have to take the mast down to check it - grrrr - all good fun i suppose.

I wanted to check that if i have the 2 wires the wrong way round - will it read nothing at all ? or would just the temp sensor not work?

Im watching the wind and we have had gusts of 69mph !!! that seems rather fast. Sure the measurement is at about 20’, but what sort of forse is a gust at that? Is there any way to check it?

OK - I checked it a different way - I ran my 2state LED across pins 2 & 3, giving the red/green glow indicating that the circuit is complete, so it seems (thank goodness) that my loop is working fine.

So any ideas please?

If the wires are the wrong way round you will get nothing…nadda

go here for wiring diagram

Yes I have been at the pole today up down up down…yes it was windy and raining and now its all back up no wind no rain…pah…all I have now is a hole in my graphs for today…


Most odd.
Dont you just LOVE technology.
Does it matter which of the 2 connectors the cables are plugged into ?

*Bonks head.

Restarted the s/w (after downloading the very latest version).

Working like a treat now.

*Still wants to know IF it matters which socket the cables are plugged into.

Should not make any difference as they are just a loop through so that you can daisy chain the sensors

Which software are you using??


There is a choice of software?
I though Weather Display was the only one?

Mind you - having to restart the software everytime I want the temperature sensor to update is getting a tad annoying.

Aha so you are using windies sadley no 1-wire in Linux version and a problem with the comport but being fixed from what I can see…woo hoo