File permissions issue

Hi I am trying to change the file permission on my global-conditions-json.php file from 750 to 666 using filezilla but it keeps reverting back to 750 so on my wxglobal.php page I keep getting the error message about the file not being updated and to change the permissions to 666. Is there any other way to change the pernmissions or do I need to do something in filezilla to make the changes stick. Getting the same issue with all the files uploaded for wxglobal.

The global-conditions-json.php file should be 750 permissions. It’s the global-conditions.json file that needs to be 666 (writable) to have global-conditions-json.php file get new copies from the regional network hub and cache the contents.

it’s the JSON file I meant, added the .php in my post by mistake!!

Ok, that’s odd. Your server at gets an odd return from the script trying to fetch the global-conditions.json file… your cache shows

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN">
<html><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><style type="text/css">html,body{height:100%;padding:0;margin:0;}.oc{display:table;width:100%;height:100%;}.ic{display:table-cell;vertical-align:middle;height:100%;}div.msg{display:block;border:1px solid #30c;padding:0;width:500px;font-family:helvetica,sans-serif;margin:10px auto;}h1{font-weight:bold;color:#fff;font-size:14px;margin:0;padding:2px;text-align:center;background: #30c;}p{font-size:12px;margin:15px auto;width:75%;font-family:helvetica,sans-serif;text-align:left;}</style><title>The URL you requested has been blocked</title></head><body><div class="oc"><div class="ic"><div class="msg"><h1>The URL you requested has been blocked</h1><p>The page you have requested has been blocked, because the URL is banned.

<a href="">Override</a></p></div></div></div></body></html>

instead of the expected JSON file. I just checked the .htaccess for the server and we are not blocking it from that IP address.

It seems your hosting has blocked the url for some reason, and offers a clickable link (with https which the NAWX site doesn’t offer) to relieve the issue. Very strange… never heard of such a thing before. I’d contact the tech support for your hoster and ask how to proceed.

very odd. I’ll see what they say, but don’t think it will be a quick reply from them!!

I have logged the issue with tech support and copied and pasted your above message, as being a novice they will probably understand the issue better than I could explain it to them. I’ll just sit back and see how long the reply takes and if they can reslove it quickly and easily. ( as “Easily” is the name of the host company!!)

Well I got a surprisingly quick reply but not what I expected or what I wanted to hear

Hello Philip,

Thank you for emailing Easily.

Unfortunately our server don’t allow the file permission 666, please accept our apologies for any inconvenience caused.

[Please do not remove this tag: RBTM1421]

Aurelio Rapisarda
Online Support Advisor

Looks like , having only just paid for a years webspace, I will have to move to another host. Is this a common issue? Should I ask the question before signing up?
I am surprised as a few years ago I had another weather website ( but due to other circumstances had to let it go , also using the Saratoga templates with the same host and then had no issue with 666 file permissions so assumed they would still be ok.


Give permission 665 a try on global-conditions.json and see if that will work (and pass their filter)

Nope 665 not working either

It may be that they don’t want writable files in the document root. Let’s try a different tack… your ./cache/ directory seems to be working fine, so
change global-conditions-json.php

$targetDir = './';   // target directory for cache files with trailing '/'


$targetDir = './cache/';   // target directory for cache files with trailing '/'

and see if this will break the impasse with the hoster and let the script run normally.

It’s still not liking this and still say the url is banned

The URL you requested has been blocked

The page you have requested has been blocked, because the URL is banned.


The URL you requested has been blocked

The page you have requested has been blocked, because the URL is banned.


I tried clicking on the overide link but it just times out.

It seems THEY are blocking access to – it’s something they will have to lift (whitelist in their application firewall).

Maybe time to get a more commodious hoster?

Thanks for all the help and suggestions, I’ll have to do without that page for now until I can sort out a new host :frowning: