Error while loading shared libraries

I am just trying to run WD in Linux Mint 18 and after I run the sudo ./ command I get the following error:

./WeatherD: error while loading shared libraries: libusb-0.1so.4: cannot openshared object file: No such file or directory.

I’m a bit of a linux newbie, and want to move away from windows.

I don’t have a usb connection to my Davies Vantage Vue station yet, as I just want to know if WD will run ok first

do you have 32 or 64 bit distro?

I don’t know if it is 32bit or 64bit as this where I downloaded it from:, and the file is WeatherD.tar.gz

you should be able to find out if the linux distro you are using is 32 or 64 bit

It doesn’t say what version it is in the filename and when I select properties if the WeatherD file in Ubuntu, it just says it is an executable type file.

How else can I find out if it is 32 or 64 bit.

The question is, what version of mint 18 are you using? Did you download the 32 or 64 bit version from Download Linux Mint 21.1 - Linux Mint


Thank you for the clarity, as I thought WeatherDisplay was asking about the WeartherD file I downloaded, my mistake doh!
I am running x64 mint, but I don’t know what the version of the said WeatherD file is.

not sure how you thought a linux distro was a version of WD?
anyway , the current version of WeatherD file for linux is compatible with a 32 bit linux distro only

Ok thanks for the reply, so that means I will have to change the linux distro to 32bit then.

yes, 32 bit Linux OS it should work
(there is no real advantage in using 64 bit for running software like WD, only need 64 bit for if you are using large video files, I would have thought?)

Ok thanks, I’ll try with a 32bit distro then.

Yes, it certainly loads up the WD program in Ubuntu 32bit. Pity it doesn’t in the x64 bit version, as I have put it on my old laptop with 8Gb of ram. My desktop has 16Gb of ram and only the windows version works.

Thanks again

I installed the WeatherD program in my Ubuntu 16.04 x64 bit system, and after extracting the files into the wdisplay folder, I ran:

sudo ./
./ line 14: ./WeatherD: No such file or directory.

I was wondering what was it looking for to return the error.

I didn’t expect it to work, but wanted to try for my own self.

./ line 14: ./WeatherD: No such file or directory.
that error occurs when you are trying to run a 32 bit compiled program on a 64 bit OS (as explained above)

The 32 bit program can run on Ubuntu 64 bit and this should work in Linux Mint or Elementary OS as well. You just need to install some 32 bit libraries to make it work.

./WeatherD: error while loading shared libraries: libusb-0.1so.4: cannot openshared object file: No such file or directory.

Is caused because it is looking for the file in /lib/i386-linux-gnu which can be installed by

sudo apt-get install libusb-0.1-4:i386

I also had to install another package with

sudo apt install libgtk2.0-0:i386

Because of this error: ./WeatherD: error while loading shared libraries: cannot open shared object file: No such file or directory

The last error you had was ./ line 14: ./WeatherD: No such file or directory. That is either because the WeatherD is no longer present or doesn’t have the executable bit set

I did find it to be a mistake to use sudo ./ as it messes a lot of permissions up so I deleted the original folder and extracted a new one