Entry Point Not Found error

Just attempted to install version 9.79a - installed but when started I get the following error:

WeatherD.exe - Entry point not found
The procedure entry point SetupDiEnumDeviceInterfaces could not be located in the dynamic link library SETUPAPI.dll.

The last version that works OK is 9.55 - I have versions 9.65, 9.75 and now 9.79a - all produce the same loading error.

System i s NT4 with SP6 and, apart from being unable to run the included FTP program (I have to use the standalone FTP package) all appears OK (except new FTP password problem - see seperate report)

you need to use the win95/nt version
see the download page
which i will update soon to the very latest version

or click here

When did that change happen? It was OK until version 9.55b (and possibly the next few releases as well…

i added support for a labjack sensor, which needs USB support (which NT does not support?, nor does win 95).
I have been telling you for a while now racetime to use the win95/nt verison…


This is the first time you have said anything about using that version.

(Apologies for double post - PHP server connection died during posting…)

And just to follow up on this, running the V9.79 NT/Win95 version produces the following error when it attempts to use the internal FTP program:

Entry Point Not Found:

The procedure entry point CheckTokenMembership could not be located in the dynamic link library ADVAPI32.dll

So the FTP program supplied with the NT program fails now…

are you refering to the ftpupd.exe verison 6.66

who else gets that error on NT?

FTP Version? Not sure as I am not always at the screen when an FTP event happens - but whatever is bundled with the Win 95/NT WD version causes the error - I have to install the stand alone version whenever I do an update (again not suer of version but it is dated 31/5/02.

And yes - I have tried DL’ing other versions of the ADVAPI32.DLL file and also reinstaiing it from the NT install and SP6 files with the same problem.

what is the status now racetime?

OK - I am still running 9.55b as the primary WD software but using the standalone FTP package V5.7

In general this combination is now working fine with only the occasional death of WD (invalid instruction or a simple crash for whatever reason). It usually runs for about 21-28 days between any crashes and usually when I am away - gaps in the data at http://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=IVICFERN1 will give an idea of how it is running.

FTP updating is back on line again - nothing was touched - one hour it wasn’t working, the next it was - so have absolutely no idea why this stopped for the 2 weeks it did.

I haven’t updated the primary WD software package since last time I tried the 95/NT version - better the devil you know etc etc so unless there is a good reason to update or any problem has been identified and fixed I will stay on this combination.

I have contemplated moving WD off the NT server as the only services it now provides is WD and as a print server and the latter can be resolved easily - but finding another machine here that is on 24/7/52 is the problem - one with an available serial port at least. We have a Linux Server but don;t believe you have a version for Linux yet.