Difficulty starting weatherdisplay

Has anyone else experienced this problem. I am setting up a new set up on a new computer {actually two computers/systems) and can’t download a new WD program. It seems to be downloading but I cannot open the download. I am using both a W10 and W11 machine(s) and get the same response. I have played around and got it to open but it’s garbled with the first sentence saying must be run in a Win32 system, whatever that means. Does anyone know how to get the program started once I download?
Thanks, Jim

do you know what the actual CPU chip is?
maybe its not x386 based
i.e ARM 64 bit CPU type
with windows running in emulation

Perhaps try running it in compatability mode?

yes, try setting to run in compatibility mode (right mouse click, properties?)


It is a “64 bit operating system, x64based processor”. I am using a minicomputer Intel core i5 to run WD and my webpage only.

are you sure you have downloaded and installed

have you tried the run as compatibility idea?
I have a 64 bit cpu pc and windows 10 64 bit and not have this error

That’s the site. What other is there? I haven’t found a compatibility option.

As you have a new machine, are there check boxes on every Icon? If so, you can right click and chose Run. If that still doesnt work, follow below instructions.

Right click on the downloaded file and choose properties, then compatability, then tick the box “Run this program in compatability…” and make sure Windows 8 is chosed, also in there i would also choose run this program as administrator, the wording may be slightly different if youre on Windows 10, im reading it from my Win 11 machine. You should be somewhere close though.

As for the check boxes on each icon, try this…

Also try, on the file you downloaded (wdisplay32.exe), right click, pick ‘Properties’, General tab, at the bottom is it marked “Security: This file came from another computer and might be blocked to help protect this computer.” Click the “Unblock” button if there is one. Then wdisplay32.exe should run.

Don’t know if this means anything but this is what I get when I download the file CRDOWNLOAD File (.crdownload)

When I open it I get that mixed up garbage posted above and it is many pages long so it must be wdisplay in another language.


The crdownload file is a temporary file created by Chrome whilst the download is still happening. If that’s the only file you’re getting then there’s something wrong with your downloads, perhaps too slow or failing part way through.

it sounds like its a corrupted download?

100% agree with Brian and Chris, the download has corrupted, this can happen when it fails for whatever reason, you have a few options;

Bashy, I tried both of you methods to download. Both work as always, it downloads the .exe file like off of the download page, then immediately starts into that CRDOWNOAD and continues on. That’s what I end up with. I downloaded the file off Google too.

That is back to front. You should get the CRDOWNLOAD file first. It will grow in size until the file is complete and then it should get renamed to be the .exe file. I’m not sure what’s happening on you computer though. Two things you could try…

  1. Use a different browser
  2. Try the download on a different PC and then transfer it to your weather PC on a memory stick or equivalent

I finally got one of those downloads to open. Don’t know which one but I am busy setting up my webpage to run from the new computer. Thanks everyone, I am sure someone’s suggestion did it. #-o

Now on to my webpage. It hasn’t updated since 3-5-22, when I pulled the plug due to that hacker.


If you’re having problems downloading on a PC that’s been hacked are you sure you’ve got rid of whatever the hacker did? I’d be suspicious that the two things were connected.