Delay on reboot/restart


Forgive me if this feature already exists. I searched but did not find it. Could there please be an option to have WD pause on startup for a user-specified time after the system starts? I ask because there is quite a bit going on with my WD computer at startup - much disk churning and CPU cycle burning. Having WD wait for 90-120 seconds or thereabouts after the system started before it began initialization would help the overall boot process run more smoothly. I am thinking of a routine in the startup that would poll the system up-time counter and run a sleep delay if necessary.


already there
called wdstartdelay.exe

which you have starting with windows start up instead of weatherd.exe

Thanks Brian! I figured it might already be there, but neither a forum search nor poking through WD dialogs uncovered the magic program. For anyone else stumbling across this thread, here is the process:

  • If WD is set to start with windows, disable that option (Setup->Launch when Windows starts->No)
  • Stop Weather Display
  • Start wdstartdelay.exe
  • Quickly switch to the wdstartdelay window and increase the start delay from the default of 5 seconds or else wdstartdelay closes and Weather Display launches. Note to Brian: It would be handy if both the default time were longer and wdstartdelay checked to see if WD was already running before launching a second instance of the program.
  • Tick the box in the wdstartdelay dialog to have it launch with windows.

Good job Mary, I’ll test this and add it to the FAQ later today.

Update: FAQ now here.

I don’t have the wdstartdelay.exe program in my wdisplay directory. Is there somewhere this can be downloaded or how can I tell if wdisplay has an outstanding upgrade?

its included with the full install of WD
which version of WD?


I can guarentee that its included with the full install

I just tested a clean install, and there it si

check again (and even use windows search/find files)

OK. Thanks Brian. I’ll check. I have noticed though, since I upgraded to this release, that the flat line areas on my graphs have cleared up any way so I no longer think I need to use this module.

Kind Regards


I just checked out the FAQ, following the steps. However, on my system there is no wdstartedelay.ini.
Is that supposed to be included in the WD disti? If not, how is it generated? Are the only contents of the
file those that you show in the FAQ? If so, that can easily be generated manually. If not, what else needs
to be put in the .ini file?



you would need to run the wdstartdelay.exe manualy to get that ini file created for the first time (and then when you run it, you can set the time delay anywhere in the program (bring it up visible from the system tray)

Thanks, Brian.


I like to use the wdstartdelay to give a share serial port software the chance to claim the com port first.

But I encountered the problem, that despite I set delay to e.g. 120 in the wdstartdelay.ini-file, WD starts always immediately. I am even not able to set the delay in the wdstartdelay window, WD is always faster.

How can I overcome that? And how can I disable wdstartdelay totally again?

Thanks and greetings,


Make sure WD isn’t set to start automatically. Look in WD under ‘setup’ then ‘launch when windows starts’. That needs to be set to ‘No (default)’ to use WDSTARTDELAY

That was already set to “No” and I also checked the Windows Autostart folder.

In the msconfig - Startup section I see only wdstartdelay, not wdisplay itself.

I now removed wdstartdelay from the startup using “StartupMan”.
If I try again to install it I get the same problem again. WD starts immediately despite I have set the delay to e.g. 240.
Anybody any idea how to overcome that?

Greetings, Uta

WDStartDelay works fine for me. The only other thing I could suggest is to check the content of your wdstartdelay.ini. My file is located in C:\windows directory rather than the wdisplay directory.
My contents for 500 second delay are:

start auto=yes

make sure that windows start up folder has the short cut to the wdstartdelay and not to weatherd.exe

I checked all again, also with StartUpMan and msconfig. I only see wdstartdelay in the startup section.
When I now startup again I get two WeatherDisplay sessions. I don’t understand that but can not spend more time on that.

I removed wdstartdelay now and went back to the normal WheatherD.exe.

I thought it would help my SharedSerialPort software to claim the com port before WD but that is not a must for my setup.

Thanks and greetings,