Davis Vantage Pro 2 outdoor temp display issues


I have had my Davis Vantage Pro 2 system for about four years. It has given me excellent service in that time. I have never had to replace anything (except the stupid little debris shield for the rain gauge - the wind blows them out.)

With recent high temps in our area, I have noticed a problem with the Davis unit displaying temps over 95 degrees F on the display. I get dashes for outdoor temp and heat index. It begins about 93 degrees with each 1/10th increase causing a brief dash period of those two displays before it will change. I have noticed that with WD open, it still seems to be getting the correct temp because the max temp is increasing and WD recorded a high yesterday of 97.9 F.

I went to Davis’ website and found an update to the software in the console which I applied. It does not seem to be working, however. At 95.4, outdoor temp and heat index are now dashed. Wind speed still changes so I can tell the console is not locked up.

The weather station has been in its location outside for at least 3 years with the console in its present location for at least 2 years, no construction or rearranging has interfered with the signal. I still get the flashing X letting me know it is receiving. The second display console in another room experiences the same problem, but it is receiving a retransmission of the first console.

Now with dashes, I can see on the WD software the temperature is increasing but nothing displays in the temp field on the console but dashes.

Do I need to replace the sensor package? Battery is good, reception is good, everything seems good, except the temp not showing when we are in higher temps. Thanks.

Have you tried to remove and replugging the temperature/humidity plug at the ISS. Could be a bad connection. Or could be sensor is failing.

Will have to try, but cannot today because of high wind and gusts. It is located high. Thank you.

I have the exact problem, I disconnected the plug from ISS for 12 hours and I still get temp and humidity dashing on the console.

I have ordered a new temp/humid sensor.

I haev the same issue (temp high of 73.3c and at the same time humidity reading goes.).

Also, wind has started recording peaks of 155mph, which is mounted on a remote anemometer transmitter and about 400 meters away from the ISS.

Had no issues until this week. I am blaming solar activity :slight_smile: