Davis IP update rate

Hi, I have a client with a Vantage Vue console and an IP adapter. Just deployed the consolewd yestertday, and this morning the weather station dropped out of the network. Suspecting it is the polling rate that could cause some havoc. Is it possible to adjust the polling rate on Davis IP type?

Entire config here:

Weather station type=32
Davis com method=2             //1 for serial, 2 for usb data logger
Davis timeout=0
OWW file location=
Davis VP IP port=22222
Davis VP IP address=
wh1080 read delay=50
Station name=redacted
Start up daily rain(mm)=0.0
Start up monthly rain(mm)=0.0
Start up yearly rain(mm)=0.0
Direction offset (whole degrees)=0
Barometer offset(hpa)=0
Davis com method=2
Revb Davis VP=Y
Davis rain gauge=2 (1 for 0.1 inch, 2 for 0.01 inch, 3 for 0.2mm)
Do clientraw FTP=Y
FTP server=redacted
FTP port=22
FTP remote dir=redacted
FTP use passive=Y                                       //(set to Y for yes, N for no)
FTP time interval=60
Save logfile=Y   //to save the .txt logfile (set to N to save on disk space)
FTP time interval=60
FTP use curlssh=Y
FTP the custom file=N
FTP use curl=Y
Logfile metric=Y
Create custom file=N   //converts the custom tags in a file called wxlocal.html to wx.html
Temp in celsius=Y
Wind in=m/s          // options are: mph,kts,kph,m/s (changes the custom tags)
Baro in metric=Y
Rain in metric=Y
run cron files=Y  // set to N to not run the separate cron files
do custom log=N    // set to Y to create an appended logfile from a template (customlog.txt)
custom log out=customlogout.txt
temp offset=
hum offset=
wmr300 channel number=1
Rain Offset=0.0  //mm
Modified rain gauge=

Welcome to the forum :slightly_smiling_face:

I don’t think there is a polling frequency setting. WD has worked reliably with Davis equipment for many years so I’d be surprised if it was polling too frequently, unless there’s something unusual about your network installation that means it woud need to poll less frequently for some reason.

When you say the station dropped off the network, do you mean that consolewd can no longer connect to it or that it’s completely disappeared so that nothing can see it, e.g. it doesn’t respond to a ping?

Thanks! Been lurking around without posting or logging in for a while :smiley:

It could just be a coincidence. It was just a suspicion I had. It has gone completely dark (not responding to ping), and this is a remote location without road access this time of year. So I guess I have to get someone to restart it and see how long it is reliable :slight_smile:

That’s sounding like a slow network if it’s so remote. Is consolewd located with the console/IP adapter or are they separated by a slow connection?

I think WD polls stations every 2.5 seconds to get ‘real time’ data. I don’t remember whether consolewd has an option to enable/disable real time data collection. If it does then you could try turning it off which should reduce the number of data reads from the station.

The Raspberry pi is on the same network as the console. The cellular connection is full fledged 4g. I have full console access to the raspberry, and I have access to the network camera on the same connection. So I suspect a good old lookup of the console here. Will try reboot and see how long it lasts.

Does the console have a static IP address or DHCP?

I think it’s static. It has been working towards a Windows computer running WD for years, but the computer now crashed. That is why I replaced it with a RPI.

weather@tilskiweather:~ $ nmap -sn
Starting Nmap 7.93 ( https://nmap.org ) at 2023-12-15 14:24 CET
Nmap scan report for homerouter.cpe (
Host is up (0.0011s latency).
Nmap scan report for
Host is up (0.00020s latency).
Nmap scan report for
Host is up (0.00066s latency).
Nmap done: 254 IP addresses (3 hosts up) scanned in 16.12 seconds

As you see, only the router, the pi itself and the webcam is present in the network currently.

If nmap isn’t seeing it then you can be pretty certain it’s gone offline. I’m out of ideas now. Sorry.

No worries, I’ll get someone to reboot it :blush:

Just FYI, a reboot worked fine, and has been stable since. Most probably a fluke :slight_smile:

Aaaand it’s back to crashing. Last restart lastet about 12 hours before it locked up again. I have not been on-site myself, but I have contact with the Raspberry Pi, and the static IP the Davis is at is not responding to anything. Sure there is no toggle for poll rate?

If there’s nothing in the config file then I don’t think there is. You could try emailing Brian to see if there’s something hidden, but he usually exposes options when he adds them. He might also be open to adding an option to do this if you ask him.