Compatibility with Windows Vista

Although ititial testing shows that WXSIM is compatible, I’m still having issues with WXSIMATE.

I guess it might continue past the error alright, but I am getting an unhandled exception in wxsimate: “Could not find a part of the path ‘c:\wxnewauto\wdata.txt’”. I am pretty sure this is a permissions problem. I can get wxsimate to run properly if I change the directory wxsimate writes the file to away from the root to c:\Users%user profile%\Desktop\wdata.txt. After making this change, it runs fine without any errors.

WXSIM was refusing to load earlier, but it turns out that it was due to an incomplete printer driver install. I just removed the printer from my list of printers and it worked.

Lastly, wxsimate is very crowded. So much so that it appears things tend to overlap. Is this because it is using the base system font which is different between Vista and XP? I’m not sure, but things are def too close together.

Thank you,
Robert Firth

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.DirectoryNotFoundException: Could not find a part of the path ‘c:\wxnewauto\wdata.txt’.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access, FileShare share)
at System.IO.File.Open(String path, FileMode mode)
at wxsimate.Form1.makefile()
at wxsimate.Form1.Button2_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

Assembly Version: 1.0.2485.15889
Win32 Version: 1.0.2485.15889
CodeBase: file:///C:/wxsim/wxsimate.exe

Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/

Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/

Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/

Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/

Assembly Version:
Win32 Version: 2.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/

Assembly Version:
Win32 Version: 8.0.50727.312 (rtmLHS.050727-3100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Hi Robert,

The path problem with WXSIMATE should be easily fixed. The “c:\wxnewauto” is actually just something on my computer. Apparently, with that last release I left the initialization file the way it saved on my last run. Just change “wxnewauto” to “wxsim” and that ought to be fixed.

I’ve seen that printer error before. You don’t actually have to have a printer, but you do have to declare one (if it’s been left undone and no printer installed previously), even if it’s just ‘Generic Printer’, in Control Panel.

WXSIMATE is fairly crowded (but still quite legible) as I see it in XP. I haven’t seen it in Vista yet. Could you send or post a screen shot?



HI,I have been running wxsim with vista starting in June. I have had only one problem. I used a reg. cleaner and It messed up my fonts so that some of the lines were off set. Font to big for window.I reloaded Vista and that fixed it. If you can ,check your fonts in Vista. Other than that runs great.