Com port changes from 2 to 5 in WD after rebooting

My old pc with Windows 10, WD and VP2 died. I got a replacement running Windows 11. Since the drive was still good from the old pc, I removed it and placed it in to an enclosure. I copied all the WD files from that drive to the new pc. I installed the latest version of WD. I worked out all the kinks to get WD working properly.

In Device Manager, Windows had com port 2 available. I set the com port in WD to 2. WD is able to communicate with my Data Logger. I set WD to start with Windows. When I restart the pc, WD is now set to Com 5 and is unable to communicate with the data logger. I can set the com port back to 2 in WD and it is able to communicate gain. This happens every time I reboot.

Was com 5 the comport you were using on the old computer
Sounds like it’s not saving the comport change
What version were you running on the old computer
Does the comport change when just WD is restarted
Is the logger usb or serial via usb adapter

You mention setting the com port in windows and saying you can connect to the station. Are you testing using the Davis Weatherlink software? If so, that will set the VP2 console into a mode that means WD can’t communicate with it. There’s a way to reset this if you need to - search the forum for the details.

I think WD used com 3 on the old computer. On the new computer, in Device Manager, it indicates that com 3 and 4 are in use. I researched online how to see what hidden devices are attached to those ports. Nothing shows up.

I tried setting the com port to com 5 in Device Manager. Reboot the computer and WD is using com 5, but there is no communication. I only use WeatherLink to test the com port in setup. It indicates there is no device on com 5. Don’t know why this happens on com 5. On the other com ports I chose, Weatherlink detects the device.

I set the com port to 6, in both Device Manager and WD and reboot. Once again WD resets back to com 5. In the WD com port setup, it shows that com 6 is available, even though it always reverts to com 5. If I change the com port to 6 in WD, communication begins. If I close WD and reopen it, it stays on com 6 and everything is working. WD only reverts to com 5 after rebooting the computer. This is the same behavior that happens when I test with com 2.

Every time I reboot the computer, WD always defaults to com 5, although in its setup, it shows the correct com port is available.

I also had to set up everything again for my Davis Vantage Pro2 and WD when my hard drive failed. I ran into a similar issue with WeatherLink and not being able to get the COM port available for WD. In the Weatherlink software, you need to go to the Setup menu and select Communications Port. You then must select ‘Serial’ in order to run 3rd party software like WD. When I did this, it could not find the COM port at all, even when hitting the ‘Auto Detect’ button multiple times. However, if I selected USB, Weatherlink could find the USB data logger.

How did I solve this issue? When you installed WeatherLink v6.0.5, it should set up a some folders. In the folder Weatherlink > Support > Utilities, there is an executable called ‘CP210x USB to Serial Converter.exe’. Running that executable solved my problem.

Another solution that I found documented in wxforum.net is to unplug the data logger from the PC. Unplug the Davis console from power, remove the batteries. Then add the batteries, plug back in the AC adapter, reinstall the USB driver, and see if it now lets you use the ‘Serial’ selection in the Weatherlink software in Setup > Communications Port.

I’m not sure this will solve your changing COM ports issue, but it’s worth a shot, IMO.

Brian

I had originally setup WD to start with Windows minimized. Which it did every time I rebooted. I decided to change the minimized setting from yes to no. At the time, I had WDISPLAY.INI open. Start minimized remained set to yes, until I “Exited and Save” out of WD. After that start minimized in WDISPLAY.INI was no. When I rebooted the computer, WD once again started minimized. I checked WDISPLAY.INI and start minimized was set to yes. The same thing is happening to the com port. I’m not sure why my changes are not surviving a reboot.

I shut down and started the computer several times this afternoon and WD had the correct com port, communication was successful and was no longer minimized. Tried it again a little while ago and WD started minimized and had the wrong com port. At that point I could go into WD and change the com port to the correct port and communication was successful. I’ll just keep experimenting.

The com port is in both the ini and the reg files

Wdisplay.ini file

Wdisplayftp.reg file

So you will need to check they are both the same
Best to use action backup settings files then shut down WD then edit them if needed then copy the ini file to main folder and double click the reg file to get it to install

I only have: C:\wdisplay\databackup\wdisplayftp.reg. It does not exist in the main folder.

It contains: [HKEY_CURRENT_USER\wdisplayftp.ini\Comport]
“last page number”=“0”

There is nothing for this in the registry for this.

I don’t ftp any files. I host my own website. Do I need to add the file to the main folder and update the registry?

If you do Action >Back Up Windows Registry Entries as suggested you should get both in \databackup

If not you can always copy and edit the current wdisplay.ini as long as you shut down WD before putting it back!

As @hcorrin says, only wdisplay.ini goes in the main folder. You double-click the .reg file to get it added to the Windows registry.

I looked at the WD files on the hard drive from the old pc. In databackup there was no .reg file. On the new pc, I double clicked the .reg file and it was added to the registry. It didn’t make any difference.

Any changes I make WD are saved in WDISPLAY.INI. I can close WD and reopen it and the changes are retained. When I reboot the pc all the changes I made are lost. They are back to the original values, before I made the changes. It’s almost like WD retained the values somewhere and reinserts them in to the settings.

Before I did anything on the new pc, I copied all the WD files from the old pc’s hard drive to the new PC. I installed WD and opened it for the first. I made the changes to the settings to have WD open with Windows and start minimized. Now, whenever I make changes to that setting, to not have WD minimized, after I reboot the pc, it’s back to minimized. All my changes do that. It’s like WD has the original values stored somewhere and replaces all the changes upon a reboot. I don’t know where WD is getting them from or why it would do that.

I edited WDISPLAY.INI and put an x at the bottom of file and saved it. After I rebooted, the x was gone. I also tried adding a text file in the WD main folder. After I rebooted the text file was still there. It seems like the problem is coming from WD and not Windows.

Maybe it’s best that I copy all the files from the old drive to the new one and start over.

Try this,
Copy files and folder from old PC. Install new version (do NOT run). Double click .reg file. Then run WD

That’s what the Windows Registry does for many programs. WD started out being developed when use of the registry was less common and .INI files were used to store program configurations. WD probably uses both the registry and .INI files for different things, but I think you need both to make it work correctly.

Or follow the FAQ Moving WD to a new/different PC

This is the best option

I have changed computers several time. Go to the device manager, open ports look for USB serial ports number, then take that number and open WD control panel goto and station types & settings, on the right side com port numbers and put the number from device manger in there, then save and close and then re boot. then download latest version. then open backup in C: wdisplay/databackup and pick your last good backup date zip, open it and double click on regedit. Then reboot. Hope this helps.

On the new computer, I deleted all the files, uninstalled WD and deleted the Registry entry.
I copied the files from the old computer to the new computer. Com 3 was used on the old computer, so I changed the port in Device Manager to 3. It complained com 3 was in use, but I chose it anyways. I reinstalled WD. Started it and couldn’t communicate with com 3. I opened WeatherLink’s setup, and tested com 3. It couldn’t communicate either. I shut down WD and I opened Task Manager to make sure WD wasn’t running something. I noticed WD display was still running. I tried killing it, but got a message indicating it couldn’t. Then I remembered that I had a utility program called FireDaemon start with Windows. It sort of encapsulates WD and turns it into a Windows service. I got that utility back when I used Virtual Weather Station. By turning it in to a service, if the computer rebooted VWS would run automatically. When I got WD, I replaced VWS with WD in FireDaemon. It worked on the old computer. I installed it on the new computer and forgot about it. I decided to use the start with Windows option of WD.

The utility would start an instance of WD as soon as the computer started and grabbed com 3. It always started before WD. Since I copied the old files over and WD was using com 3, that was a problem. I shut down the utility and started WD and it worked. It was communicating. I restarted the computer multiple times and WD was always able to communicate with logger. I still had to change some other settings to get everything working.

Since the old computer was inoperable, I couldn’t back up the registry. I didn’t already have a backup. I got WD running without doing anything with the registry. I backed it up any ways, and double click it.

It works, except I get this after I reboot the computer:

image

It just sits there and nothing happens. I click abort and WD opens and works properly. I need to figure out why this happens.

In WD goto control panel/stations settings/data logger and turn off extract data at startup. There may be no data? If you turn your computer off/on you may have to turn it on but there has to be some data.
windows sets the com port number for silab can be different number on different computers. You set the number in WD to what ever number silabs is set to, forget the old number.

I run my computer 24/7/365

I can’t seem to find that setting.

You are right about there being no data. I opened WeatherLink and tried to download data. I got a message indicating that there is no data.

I never had this issue with WD on any of the computers. I haven’t had any issues running WD on past computers.

It’s just Control Panel > Data Logger

You mean this?

WD didn’t check the logger after a reboot this time. Is this used for when the computer has been turned off for a while, WD will pull the missing data stored on the logger?

I wouldn’t think having this on, that WD can’t handle no data in the logger. This is the first time I’m using a USB data logger. I’ve used the serial logger in the past.

I keep the computer on all the time. Windows update caused the computer to reboot.