1-wire Lightning Dector - Actual Attempt

I figured I would start a new thread in regards to the actual “attempt” to install the Hobby-Board 1-wire lightning detector and associated items…

For anyone that missed it, this thread got things started with me trying this…

I got the USB 1-wire adaptor late yesterday, actually I don’t know when I got it as I saw a box on a bookshelf and asked what that was and one of my “Darling” daughters said Dad that was delivered a while ago… Grrrrrrrrrrrrrrrrrr LOL

So today I have some quiet time (means Boss and daughters are out for a few hours and the Music is cranking on my new Onyko Stereo System :slight_smile: ) so i am going to try and do a test hook up. I read that you can set it up and touch the antenna lead to the earth ground and if working get “hits”…

I download the drivers from here:


I install and I am prompted to install .NET framework 1.1 which I do…
Available here: http://msdn.microsoft.com/netframework/downloads/updates/default.aspx#.NET%20Framework%201.1%20Downloads

I get same prompt after installing so i reboot… I still get same prompt and then I realize it isn’t actually the same prompt, but the link takes me to same place…

It was a second prompt to install: Visual J# .NET which I get and install, this download is located here:

Ok now the install for the drivers goes swimmingly and all says is OK… It still cannot detect 1-wire adaptor, so i reboot again, as noted in the readme. This time after rebooting it is detected and I think all is well…

BUT I can get no readings anywhere, tried OneWireViewer Application, tried WD setting up Lightning detector and all No-Joy :frowning:

I really would like to test this thing before I go and make it’s permanent home and run 50’ of wire and drive in a three foot deep ground spike…

Anyone have any ideas?


check in windows control panel, device drivers, for the usb adaptor and it should say there what port number it is on…
mine ended up being as port number 1…which is not to be confused with com port 1
in wd, in the com port setup, you will need to tick, i want to use a dallas 1 wire, then tick, usb,then set the com port number to 1 in that , i want to use a dallas 1 wire, then tick, i do not have a temperature sensor
then click on ok
then go to setup, control panel, dallas 1 wire setup, and click on save/reset
and you should see the 1 wire ROM id counter

Hi Brian, Fancy meeting you here :stuck_out_tongue:

I will try those suggestions on my next attempt to get this tested, prior to full installation.

Right now my system doesn’t seem to recognize the 1-wire sensor or adaptor at all so i will most likely have to uninstall and try from scratch… which may not be today as it requires (or has so far) a reboot to get it installed…

Will keep this thread posted…


yes, its a shame so many reboots a required for those driver installs…1 more might do it
actualy, just checking my device manager, it lists it at the top, under 1 wire deives
but does not say what port number
but the i button viewer reports USB1 down the bottom left hand corner,. hence the 1 needed for port number


I got to that, but unless there is something else I am missing I get no incremental counts when testing by crossing Antenna Lead to Main Earth Ground so I have no clue if it is actually working?

I see where you are to enter specific IDs for specific tasks , wind, temp and so on BUT no Lightning field…


I see where you are to enter specific IDs for specific tasks , wind, temp and so on BUT no Lightning field

There is a tab along the top for the lightning detector. Copy and pasted the rom id from the list window in there and then do a reset/save.

Testing is best done with a spark source, like a gas fire lighter or similar.

now that you have a 1 wire Jax weather, and now that i have the 12 volt 1 wire switch working in wd (latest version of wd now had a sheduler ), you can get WD to turn things off and on.,…like turn the coffee machine on …turn of the or irrigation, set things based on temeprature ranges (i am still to add that), even get a leaf wetness sensor and wd could turn something on or off as soon as it starts raining, etc

I tried that, there are 3 question marks in the field “???” and no matter what I try it will not allow me to enter… I paste and it shows but then disappears. I also am unable to erase the “???” nothing works…

I wish I had 1-wire Brian… either something still isn’t right in WD OR my Lightning Detector ain’t working :frowning:


there are 3 question marks in the field "???"

No no…thats for the direction indicator on older 1-wire versions. You need to select the Lightning tab (along the top of the window) in the 1-wire setup. :slight_smile:

Yes yes… YES

That was the ticket… Tested with spark fire lighter and BOOM It works !!!

Thank you :slight_smile:

Ok now to get in set up outside and functional… which won’t be today or tomorrow as it is miserable out there today LOL (just my luck)

Thanks 41South and Brian :slight_smile: :slight_smile: :smiley:



Excellent - pleased to be of service. :thumbright:

Jaxweather…you had me worried :slight_smile: I’m going to follow this thread in getting mine setup.

Going to send away for my parts this week., Which cabling are you going to go with ?
The Cat5 or Telephone cable?

Hello Ed,

Actually I was going to use the twisted pair stuff from Radio Shack however I discovered (along with my RJ crimpers) I had some 6 wire shielded cable (flat) laying about and I am going to try that first…

If you have to buy stuff I would think the Cat5 would be best followed by the twisted pair cabling however that is an assumption on my part.

I have submitted a FAQ to the “Powers that be” regarding installing the USB adaptor and setting the Lightning Detector up in WD and if approved will eventually be added to the FAQ section…

Will post more later in the week when I actually get it installed outside in production…



Thanks for getting a fact together for the setup, it’ll be a great addition.

Also remember…you can assign a Wav file to your lighting hits for an audible alert.

I did forget that and will do that when in production… Thanks again,

Ok I must be missing something as I do not see a .wav that I would associate with Lightning hits listed in Alarm Settings ? Or under Lightning Counts.

I do have it enabled to email me right now, as part of my testing which does work fine but I don’t see a location to enable an Audible alarm?


you need to create your own .wav file , called that appropriate name, and have it where wd is stored :slight_smile:
maybe do a serach on the web for a sound file that sounds like lightning?>
or just record your own voice, and fo, “shit, that was close!”

Hi Brian,

Called what appropriate name? I don’t see a name in the list that appears to be associated with “Lightning” ?

I understand say for firstrain.wav you would locate a raining sound, name it ‘firstrain.wav’ and when first rain of the day occurred it would sound… However this is the list if names I see in the box?


Don’t see a "lightning’ name?


ah ha
i must have dreament i had put that ability into the program!
i will add that now, for the update

Finally One Time it “wasn’t ME” LOL

Thanks Brian :slight_smile: