WXSIM Version 12.6 Beta 6 ready for testing

OK, here’s another one! Go to www.wxsim.com, and Downlaods, to get the Beta 6 upgrade.

I created a new check box in WXSIM to allow control whether or not the program closes after an auto run. Without first checking to see if there was a problem saving settings, I made a change that should make saving of settings more certain, even with that automatic closing. A quick test of a change I made while the program was up (before the run started) confirmed saving of at least the item I tried (Fahrenheit versus Celsius).

In WXSIMATE, it appears all the data WAS getting download and imported - it just didn’t look like it because by the time the files are all culled and appended, the local data import seems to have been done, and the screen disappears before you get to see the progress bar of data from the local data import. I tried several things to try to force it to show the progress bar, but to no avail, so I put a note in red under the new check boxes advising users that they might not get to see all the progress bar action before the program closes itself. That shouldn’t matter too much, as auto runs are often done with no one watching. You can verify creation of the files localdat.txt, localcal.txt, and locallog.txt by looking at their time stamps, though. Let me know if you see any failure to create them. It seems to work consistently here.

Thanks for the feedback! :slight_smile:


Hi Tom

Installed beta6 and everything is running fine - both in WXISMATE and WXISM.

Best regards,


Works great here also. The new auto close feature works for both Wxsim and Wxsimate, and Wxsimate is doing the local station data import just fine, prior to auto closing.

Thanks! Tom

–Kevin H.

Yea it works perfectly here too.

Tom still not saving changes on the autorun form. I turned off Use MOS/GFS Advection data and turned on Close when finished, then clicked on Run Immediately and it ran, it did give run time error 6 at the end and then closed when I cleared the error box. It does not save my changes on the Autorun form. Tried this twice and both times the Overflow error 6 which I did not get with beta 5 or any previous ones.

Edit: Just twigged that the Run time 6 overflow is what is closing WXSim - ignore the comments about not saving until we get the overflow fixed. The error happens after the forecats screen closes. As I said I’ve not seen this error before on any of these betas, I am running this version on mytest PC under XP as I did not want to run it live yet. Beta5 is still running clean on my weather PC (W2K m/c).



Regarding that overflow error you saw, can you check to see if it happens if you run WXSIM with the new ‘Close’ box UNchecked? I’d like to know if the problem is somehow triggered by the new option.



Tom happened both with and without the new Close check box checked on last nights tests… however this morning with a fresh download of input data from WXSimate it is all running fine with no errors. Now I dont know if this was anything to do with the timing of my testing which was between 23:30 and 23:59 last evening. Cold there have been some anomalies in the data which caused this error? This is not a normal time for me to run it, I just did it as I found the new beta6 at that time and decided to do a test or two before bed.

I’ll test a bit more this morning and see what happens regarding the saving the options etc.


A few more tests and all seems OK now, no errors and all options being saved OK. So I think there must be a problem with the data collected just before midnight which caused the overflow, not sure now whether it was using GFS advection or not when these errors happened.

However one thing would be nice and that would be that the ‘Run immediately’ was not saved after a run with it set. There have been times when I’ve left this in the past and forgotten and it seems to mess up any future autoruns.

One last point, I am a little concerned about a recent forecast which predicts 30mm of rain for this coming Thursday, while 30mm is not impossible, it is in my view improbable, could the new GFS advection data impact the rain predictions? August here can be wet and has been in the past the rainiest month of the year and we do get sigificant rain events sometimes but the highest I have ever recorded here is 37.8mm in 4 years.

I am getting an unhandled exception error dialogue box with wxsimate, in manual mode if I have the metar “first instance only” box ticked. If I untick it then the error does not appear. The error message is “The process cannot access the file C:\wxsim\culbouy.txt because it is being used by another process”.

  • Running XP SP3.


12.6 beta 6 running OK here Tom in auto. Thanks for the added boxes post beta 5…close after download and import etc… I don’t however, use/tick them at the mo as I use other means.

I did note that on an evening run yesterday, that right at end of the wxsim run, there was an added note on the last day of the txt fcst, “Text box Full”. However, nothing else untoward happened and everything looked normal otherwise. :slight_smile:

I often get this message and it has never caused me any problems.


Hi Tom,

No issues so far for beta 6!


Thanks for the confirmation Stuart…Because the page closes so quickly in autorun, I don’t generally have the opportunity to see the running output… :wink:

I just downloaded my this Beta this morning. It runs fine in Manual mode but I get the following error in Auto Mode

I am sure I probably just don’t have a correct box ticked?.



When I run in auto it finishes <30 sec. No error boxes.

In manual, I get to the data import screen (using FOUS, RAOB, READY/GFS). Then an info box when getting through Adv Data Entry states MOS has run out, the runtime error 62, ‘Input past end of File’.

Some answers …

‘Text box full’ just means that the 32K limit of the output screen has been exceeded. Nothing is lost in the saved forecast files. To keep the message from appearing, you can just increase the output interval (under Parameters) say, from 30 minutes to 1 hour.

If you get a message that no FOUS, READY, or GFS was used, that means you need to tell WXSIM to use it. In Auto Run mode, that’s done by checking the appropriate boxes on the Auto Run form under Start.

I’m curious about the error 62. I need more details about exactly what actions you were taking and had taken. Note that you should use MOS for intiial advection, and also not for home site data. I have safeguards in there against that (mostly the option button should be disabled at those times), but some sequence of events might be letting it slip through.


Tom could you please comment on my message earlier here.

Also my comment about the rain, something has obviously changed in the input data as Thursday’s rain forecast is now a much more reasonable 5mm daytime and 7mm at night, still high but so unlikely as the 30mm before.


Tom atatched is my setup for auto run

If I mark “use GFS for initial advection” I get a runtime62 error everytime I try a full start


I just did a manual wxsimate import, however, the import screen w/ checkboxes quickly flashed, not allowing me to select anything. Prior to this, a scheduled autorun completed. If I close wxsim and open, then I get the import screens. Import Data did the same.

Data Import screen has NAM, RAOB, and READY checked.
Get Data, Set Upper Wind-OK

Full Start:
Upper lvl data-RAOB-OK
Adv Data Entry-Regional-Import-Get data-OK
Adv Data Entry-Use all-OK
Int Planner-use model data-OK

Adv Data Entry-Regional-Import-Get data-OK
Adv Data Entry-Use all-OK

Info screen-FOUS, Do you want to update wind dir-NO

Adv Data Entry-Regional-Import-Get data-Mos data has run out. Choose another advection.
This time I clicked OK to get back to Adv Data Entry, didn’t get the error62, selected NEUTRAL, then back to REGIONAL and picked the routine back up.
Import-Get data-OK
Adv Data Entry-Use all-OK…to the end.

Repeated again. Same problems.

2 very diff forecasts b/w manual-temps 91 to 92 rest of week w/ little to no precip.
Auto- temps high 80s with much more precip.

Answers to a couple of earlier posts …


The new GFS advection routine has no effect on rainfall (in fact none of the advection options do anything to rainfall). The 30 mm was derived from the home-site GFS data, which I’m pretty sure hasn’t changed.


OK, idea #2! It’s likely then that on your Import form, somehow READY/GFS and FOUS have gotten unchecked (I don’t know how it would have happened). In manual mode (disable auto run for a bit), go to Import, and make sure the METAR, NAM FOUS, RAOB, and READY/GFS boxes are checked.

Let me know what you find.

Well, school starts tomorrow, so I may be getting a bit busy with that. I do plan to get Version 12.6 officially released in a week or so, though.