WS 16 Fails [RESOLVED]

Good Morning/Afternnoon

I run four WS 16 units from Novalynx
I have had them for ages but with WD I need to constantly reset the program. The Data quality lamp is constantly on red.
Eventually the the green Data received light flashes but the increment stays the same.
I have tried these on 19200 and 9600 (Of course I changed both ends) The units all work fine in hyperterminal
9600, 8 bits, no parity, 1 stop bit with no flow control.
The software runs on a decent HP with Intel core2 [email protected] and 4Gig Ram (3.25 on XP 32bit)
Whilst this has been a minor nuisance as the sites weren’t public, the push now is to make them so.
Obviously I cant be resetting them twice a day.

My first thought is that the WS16 parameters may be set wrong in the code. I often upgrade the software and it has still remained a problem.

This is a standard line received fro HT
10/05/2011, 16:22:40, 8.11, 0.00, 29.78, 94.29, 84.70, 6.77, 83.55, 82.93

Hopefully there will be something easy to fix



its not all that clear exactly what is going wrong or what is or what is not happening, to me.
do you get data, or not?
if you do get data, do you then say that it stops as some point??
its not very clear

 WS-16 here too, good to know I'm not alone:-).  If newly using with WD make sure you have the other data sequence box checked, as originally the data sequence the WS-16 outputs is not what WD is programmed to expect. Check the View menu to see that WD is getting the data in.

 The Red data quality box is ALWAYS RED (at least for me...), if it isn't something is wrong! Not logical but that's the way it is. The green box will flash when the WS-16 transmits data.

I’ve been traveling down this particular road for 2-3 years now with WD and the WS-16.

The data keeps flowwing and I have confirmed this.
Overall (I’m looking at one of them right now) the data quality light is solid red, The data received light flashes green every five seconds but the increment counter is not moving.
If I shut down the program it will work when I restart it.

As I said my data quality light is always solid red(and always has been) , where as if run it on hyperterminal the data is clean with no errors. I’m wondering if you have set something wrong in the software re guarding the comm port parameters.

I even have one coming in on a serial over TCP link and that suffers the same problems as one connected direct to the com port.

Actually just looking at the program error log

ERROR: ''78

the data quality light being red is not a big problem
i.e nothing to worry about
i.e just means I have not hooked it up to go green when data arrives from this station type
I will fix that for the next update of WD

the problem instead for cayman is 2 things: first the start up error
(use the debug version to pin point that)
and then the out of memory error
(what other programs are runnning on the pc, maybe monitor the performance/memory etc)

I think I stated the start up bit wrong.
When I start the program it is fine apart from the red quality led which we now know is purely cosmetic and more “I’m recieving steady data” type deal.

The memory issue is interesting as the times are generally random and not all four stations crash. sometimes only one or two.

The computer itself is running nothing much at all.
an earthquake location client that runs in a java enviroment, Mcafee AV proffessional 8.8

Funny, similar thing happened at the same time this morning.
I will keep looking every day.

ERROR: ''82

Cayman: You need to download and run the debug version as Windy suggested. It’s on the download page called “Weather Display with error/crash debug code v 10.37Q Build 80 Debug” it will create an error file weatherd.elf in your c:\ folder.

10.37Q Build 80 Debug installed for all four stations

Ok another station crashed,. Program event log is clear.
I’m runnuing the debug version but can’t find a log file.
WD is still up and running. My data recieved light is flashing every 5 seconds but no increment or data actually displaying.

If shut down WD and restart no problem
The other stations running didn’t crash.

Ok another station crashed
how do you mean exactly by that statement?

from what you then say after that statment, its not a crash as such but unstead sounds to me like the data being received from the station is not being recognised by WD anymore

you can set WD to log the raw data under view, advanced/misc

then the raw data will show up under view, WS2010/WS2500 data setup

see what shows up there the next time the data flow stops

the memory error you are getting could happen if too data lines arrive joined end to end (i.e double in length)
I have increased the array size, in case that might be happening, latest .zip update, so try that

Nothing bad noted here on my WS-16 with the latest zip. update, and Data Quality is now green instead of red.

yes, I fixed the data quality not showing green for this station type

Ok your right, data being received from the station is not being recognised by WD anymore rather than crashing.
Although there is the odd crash probably related to the memory issue.
I have installed the new version and wioll see how that goes. The green quality light works now. Lets see if the array size helps the other issue.

I will let you know.

Big game this Sunday! (I’m an Aussie)


Go the all Blacks!

OK one station stopped working this morning. The data light is still flashing but the data is not being recognized by WD
I didn’t see any data come in on the WS2010/WS2500 data setup screen

This is from the program error log.

ERROR: ‘‘12753’’ is not a valid integer value at time/date 8:12 am 10/11/11
repeated 7 times for some reason.

When I close WD I get

error signature
AppName: weatherd.exe AppVer: ModName: kernel32.dll
ModVer: 5.1.2600.5781 Offset: 0001afb

Attached is the error report from XP if it helps.

I have to say I think the All Blacks will win. The Springboks played far better than the Wallabies but just couldn’t get it over the line.
If it was a boxing match they would have won on points no problem at all.
It was certainly one of the toughest game of the series. This Sunday may be tougher.

87a4_appcompat.txt (128 KB)

This is from the data file

10/12/2011, 02:13:25, 2.39, 0.00, 29.76, 83.51, 81.18, 205.14, 81.18, 75.85


Just went again

10/12/2011, 15:30:45, 3.82, 0.00, 29.72, 61.25, 88.28, 113.99, 88.28, 73.66


looks like some control characters are getting into the data stream at times for some reason
causing that error
the latest .zip update will handle/check for that now

Build 81 installed.
Lets see how we go.
Hope your weather calms down for Bay of Plenty