Wireless weather station gives incorrect wind speed readings

Hello everyone,

I just recently purchased a La Crosse 2310 wireless weather station and I totally love it!!

One thing that has got me puzzled though. I mounted the wind vane on a wooden pole and attached that pole to the railing on my apartment balcony.

I have noticed that every evening the wind reading on the weather station will show strange results…sometimes the wind speed will be 22 miles per hour when the wind outside is totally still. All of the other readings temp, rain etc. are correct.

Any ideas as to what might be happening with this. I really like this weather station and I hope that I can get it to work.

Thanks
James

....I have noticed that every evening the wind reading on the weather station will show strange results..sometimes the wind speed will be 22 miles per hour when the wind outside is totally still. All of the other readings temp, rain etc. are correct.....
Turbulence due to your building may be causing erratic readings.

From An Inexpensive APRS Weather Station

Wind speed and direction:

Thanks very much for your help. Any sorry for the multiple postings…new at this forum stuff.

-James

quite a few weather stations have the windspeed affected by electrical intereference…
and there are some solutions, like good grounding of the PC, ferrit baluns and the like, replacing the data cables with sheilded cables, iso opto couplers, etc

The problem might have something to do with the propeller design Lacrosse uses. On the other hand you might place the wind sensor higher in an open spot to get best results.

Call the vendor.