Web Cam Image size discrepancy

Hi.

(Sorry, put this in wrong forum - should be in WD. M. :slight_smile:

I have found that the size of web cam image created differs slightly (smaller than) from the settings one enters into the dialogue (can’t remember the name, but its the one in which you can also add a time stamp and weather data to your images). It also crops the image slightly from the bottom. I’m using latest version 10.35q.

Regards - Mat Mackenzie.

I’m seeing this issue too. My third party network cam produces a 320x240 sized image. I have the “Image height/width adjust” set to 320x240, but I’ve had to set the “File image height/width adjust” to 337x258 in order to get the whole image shown. I end up with a 321 x 242 sized image with a slight grey border. If I set both values to 320x240, I end up with a 304 x 214 sized image (cropped).

To me these settings seem to have little bearing on what sized image they actually produce… I spent a good while trying to get WD to output a webcam image the same size as the input and even now I’ve only gotten close but not spot on. When WD restarts, it seems to revert back to producing a 304x214 sized image, so I have to open up the 3rd party webcam settings and play around with the sizes until it comes good again.

Same with my 3rd party webcam, a 640x480 image needs to be set as a 650x510.
It doesn’t bother me, I just adjusted the setting and left it alone, no problems.

Yeah that’s not so bad if it produces the image of the correct size on start-up… mine seems to revert back to the smaller size when I restart WD for some reason. Weird!!

Hey just a question krucky, do you have both lots of image settings (Image adjust and File Image adjust) set to 650x510, or just the lower lot (the Image Adjust Height/Width)?

Cheers,
Graham

I only changed the bottom set.

Afterthought - Try removing the custom tags for a little while if you can’t get the settings to stick, I seem to remember having a few problems there myself, now I only use the time stamp. But I am using an old slow computer so that could have caused the problems…


Thanks Krucky, that’s what I’ve done too, but if I try and adjust the second lot of values so that it produces a 320x240 output, it always crops it back to 304 x 214 for some reason… it seems like the File Image parameters need to be slightly bigger than the actual image, for me anyway (although looking at your webcam, I see you have managed to get it to work and produce an image exactly the same size as your source webcam image). I’m running 10.35u by the way, but I don’t think the webcam stuff has changed in a while.

I too have a very slight grey border on the bottom & right of my image but it is only 1 or 2 pixels so I’m not worried.
Your one up on me though, I see you have managed to get your alldayvideo working, I can’t seem to get mine working correctly since I changed to in IP camera.

Ahh well that makes me feel better if you get the grey border too! :smiley: :smiley: I’m not too worried about it either… it would just be nice to get the image the right size… which leads me to my suggestion about your all day video. I was getting an error when running the encodenew.bat or encodenew2.bat. Is that the issue you are having too, or is it failing somewhere else?

I just ran my encodenew2 in cmd and yes, there was an error.

I found another thread on this issue from a few months back, but no solution. :frowning:
http://discourse.weather-watch.com/t/17102


C:\Program Files\wdisplay\alldayvideo>cscript.exe wmcmd.vbs -input "C:\Program F
iles\wdisplay\alldayvideo\videolastday.mpg" -output "C:\Program Files\wdisplay\a
lldayvideo\videolastday.wmv"
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

Prepare to encode failed with error -1072889796 The specified stream does not ex
ist.


C:\Program Files\wdisplay\alldayvideo>COPY "C:\Program Files\wdisplay\start.txt"
 "C:\Program Files\wdisplay\finish.txt"
        1 file(s) copied.

Ahh right, that sounds like the webcamcapture program has not produced the mpeg version of the all day video from the timestampted jpg webcam files. I basically just followed the All Day Video setup in the WD FAQ forum to the letter, and it did start to work for me (although I later had another issue running the encoding batch files, caused by the dimensions of my webcam images being slightly off, which I thought could be a similar issue to what you were experiencing). Does the movemaker start up around 7-10 minutes past the top of each hour? You’ll still need to have the webcamcapture program running in order for this to happen (even though, like me, you’re running an IP camera).

Mpeg videos & images were producing a while ago, but I shut down WebCam Capture a few weeks ago. I have started it again and will see if the error is the same in the morning. ZZzzzzzz…

No problems Krucky, happy to help out if I can, so let us know how it goes! :slight_smile:

Same again this morning. error- 1072889796. The specified stream does not exist. :?
I tried running encodenew.bat for the hour video which I don’t use, just to see what error comes up when the files are not there. This time it had an Error: 0x80070002 - The system cannot find the file specified.

maybe try with fresh web images
(i.e delete them all)

OK, done. All that is left in the alldayvideo folder is encodenew2.dat & WMCmd.vbs

The mpg was producing, its just the wmv which is not.

is windows media encoder installed?
also try deleting the wmcmd.vbs file, so that the one included with the wd install is copied there instead

Encoder is installed & I have now removed the wmcmd file.

Last hour only jpgs & mpg were produced.

I tried to convert the mpg manually through the Media Encoder and I got an error of -The input media format is invalid.

that sounds like an error with the mpeg file format
is this with which version of the moviemaker and wd web cam capture?

Hi Krucky,

I’m such a dunce… looking at your error again, I realise now it IS the same problem I was having!! I take it from your post above that WD is creating the two .mpg movie files OK (videolasthour.mpg/videolastday.mpg), but the encoding to WMV is obviously failing. Can you play back the .mpg files and do they look OK?

Assuming that’s all OK, can you open up one of the “XXXXjpgwebcam.jpg” named images from the alldayvideo directory, and tell me the EXACT pixel dimenstions of the image. I suspect it’s going to be something like 641x481 or 642x481. If you can get me that info, I can give you a modified command line to insert into the encoding batch files that will hopefully solve the problem for you, by cropping the mpg video source to the correct aspect ratio for WME.