Weatherlink 5.8-> USBxpress mode

I downloaded Weatherlink 5.8 and checked USB to check out the software. Big mistake, it changes a byte in the datalogger and will only run USB . They have a program to change it back to serial but it does not work and you get an error code. Called Davis support and they know it and are working on it, no time span to fix the problem. My web page has been down for three days. They agreed to swap out my logger to get me going. MY USB has always work well. I am going back to 5.7 for a while, waiting for logger. DO NOT CHECK USB ON 5.8 WEATHERLINK SOFTWARE!!! OR NOT COM PORTS PERIOD. There is a warning about third party software and com port. But no warning of a one way street. Joe

Update: the later versions of wlink 5.8 now have the cpx210.exe program included in the install…run that is the usb data logger has been set to USBexpress mode, to set it back to normal USB to serial mode

I tried the USB connection option of WeatherLink 5.8 with my test console which is USB. WeatherLink said it couldn’t find it. But I was able to connect to it using the virtual COM port just like I did with the previous version of WeatherLink. I understand your warning about the USB option in WeatherLink, but I don’t understand you saying the same think for the COM port option, as I’ve tried it and it seemed ok to me.


Just a thought, but why don’t you try uninstalling the Davis drivers, rebooting, and then reinstalling the drivers. I’d be curious to know if that allowed you to go back to using the COM port connection you used to use.

I have done that. The problem is in the logger. If you click on USB in the com page it changes the information in the usb logger and you can not change it back to work on serial. It’s a bug in there software. They are sending me a new logger. Joe

Sorry but I’m lost, can you explain that a bit? Your profile says you have a USB logger, so that can only work USB - right? How did it ever work on serial ?

I think the problem is that before version 5.8, WeatherLink (and other weather software too) comunicated with the console by using a virtual COM port created by the driver. With version 5.8, it looks like Davis is skipping the virtual COM port and communicating directly through the USB driver, skipping the virtual COM port.

Scary 8O

Yes I have a USB logger I clicked on USB and it worked OK. But it changed something in the logger per Davis support so it is USB only. There are no com ports. I then clicked on serial it shows the com port but will not find them. There is a program in the Weatherlink 5.8 directory to change the logger back to serial but it does not work and gives an errors. The program USB to CP210X.ex? has a bug and will not change logger back to serial with virtual Com ports. Davis is sending me a logger USB that will work. I removed 5.8 and re installed 5.71. IF IT WORKS LEAVE IT ALONE! Joe

Indeed they seem to offer Silabs USBXpress to skip the UART may be of interest and perhaps Softx could use this with an alternate version of VVP if it chats to the device any better?

I see the install also installs a folder with V5.0 of the standard USB drivers


My serial logger and 5.8 work fine.

I think that’s what Davis did in WL 5.8, and apparently the experience is not so good. There is also a person on another forum with the USB connection drop problem who tried WL 5.8 in USB mode, and although the connection problem didn’t occur as frequently, it still occurred. The way VirtualVP works around the VP USB problem has completely solved the issue for many people. I know this because they’ve written and told me. I think I will stick with the current method since it’s proved successful in almost all cases.


If this USB problem happens with all new USB VP2 interfaces uses who wish to move away from the provided Weatherlink to an alternate product could have an issue.

e.g. Someone buys a VP2, USB Logger and runs weatherlink 5.8 selecting USB.

Weeks later they note Weatherlink is a bit limited in what it does and want to try WD but cannot because no COM port is available.


I talked to Larry in support at Davis and he said several people have had this problem and they are working on a fix and hope to have it soon. I don’t know how long soon is, so I ask them to swap my logger so I can get it going again. They are sending me a logger.

There is now a v2 of the utility to convert back to serial port operation, which should have the bug fixed. It should be uploaded to the Davis site in the next day or two.

That is exactly what happened to me. I have had my station up for a week. I setup my web page with Weatherlink last night and thought ‘this is ugly’. Found WD and thought that looks nice and has more options. Went to try the trial version and I can not get it to communicate since there is no Com port. I have been everywhere (boards) trying to figure this out. I am so glad I found this post. I was starting to think I was loosing it. I am not sure how to proceed though. With the new software Davis will not be assigning a com port to the usb anymore? So will WD create a fix or is the only way to downgrade the Weatherlink software?

Another item you may wish to beware of with WL 5.8 is if you are running Vista.

It will install itself under C:\Program Files\Weatherlink and apparently create a folder under Weatherlink containing your station data.

Of course it is not, and Vista just pretends that’s the location of your data so when you try and backup that area under program files your data is not actually saved.

Your data will actually be stored under “C:\Users%username%\AppData\Local\VirtualStore\Program Files\WeatherLink”

If you paste the above line including quotes into the start menu “Start Search” box it should take you to the folder.


Gtstricky I would call Davis support and see if they have a fix. The problem is the Davis USB logger gets changed when to choose USB. They were working on a fix. The program that changes the logger back to serial with com ports does not work. I ask to swap data logger and they did (USB) I removed 5.8 and installed 5.7 every thing is working OK. Joe

I see that the updated utility to reset the USB logger for compatibility with the virtual COM port driver is now posted on the Davis site at:

This particular bug is hopefully now squashed.

thats good news
re the vista thing, make sure to run weatherlink as administrator…

I am completely confused, just upgraded from LA CROSSE to VANTAGEPRO2 and trying to resume the WD & WDL.
My weatherlink is USB, it works fine with the Davis 5.80 program (comport defined as USB), what shall I do in the WD Comport number setup (how can I know what Comport number has windows assigned ?) Can someone explain it to me as I got lost with the advices in the forum, is there a simple and step by step solution ?
shall I try it with the 5.7.1 version ? please…
[email protected]