Weather Display doesn't want to start, after computer hard shutdown

Yesterday, we have been hit by heavy rain and thunderstorms. The village power went down and apparently my UPS didn’t shutdown the computer in a clean way before battery exhaustion.
Now WD doesn’t start and is shut down bt windows with errors. See post.
I reinstall a previous version, I double clicked the reg file and extracted the backup zip file and overwrote the files.
Any ideas?
Thank you.



Have you tried disconnecting your weather station from the machine and then try and launch WD? Just guessing at possibilities here. Also if you have a 1-wire network disconnecting that as well…


Thanks for the advice.
As I am away from home until after tomorrow, I 'll try that when back. In fact I have a 1 wire system with drivers only installed but so far I don’t use any sensor yet.
I’ll let you know. :wink:

try running the debug version, to see if they gives more usefull info
also try deleting the datafiles latest.inf,, graphdata2.inf,graphdata3.inf
then restart

I would look closely at your 1-Wire if it’s feeding WD.
I had a close strike last year that took out my AAG anemometer, and USB adaptor on the 1-Wire. Before I knew there was a problem with these two, I couldn’t get WD to fire up. When I disconnected the 1-Wire adaptor it worked fine (but I only found this after reinstalling WD #-o) but connecting the adaptor again cause WD to freeze.

I disconnected the wx station and the 1-wire interface, restarted and still th eproblem.
I erased all the *.inf file in wdisplay default directory and the latest.inf,, graphdata2.inf,graphdata3.inf as suggested by Brian and all is up and running.
Thanks all. :slight_smile: