WDMysql

I’ve had trouble ever since the new version of wdmysql came out… the problem seems to be a timeout of some sort? The machine that is connected to the weather station sends it’s data to a mysql database that is at another site… and frequently, as in at least once a day, the wdmysql.exe application reports ‘Mysql has gone away’… it hasn’t in reality… and by disconnecting and reconnecting the app it re-connects and all is well for a few hours…

Would it be possible to increase the timeout for this insert, or perhaps put in some sort of retry if there is an error or timeout?

Thanks!

Similar error here, it seems WDMYSQL (ver 10.3) does not try to reconnect:

Lost connection to MySQL server during query
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away
MySQL server has gone away

A manual disconnection and reconnection starts again adding data. But not always, sometimes I get this other error:

ERROR: Access violation at address 1001FBA7 in module ‘libmysql.dll’. Write of address 00000000 at time/date 14:08:12 14/10/2011
ERROR: Access violation at address 1001FBA7 in module ‘libmysql.dll’. Write of address 00000000 at time/date 14:08:33 14/10/2011
ERROR: Access violation at address 1001FBA7 in module ‘libmysql.dll’. Write of address 00000000 at time/date 14:08:36 14/10/2011
ERROR: Access violation at address 1001FBA7 in module ‘libmysql.dll’. Write of address 00000000 at time/date 14:08:39 14/10/2011

you would need to restart instead of a manual disconnect/reconnect via the program,to avoid that error

I could see if I could check for that server gone away error and then the program will restart

Breitling, do you use a local or remote mysql server?

It’s a remote server.

try vers 10.4
http://www.weather-display.com/downloadfiles/wdmysql.zip

Same problem Brian. It worked fine for some hours but finally reapeared the error message.

so it did not pick up on that error message and then restart…

No, it keeps the “Mysql server has gone away” message.

Did this get resolved yet? I’ve waited to upgrade until I hear positive information… Should I try 10.4 as well, or is there a 10.5 about to come out for testing?

its school holidays here

your patience is appreciated

a solution might be to add option to log in and out each update
I will add that tomorrow…

try
use the login each time
option
in this vers 10.4 update
http://www.weather-display.com/downloadfiles/wdmysql.zip

Testing now. Anyway ver 10.4 seemed to be a lot more stable, 2-3 days between failures.

Btw… any chance to add the option to hide the app into the task bar when minimized?

right mouse click on the icon in the system tray and select hide

is it working OK now using the re login option?
(I presume no news is good news)

Never knew that, something so simple that i missed, i used to just put up with them in the task bar!
haha thanks Brian!

Still testing. It connects again if database has gone away, but I suffered a couple freezings on wdmysql. Let me test some days more.

strange that I do not have any other reports of freeze up or similar

That’s why I want to test and observe some more, to avoid giving you extra work.